aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2013-11-20 07:08:44 +0800
committermat <mat@FreeBSD.org>2013-11-20 07:08:44 +0800
commit57524a11df3f0950e857f0ffa06d8a160baa9437 (patch)
treeab8d23ab014eb4477219665648225ccea56d0295 /games
parent869dfb43fab6a3f2a51d1ab26c1b8cd6cf6e4a7a (diff)
downloadfreebsd-ports-gnome-57524a11df3f0950e857f0ffa06d8a160baa9437.tar.gz
freebsd-ports-gnome-57524a11df3f0950e857f0ffa06d8a160baa9437.tar.zst
freebsd-ports-gnome-57524a11df3f0950e857f0ffa06d8a160baa9437.zip
- Convert to dos2unix.mk
- While at it convert to gmake.mk ports that still USE_GMAKE.
Diffstat (limited to 'games')
-rw-r--r--games/cre/Makefile3
-rw-r--r--games/evq3/Makefile3
-rw-r--r--games/exhaust-ma/Makefile4
-rw-r--r--games/fteqw/Makefile3
-rw-r--r--games/galaxyhack/Makefile3
-rw-r--r--games/lwjgl/Makefile2
-rw-r--r--games/nehquake/Makefile3
-rw-r--r--games/odamex/Makefile4
-rw-r--r--games/ppracer/Makefile3
-rw-r--r--games/q3cellshading/Makefile3
-rw-r--r--games/quake-reaper/Makefile3
-rw-r--r--games/sampsvr/Makefile3
-rw-r--r--games/species/Makefile3
-rw-r--r--games/tenebrae/Makefile3
-rw-r--r--games/xevil/Makefile3
15 files changed, 20 insertions, 26 deletions
diff --git a/games/cre/Makefile b/games/cre/Makefile
index 61a7842860a0..b4ec5481269a 100644
--- a/games/cre/Makefile
+++ b/games/cre/Makefile
@@ -13,7 +13,8 @@ COMMENT= Corewars Redcode Evolver
LICENSE= GPLv2
-USE_DOS2UNIX= *.txt
+USES= dos2unix
+DOS2UNIX_FILES= *.txt
NO_WRKSUBDIR= yes
BUILD_WRKSRC= ${WRKSRC}/src
diff --git a/games/evq3/Makefile b/games/evq3/Makefile
index 30452525a967..611a6ae646bb 100644
--- a/games/evq3/Makefile
+++ b/games/evq3/Makefile
@@ -16,9 +16,8 @@ COMMENT= The Marriage of XreaL and Icculus.org Q3 w/ Improvements
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
+USES= gmake dos2unix
USE_BZIP2= yes
-USE_DOS2UNIX= yes
-USE_GMAKE= yes
ALL_TARGET= release
WRKSRC= ${WRKDIR}/${PORTNAME}
CFLAGS+= -DMAP_ANONYMOUS=MAP_ANON
diff --git a/games/exhaust-ma/Makefile b/games/exhaust-ma/Makefile
index 60dd9e1f7a3a..2e7be1a308cf 100644
--- a/games/exhaust-ma/Makefile
+++ b/games/exhaust-ma/Makefile
@@ -11,12 +11,10 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Redcode simulator easy to embed into applications
USE_ZIP= yes
-USES= gmake
+USES= gmake dos2unix
NO_WRKSUBDIR= yes
-USE_DOS2UNIX= yes
-
PLIST_FILES= bin/${PORTNAME}
do-install:
diff --git a/games/fteqw/Makefile b/games/fteqw/Makefile
index 2ca2c1b84dd3..8f01e2bf88f9 100644
--- a/games/fteqw/Makefile
+++ b/games/fteqw/Makefile
@@ -11,8 +11,7 @@ DISTNAME= ftesrc${PORTVERSION}-all
MAINTAINER= ports@FreeBSD.org
COMMENT= QuakeWorld client with cool features, but still compatible
-USE_DOS2UNIX= yes
-USE_GMAKE= yes
+USES= gmake dos2unix
USE_CSTD= gnu89
NO_WRKSUBDIR= yes
diff --git a/games/galaxyhack/Makefile b/games/galaxyhack/Makefile
index 9ffea71b8724..9b28f4911a79 100644
--- a/games/galaxyhack/Makefile
+++ b/games/galaxyhack/Makefile
@@ -15,9 +15,8 @@ COMMENT= AI script based strategy game
LIB_DEPENDS= boost_filesystem:${PORTSDIR}/devel/boost-libs \
freetype.9:${PORTSDIR}/print/freetype2
+USES= dos2unix gmake
USE_BZIP2= yes
-USE_DOS2UNIX= yes
-USE_GMAKE= yes
USE_SDL= gfx image mixer sdl
WRKSRC= ${WRKDIR}/${PORTNAME}/src
diff --git a/games/lwjgl/Makefile b/games/lwjgl/Makefile
index 84658399803c..abbaeef7a0fd 100644
--- a/games/lwjgl/Makefile
+++ b/games/lwjgl/Makefile
@@ -22,10 +22,10 @@ ONLY_FOR_ARCHS= i386 amd64
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
EXTRACT_AFTER_ARGS= -d ${WRKSRC}
+USES= dos2unix
USE_ZIP= yes
USE_JAVA= yes
USE_LDCONFIG= yes
-USE_DOS2UNIX= yes
DOS2UNIX_REGEX= .*.[^j][^a][^r]$
JAVA_VERSION= 1.6+
JAVA_OS= native
diff --git a/games/nehquake/Makefile b/games/nehquake/Makefile
index b93ce1e3c533..0a303f04f6e5 100644
--- a/games/nehquake/Makefile
+++ b/games/nehquake/Makefile
@@ -12,11 +12,10 @@ DISTNAME= NehQuake-bjp-bin-src.linux
MAINTAINER= ports@FreeBSD.org
COMMENT= Quake engine designed for playing Nehahra
+USES= gmake dos2unix
USE_BZIP2= yes
-USE_DOS2UNIX= yes
USE_GL= gl
USE_XORG= xxf86dga
-USE_GMAKE= yes
OPTIONS_DEFINE= OPTIMIZED_CFLAGS SDL X86_ASM
OPTIONS_DEFAULT= OPTIMIZED_CFLAGS SDL X86_ASM
diff --git a/games/odamex/Makefile b/games/odamex/Makefile
index ad4248cb806d..cdfbc660e8a5 100644
--- a/games/odamex/Makefile
+++ b/games/odamex/Makefile
@@ -12,8 +12,8 @@ COMMENT= Standard in Online Multiplayer Doom
USE_BZIP2= yes
USE_SDL= sdl mixer
-USES= cmake
-USE_DOS2UNIX= CMakeLists.txt odalaunch/CMakeLists.txt common/d_main.cpp
+USES= cmake dos2unix
+DOS2UNIX_FILES= CMakeLists.txt odalaunch/CMakeLists.txt common/d_main.cpp
OPTIONS_DEFINE= LAUNCHER
diff --git a/games/ppracer/Makefile b/games/ppracer/Makefile
index 3c09488d4bdc..b6a44ffb46ca 100644
--- a/games/ppracer/Makefile
+++ b/games/ppracer/Makefile
@@ -14,11 +14,10 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
freetype:${PORTSDIR}/print/freetype2
USE_BZIP2= yes
-USES= gmake pkgconfig
+USES= gmake pkgconfig dos2unix
USE_SDL= mixer sdl
USE_GL= gl
GNU_CONFIGURE= yes
-USE_DOS2UNIX= yes
DOS2UNIX_REGEX= .*\.(c|cpp|h)
USE_XORG= x11 xi xext xmu xt
diff --git a/games/q3cellshading/Makefile b/games/q3cellshading/Makefile
index a5b7d95d89f6..302f4db76d38 100644
--- a/games/q3cellshading/Makefile
+++ b/games/q3cellshading/Makefile
@@ -14,9 +14,8 @@ COMMENT= Quake III engine with Cell Shading capabilities
ONLY_FOR_ARCHS= i386
ONLY_FOR_ARCHS_REASON= does not run properly; try games/ioquake3 with option
-USES= gmake
+USES= gmake dos2unix
USE_ZIP= yes
-USE_DOS2UNIX= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
BUILD_WRKSRC= ${WRKSRC}/code/unix
diff --git a/games/quake-reaper/Makefile b/games/quake-reaper/Makefile
index 30519665a1e9..dce82503bb6d 100644
--- a/games/quake-reaper/Makefile
+++ b/games/quake-reaper/Makefile
@@ -11,8 +11,9 @@ DISTNAME= reaprb81
MAINTAINER= ports@FreeBSD.org
COMMENT= Quake 1 bots
+USES= dos2unix
USE_ZIP= yes
-USE_DOS2UNIX= ${PORTDOCS}
+DOS2UNIX_GLOB= ${PORTDOCS}
NO_BUILD= yes
NO_WRKSUBDIR= yes
diff --git a/games/sampsvr/Makefile b/games/sampsvr/Makefile
index 7c906e2e6a91..3b2ca1fff633 100644
--- a/games/sampsvr/Makefile
+++ b/games/sampsvr/Makefile
@@ -10,10 +10,11 @@ DISTNAME= samp${PORTVERSION:S,.,,}svr
MAINTAINER= ports@FreeBSD.org
COMMENT= Rockstar's GTA: San Andreas multiplayer modification dedicated server
+USES= dos2unix
USE_LINUX= yes
NO_BUILD= yes
WRKSRC= ${WRKDIR}/samp03
-USE_DOS2UNIX= *.txt *.pwn *.inc
+DOS2UNIX_GLOB= *.txt *.pwn *.inc
USE_RC_SUBR= sampd
SAMPDIR= ${PREFIX}/libexec/${PORTNAME}
PORTDOCS= LICENSE README
diff --git a/games/species/Makefile b/games/species/Makefile
index a06bcb8a0ec8..b99743456699 100644
--- a/games/species/Makefile
+++ b/games/species/Makefile
@@ -11,9 +11,8 @@ DISTNAME= redcoder
MAINTAINER= ports@FreeBSD.org
COMMENT= Corewars evolver - generates warriors using genetic algorithms
-USE_DOS2UNIX= yes
USE_BZIP2= yes
-USES= gmake
+USES= gmake dos2unix
WRKSRC= ${WRKDIR}/${PORTNAME}
OPTIONS_DEFINE= VISITOOL
diff --git a/games/tenebrae/Makefile b/games/tenebrae/Makefile
index 333dbf6163f6..3ead34bbe0db 100644
--- a/games/tenebrae/Makefile
+++ b/games/tenebrae/Makefile
@@ -14,9 +14,8 @@ COMMENT= Quake engine with lighting similar to that in Doom III
LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
-USES= gmake
+USES= gmake dos2unix
USE_ZIP= yes
-USE_DOS2UNIX= yes
USE_GL= glu
USE_SDL= yes
USE_XORG= xxf86dga
diff --git a/games/xevil/Makefile b/games/xevil/Makefile
index 85baf9464796..7558ea85ecd0 100644
--- a/games/xevil/Makefile
+++ b/games/xevil/Makefile
@@ -18,9 +18,10 @@ OPTIONS_DEFINE= DOCS
NO_WRKSUBDIR=yes
+USES= dos2unix
USE_ZIP= yes
USE_XORG= xpm
-USE_DOS2UNIX= *.cpp *.h config.mk makefile
+DOS2UNIX_GLOB= *.cpp *.h config.mk makefile
MAKEFILE= makefile
MAKE_ARGS= DEPTH="${WRKSRC}"
ALL_TARGET= ${OPSYS:L}