aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2008-09-23 10:27:18 +0800
committerbeech <beech@FreeBSD.org>2008-09-23 10:27:18 +0800
commit5865dab63c004a1044cf70f70414dba6e13e3423 (patch)
tree2308eef677f85df5a9cc0137879dbe0c7d58d7e2 /games
parent61e82d7f6d358adfe28093482f077d56b72ffee9 (diff)
downloadfreebsd-ports-gnome-5865dab63c004a1044cf70f70414dba6e13e3423.tar.gz
freebsd-ports-gnome-5865dab63c004a1044cf70f70414dba6e13e3423.tar.zst
freebsd-ports-gnome-5865dab63c004a1044cf70f70414dba6e13e3423.zip
Update to 3.5
PR: ports/127128 Submitted by: Artem Naluzhnyy <tut@nhamon.com.ua> Approved by: Guido Falsi <mad@madpilot.net> (maintainer)
Diffstat (limited to 'games')
-rw-r--r--games/traindirector/Makefile32
-rw-r--r--games/traindirector/distinfo6
-rw-r--r--games/traindirector/files/patch-Makefile24
-rw-r--r--games/traindirector/files/patch-Makefile.fc932
-rw-r--r--games/traindirector/files/patch-setup_trdir.sh65
-rw-r--r--games/traindirector/pkg-plist19
6 files changed, 53 insertions, 125 deletions
diff --git a/games/traindirector/Makefile b/games/traindirector/Makefile
index 86c903d9bc9f..07d1736a8a0e 100644
--- a/games/traindirector/Makefile
+++ b/games/traindirector/Makefile
@@ -6,28 +6,32 @@
#
PORTNAME= traindirector
-PORTVERSION= 1.19c
-PORTREVISION= 4
+PORTVERSION= 3.5
CATEGORIES= games
-MASTER_SITES= http://xtsl.free.fr/119c/
-DISTNAME= traindir-${PORTVERSION}-src
+MASTER_SITES= http://www.backerstreet.com/traindir/
+DISTNAME= tdir35src
MAINTAINER= mad@madpilot.net
COMMENT= Train controller simulation
-WRKSRC= ${WRKDIR}/traindir-${PORTVERSION}
+NO_WRKSUBDIR= yes
USE_GMAKE= yes
-USE_GNOME= gtk12
-USE_BZIP2= yes
+USE_GNOME= gtk20
+USE_ZIP= yes
-post-extract:
-.for file in Makefile field.c loadsave.c run.c setup_trdir.sh tgraph.c track.c track1.c trsim.c
- @${TR} -d '\015' < ${WRKSRC}/${file} > ${WRKDIR}/xxxx
- @${MV} ${WRKDIR}/xxxx ${WRKSRC}/${file}
-.endfor
+USE_WX= 2.8
+WX_COMPS= wx
+WX_UNICODE= yes
-post-patch:
- ${REINPLACE_CMD} -e 's#PREFIX#${PREFIX}#' ${WRKSRC}/setup_trdir.sh
+DESKTOP_ENTRIES="Train Director" "${COMMENT}" "" "traindir3" \
+ "Game;Simulation;StrategyGame;" false
+
+PLIST_FILES= bin/traindir3
+
+MAKEFILE= Makefile.fc9
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKDIR}/traindir3 ${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/games/traindirector/distinfo b/games/traindirector/distinfo
index aa754fd3c572..ed374ce87644 100644
--- a/games/traindirector/distinfo
+++ b/games/traindirector/distinfo
@@ -1,3 +1,3 @@
-MD5 (traindir-1.19c-src.tar.bz2) = e6b0ee6fa10c155894db695f757a4b21
-SHA256 (traindir-1.19c-src.tar.bz2) = f803061fc1870773cd615f519aec4849bc4e84101a8334ad589149fc17fb470b
-SIZE (traindir-1.19c-src.tar.bz2) = 112924
+MD5 (tdir35src.zip) = d51bfcc8dafae019cfa45e27863221e3
+SHA256 (tdir35src.zip) = 5819c6855cfa97b4ce6142a82bc7af9d0377b0071a73e4130c052763e07b43e3
+SIZE (tdir35src.zip) = 236651
diff --git a/games/traindirector/files/patch-Makefile b/games/traindirector/files/patch-Makefile
deleted file mode 100644
index 91052c00b16b..000000000000
--- a/games/traindirector/files/patch-Makefile
+++ /dev/null
@@ -1,24 +0,0 @@
---- Makefile.orig Sat Dec 13 02:34:25 2003
-+++ Makefile Sat Dec 13 02:33:16 2003
-@@ -7,15 +7,15 @@
-
- VERSION=1.18l
-
--BINDIR=/usr/local/bin
--SAMPLEDIR=/usr/local/share
-+BINDIR=$(PREFIX)/bin
-+SAMPLEDIR=$(PREFIX)/share
-
- INSTALL = install
-
--GTKINC=`gtk-config --cflags`
--GTKLIB=`gtk-config --libs`
--GLIBINC=`glib-config --cflags`
--GLIBLIB=`glib-config --libs`
-+GTKINC=`gtk12-config --cflags`
-+GTKLIB=`gtk12-config --libs`
-+GLIBINC=`glib12-config --cflags`
-+GLIBLIB=`glib12-config --libs`
-
- CFLAGS += -g $(GLIBINC) $(GTKINC) #-static
-
diff --git a/games/traindirector/files/patch-Makefile.fc9 b/games/traindirector/files/patch-Makefile.fc9
new file mode 100644
index 000000000000..182d3bc90351
--- /dev/null
+++ b/games/traindirector/files/patch-Makefile.fc9
@@ -0,0 +1,32 @@
+--- Makefile.fc9.orig 2008-08-31 18:53:10.000000000 +0300
++++ Makefile.fc9 2008-09-07 04:07:22.000000000 +0300
+@@ -20,16 +20,16 @@
+ LDFLAGS_GUI =
+ CXX = g++
+ #CXXFLAGS = -g -O0 -pthread -Wall -Wundef -Wno-ctor-dtor-privacy -finput-charset=ISO-8859-1
+-CXXFLAGS = -O2 -pthread -Wall -Wundef -Wno-ctor-dtor-privacy -finput-charset=ISO-8859-1
++CXXFLAGS += -pthread -Wall -Wundef -Wno-ctor-dtor-privacy
+ #CPPFLAGS = -D__WXDEBUG__ -DGTK_NO_CHECK_CASTS -pthread -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D_LARGEFILE_SOURCE=1 -DwxUSE_UNICODE=1 -I.
+-CPPFLAGS = -DGTK_NO_CHECK_CASTS -pthread -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D_LARGEFILE_SOURCE=1 -DwxUSE_UNICODE=1 -I. -I/usr/include/wx-2.8 -I/usr/lib/wx/include/gtk2-unicode-release-2.8
++CPPFLAGS += -DGTK_NO_CHECK_CASTS -pthread -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D_LARGEFILE_SOURCE=1 -DwxUSE_UNICODE=1 -I. -I/usr/local/include/wx-2.8 -I/usr/local/lib/wx/include/gtk2-unicode-release-2.8
+ LDFLAGS = -pthread -L/usr/X11R6/lib
+ WX_LIB_FLAVOUR =
+ TOOLKIT = GTK
+ TOOLKIT_LOWERCASE = gtk
+ TOOLKIT_VERSION = 2
+-EXTRALIBS = -pthread -L/usr/X11R6/lib -lz -ldl -lm
+-EXTRALIBS_GUI = -Wl,--export-dynamic -pthread -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangoxft-1.0 -lpangox-1.0 -lpango-1.0 -lgobject-2.0 -lgmodule-2.0 -ldl -lgthread-2.0 -lglib-2.0 -lXinerama -lXxf86vm -lpng -lz -ljpeg -ltiff
++EXTRALIBS = -pthread -L/usr/X11R6/lib -lz -lm
++EXTRALIBS_GUI = -Wl,--export-dynamic -pthread -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangoxft-1.0 -lpangox-1.0 -lpango-1.0 -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lglib-2.0 -lXinerama -lXxf86vm -lpng -lz -ljpeg -ltiff
+ EXTRALIBS_SDL =
+ HOST_SUFFIX =
+ SAMPLES_RPATH_FLAG = -Wl,-rpath,$(top_builddir)lib
+@@ -38,7 +38,7 @@
+ ### Variables: ###
+
+ DESTDIR =
+-OBJDIR = objs/
++OBJDIR =
+ WX_RELEASE = 2.8
+ WX_VERSION = $(WX_RELEASE).4
+ LIBDIRNAME = $(top_builddir)lib
diff --git a/games/traindirector/files/patch-setup_trdir.sh b/games/traindirector/files/patch-setup_trdir.sh
deleted file mode 100644
index 6d37266e882b..000000000000
--- a/games/traindirector/files/patch-setup_trdir.sh
+++ /dev/null
@@ -1,65 +0,0 @@
---- setup_trdir.sh.orig Tue Jan 25 13:44:55 2005
-+++ setup_trdir.sh Tue Jan 25 13:45:30 2005
-@@ -6,9 +6,9 @@
- # edit the folowing line
- #
- # This is the place where traindirector is installed
--TRAINDIR="/usr/local/bin"
-+TRAINDIR="PREFIX/bin"
- # This is the place where samples file is installed
--SAMPLE="/usr/local/share"
-+SAMPLE="PREFIX/share"
- ##################################################################"
- echo "*********************************"
- echo "* Traindirector Installation *"
-@@ -16,7 +16,7 @@
- echo
- echo "Making traindir samples directory....."
- echo
--TDHOMEDIR="$HOME/traindir"
-+TDHOMEDIR="$HOME/.traindir"
- ICONDIR="$TDHOMEDIR/tdicons"
- LOCALEDIR="$TDHOMEDIR/locales"
- if ! test -d $TDHOMEDIR ; then
-@@ -38,7 +38,7 @@
-
- case $CHOIX in
- "2") FLNAME=".traindir.it"
-- echo " Avette schelto Italiano"
-+ echo "Avete scelto l'italiano"
- STRING='locale .it';;
-
- "3") FLNAME=".traindir.fr"
-@@ -56,12 +56,10 @@
- if ! test -d $HOME/.traindir ; then
- mkdir $HOME/.traindir
- fi
-- echo $STRING > $HOME/.traindir/.traindir.ini
-- cp -f $SAMPLE/traindir/locales/$FLNAME $HOME/.traindir/
--
--cp -f $SAMPLE/traindir/* $TDHOMEDIR
--cp -f $SAMPLE/traindir/tdicons/*.* $ICONDIR
-+echo $STRING > $HOME/.traindir/.traindir.ini
-+cp -f -R $SAMPLE/traindir/locales/$FLNAME $HOME/.traindir/
-
-+cp -f -R $SAMPLE/traindir/* $TDHOMEDIR
-
- echo
- echo "Creating startup script......"
-@@ -69,12 +67,13 @@
- echo "#!/bin/sh" > $HOME/traindir.sh
- echo "# Startup file for traindirector" >> $HOME/traindir.sh
- echo "#" >> $HOME/traindir.sh
--echo "TDHOME=\"$HOME/traindir\"" >> $HOME/traindir.sh
-+echo "TDHOME=\"$HOME/.traindir\"" >> $HOME/traindir.sh
- echo "export TDHOME" >> $HOME/traindir.sh
- echo "echo starting Traindirector" >> $HOME/traindir.sh
- echo "$TRAINDIR/traindir" >> $HOME/traindir.sh
-
- chmod 0775 $HOME/traindir.sh
- echo "Installation complete"
--echo "You can run ~/traindir.sh from a X console"
--
-+echo "a script file 'traindir.sh' has been created in the current"
-+echo "directory. You can launch it to start the simulation, or move it"
-+echo "to your user's bin directory if you want."
diff --git a/games/traindirector/pkg-plist b/games/traindirector/pkg-plist
deleted file mode 100644
index 7a53d38e88b9..000000000000
--- a/games/traindirector/pkg-plist
+++ /dev/null
@@ -1,19 +0,0 @@
-bin/traindir
-bin/gentt
-bin/setup_trdir.sh
-share/traindir/default.sch
-share/traindir/default.trk
-share/traindir/demoitin.trk
-share/traindir/southst.trk
-share/traindir/tdirico1.ico
-share/traindir/tdirico2.ico
-share/traindir/train.ico
-share/traindir/tdicons/bridgeup.xpm
-share/traindir/tdicons/bridgedn.xpm
-share/traindir/tdicons/triangl.xpm
-share/traindir/locales/.traindir.it
-share/traindir/locales/.traindir.fr
-share/traindir/locales/README
-@dirrm share/traindir/tdicons
-@dirrm share/traindir/locales
-@dirrm share/traindir