aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2010-04-28 05:58:27 +0800
committergahr <gahr@FreeBSD.org>2010-04-28 05:58:27 +0800
commit5a71031394b0a0b65d9d5aece3362619c2d1169f (patch)
treeabb9c1dc1cedf9be9c56cba34f1ca9ae07bd6108 /games
parent2b15c1b3a344354d1bb987c4199ab8c4e1cb3c88 (diff)
downloadfreebsd-ports-gnome-5a71031394b0a0b65d9d5aece3362619c2d1169f.tar.gz
freebsd-ports-gnome-5a71031394b0a0b65d9d5aece3362619c2d1169f.tar.zst
freebsd-ports-gnome-5a71031394b0a0b65d9d5aece3362619c2d1169f.zip
- Add glew to the list of supported USE_GL variables
- Patch ports depending on GLEW directly Approved by: portmgr (pav)
Diffstat (limited to 'games')
-rw-r--r--games/balazar/Makefile3
-rw-r--r--games/balazarbrothers/Makefile3
-rw-r--r--games/slune/Makefile5
-rw-r--r--games/spring/Makefile3
-rw-r--r--games/tnl/Makefile5
-rw-r--r--games/vdrift/Makefile5
-rw-r--r--games/windstille/Makefile3
7 files changed, 10 insertions, 17 deletions
diff --git a/games/balazar/Makefile b/games/balazar/Makefile
index 65c4b47c970d..cfe4d925e3a1 100644
--- a/games/balazar/Makefile
+++ b/games/balazar/Makefile
@@ -16,7 +16,6 @@ MAINTAINER= acm@FreeBSD.org
COMMENT= 3D adventure and roleplaying game
LIB_DEPENDS= cal3d.12:${PORTSDIR}/graphics/cal3d \
- GLEW.1:${PORTSDIR}/graphics/glew \
freetype.9:${PORTSDIR}/print/freetype2
RUN_DEPENDS= soya_editor:${PORTSDIR}/graphics/py-soya3d \
${PYTHON_SITELIBDIR}/_openal.so:${PORTSDIR}/audio/py-openal \
@@ -28,7 +27,7 @@ USE_BZIP2= yes
USE_PYTHON= yes
USE_PYDISTUTILS= yes
USE_TWISTED= yes
-USE_GL= yes
+USE_GL= glew
USE_SDL= sdl mixer
USE_GETTEXT= yes
diff --git a/games/balazarbrothers/Makefile b/games/balazarbrothers/Makefile
index 056abaf8a774..4e01e97fc180 100644
--- a/games/balazarbrothers/Makefile
+++ b/games/balazarbrothers/Makefile
@@ -16,7 +16,6 @@ MAINTAINER= acm@FreeBSD.org
COMMENT= Balazar Brother is a free software 3D puzzle game
LIB_DEPENDS= cal3d.12:${PORTSDIR}/graphics/cal3d \
- GLEW.1:${PORTSDIR}/graphics/glew \
freetype.9:${PORTSDIR}/print/freetype2
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/cerealizer/__init__.py:${PORTSDIR}/security/py-cerealizer \
${PYTHON_SITELIBDIR}/soya/__init__.py:${PORTSDIR}/graphics/py-soya3d \
@@ -28,7 +27,7 @@ USE_GETTEXT= yes
USE_PYTHON= yes
USE_PYDISTUTILS=yes
USE_TWISTED= yes
-USE_GL= yes
+USE_GL= glew
USE_GMAKE= yes
PYDISTUTILS_PKGNAME= BalazarBrothers
diff --git a/games/slune/Makefile b/games/slune/Makefile
index d0bdaac35570..42f20ffd086f 100644
--- a/games/slune/Makefile
+++ b/games/slune/Makefile
@@ -19,15 +19,14 @@ RUN_DEPENDS= soya_editor:${PORTSDIR}/graphics/py-soya3d \
${PYTHON_SITELIBDIR}/_openal.so:${PORTSDIR}/audio/py-openal \
${PYTHON_SITELIBDIR}/ogg/vorbis.so:${PORTSDIR}/audio/py-vorbis \
${PYTHON_SITELIBDIR}/py2play/level.py:${PORTSDIR}/net-p2p/py-py2play
-LIB_DEPENDS= cal3d.12:${PORTSDIR}/graphics/cal3d \
- GLEW.1:${PORTSDIR}/graphics/glew
+LIB_DEPENDS= cal3d.12:${PORTSDIR}/graphics/cal3d
USE_BZIP2= yes
USE_DOS2UNIX= *.po *.mo
USE_GETTEXT= yes
USE_PYTHON= yes
USE_PYDISTUTILS= yes
-USE_GL= yes
+USE_GL= glew
USE_SDL= sdl mixer
PYDISTUTILS_PKGNAME= Slune
diff --git a/games/spring/Makefile b/games/spring/Makefile
index 9610921900c9..8db664234fa7 100644
--- a/games/spring/Makefile
+++ b/games/spring/Makefile
@@ -15,7 +15,6 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= A project aiming to create a new and versatile RTS Engine
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
- GLEW.1:${PORTSDIR}/graphics/glew \
boost_thread.4:${PORTSDIR}/devel/boost-libs \
IL.2:${PORTSDIR}/graphics/devil \
ogg.6:${PORTSDIR}/audio/libogg \
@@ -28,7 +27,7 @@ ONLY_FOR_ARCHS_REASON= relies on x86 floating-point math
USE_SDL= sdl
USE_OPENAL= al
-USE_GL= gl glu
+USE_GL= glew
USE_XORG= x11 xcursor
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
diff --git a/games/tnl/Makefile b/games/tnl/Makefile
index 85c819050f46..f6334e44f00b 100644
--- a/games/tnl/Makefile
+++ b/games/tnl/Makefile
@@ -22,15 +22,14 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libiovmall.so:${PORTSDIR}/lang/io
RUN_DEPENDS= ${BUILD_DEPENDS}
LIB_DEPENDS= sigc-1.2.5:${PORTSDIR}/devel/libsigc++12 \
CEGUIBase.3:${PORTSDIR}/graphics/cegui \
- png.6:${PORTSDIR}/graphics/png \
- GLEW.1:${PORTSDIR}/graphics/glew
+ png.6:${PORTSDIR}/graphics/png
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_SDL= sdl
USE_GCC= 4.2+
-USE_GL= yes
+USE_GL= glew
USE_OPENAL= al alut
CONFIGURE_ARGS= --with-io-cflags="-I${LOCALBASE}/include/io" \
diff --git a/games/vdrift/Makefile b/games/vdrift/Makefile
index cd4f28991bfb..497853d67e84 100644
--- a/games/vdrift/Makefile
+++ b/games/vdrift/Makefile
@@ -18,12 +18,11 @@ COMMENT= Open source driving simulation
BUILD_DEPENDS= scons:${PORTSDIR}/devel/scons \
${LOCALBASE}/lib/libbulletcollision.a:${PORTSDIR}/devel/bullet
-LIB_DEPENDS= vorbis.4:${PORTSDIR}/audio/libvorbis \
- GLEW:${PORTSDIR}/graphics/glew
+LIB_DEPENDS= vorbis.4:${PORTSDIR}/audio/libvorbis
RUN_DEPENDS= ${LOCALBASE}/share/${PORTNAME}/settings/VDrift.config:${PORTSDIR}/games/vdrift-data
USE_BZIP2= yes
-USE_GL= yes
+USE_GL= glew
USE_SDL= sdl image net gfx
SCONS_ARGS= prefix=${PREFIX} \
diff --git a/games/windstille/Makefile b/games/windstille/Makefile
index 66af20dffd5e..8d4f3b0c0530 100644
--- a/games/windstille/Makefile
+++ b/games/windstille/Makefile
@@ -18,7 +18,6 @@ LIB_DEPENDS= physfs.1:${PORTSDIR}/devel/physfs \
ogg.6:${PORTSDIR}/audio/libogg \
vorbis.4:${PORTSDIR}/audio/libvorbis \
png.6:${PORTSDIR}/graphics/png \
- GLEW.1:${PORTSDIR}/graphics/glew \
squirrel.0:${PORTSDIR}/lang/squirrel \
freetype.9:${PORTSDIR}/print/freetype2
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
@@ -26,7 +25,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost
USE_BZIP2= yes
USE_SCONS= yes
USE_OPENAL= al
-USE_GL= gl
+USE_GL= glew
USE_SDL= sdl image
USE_BISON= build
MAKE_JOBS_SAFE= yes