aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2013-07-17 08:09:16 +0800
committerrene <rene@FreeBSD.org>2013-07-17 08:09:16 +0800
commit5b0e8c8a6575648082a9f1008117099d1dca2820 (patch)
tree7f16465f2a1dc739d378ac84930af7bee99aa6b6 /games
parentce66f8e2447a715b162c6da702d3df87e8827772 (diff)
downloadfreebsd-ports-gnome-5b0e8c8a6575648082a9f1008117099d1dca2820.tar.gz
freebsd-ports-gnome-5b0e8c8a6575648082a9f1008117099d1dca2820.tar.zst
freebsd-ports-gnome-5b0e8c8a6575648082a9f1008117099d1dca2820.zip
- Fix fallout from shebangfix conversion
- Remove two patches which are believed to be obsolete with new freeglut
Diffstat (limited to 'games')
-rw-r--r--games/torcs/Makefile9
-rw-r--r--games/torcs/files/patch-src__libs__confscreens__Makefile11
-rw-r--r--games/torcs/files/patch-src__libs__tgfclient__Makefile11
3 files changed, 9 insertions, 22 deletions
diff --git a/games/torcs/Makefile b/games/torcs/Makefile
index cbd855ca719d..052c56c2a7be 100644
--- a/games/torcs/Makefile
+++ b/games/torcs/Makefile
@@ -44,6 +44,8 @@ INSTDIR= ${PREFIX}/share/games/${PORTNAME}
PORTDOCS= faq.html
+BASH2FIX= src/linux/torcs.in Make-default.mk
+
DESKTOP_ENTRIES= "TORCS" \
"The Open Racing Car Simulator" \
"${INSTDIR}/Ticon.png" \
@@ -57,6 +59,13 @@ OPTIONS_DEFINE= DOCS
EMPTYDIR= champ dtmrace endrace ncrace practice quickrace
+# shebangfix does not catch these two (not at top of file):
+post-patch:
+.for FILE in ${BASH2FIX}
+ @${REINPLACE_CMD} -E -e "s|/bin/bash|${LOCALBASE}/bin/bash|" \
+ ${WRKSRC}/${FILE}
+.endfor
+
pre-install:
@${MKDIR} ${PREFIX}/share/games
diff --git a/games/torcs/files/patch-src__libs__confscreens__Makefile b/games/torcs/files/patch-src__libs__confscreens__Makefile
deleted file mode 100644
index 4347c6263726..000000000000
--- a/games/torcs/files/patch-src__libs__confscreens__Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/libs/confscreens/Makefile.orig 2012-01-02 17:39:05.000000000 +0100
-+++ src/libs/confscreens/Makefile 2012-01-09 20:41:34.000000000 +0100
-@@ -28,7 +28,7 @@
- EXPORTS = confscreens.h driverconfig.h joystickconfig.h mouseconfig.h controlconfig.h graphconfig.h\
- simuconfig.h soundconfig.h openglconfig.h
-
--LIBS = -lplibjs
-+LIBS = -lplibjs -lusbhid
-
- src_PKGFILES = $(shell find * -maxdepth 0 -type f -print)
-
diff --git a/games/torcs/files/patch-src__libs__tgfclient__Makefile b/games/torcs/files/patch-src__libs__tgfclient__Makefile
deleted file mode 100644
index 997a968e6162..000000000000
--- a/games/torcs/files/patch-src__libs__tgfclient__Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/libs/tgfclient/Makefile.orig 2012-01-02 17:39:05.000000000 +0100
-+++ src/libs/tgfclient/Makefile 2012-01-09 20:46:09.000000000 +0100
-@@ -51,7 +51,7 @@
-
- CONFIG = screen.xml
-
--LIBS = -lplibjs
-+LIBS = -lplibjs -lusbhid
-
- src_PKGFILES = $(shell find * -maxdepth 0 -type f -print)
-