aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-12-24 10:31:16 +0800
committerjbeich <jbeich@FreeBSD.org>2016-12-24 10:31:16 +0800
commit5b884bec132b3fee81dbf554660ad206b07c07ed (patch)
treeb6966fdd030387c12745308836faa4cc33223353 /games
parent67d6299c98129cac6437fac0d23f26f7f8438003 (diff)
downloadfreebsd-ports-gnome-5b884bec132b3fee81dbf554660ad206b07c07ed.tar.gz
freebsd-ports-gnome-5b884bec132b3fee81dbf554660ad206b07c07ed.tar.zst
freebsd-ports-gnome-5b884bec132b3fee81dbf554660ad206b07c07ed.zip
devel/libopenbsd, games/openbor: unbreak BOOTSTRAP build
$ make clean all BOOTSTRAP= -C devel/libopenbsd ===> Cleaning for libopenbsd-r298107 ===> License ISCL accepted by the user ===> libopenbsd-r298107 depends on file: /usr/local/sbin/pkg - found ===> libopenbsd-r298107 depends on executable: svn - found /bin/mkdir -p /usr/ports/devel/libopenbsd/work svn export -r298107 https://svn.freebsd.org/base/head/lib/libopenbsd/ /usr/ports/devel/libopenbsd/work/libopenbsd-r298107 A work/libopenbsd-r298107 A work/libopenbsd-r298107/sys A work/libopenbsd-r298107/Makefile A work/libopenbsd-r298107/imsg.c A work/libopenbsd-r298107/sys/sysctl.h A work/libopenbsd-r298107/getdtablecount.c A work/libopenbsd-r298107/unistd.h A work/libopenbsd-r298107/README A work/libopenbsd-r298107/imsg-buffer.c A work/libopenbsd-r298107/imsg.h A work/libopenbsd-r298107/imsg_init.3 A work/libopenbsd-r298107/ohash.h A work/libopenbsd-r298107/Makefile.depend A work/libopenbsd-r298107/ohash_init.3 A work/libopenbsd-r298107/ohash_interval.3 A work/libopenbsd-r298107/ohash.c Exported revision 298107. (cd /usr/ports/devel/libopenbsd/work && /usr/bin/tar cJvf /usr/ports/distfiles//libopenbsd-r298107.tar.xz --uid 0 --gid 0 libopenbsd-r298107) a libopenbsd-r298107 a libopenbsd-r298107/imsg.c a libopenbsd-r298107/imsg.h a libopenbsd-r298107/imsg_init.3 a libopenbsd-r298107/ohash_init.3 a libopenbsd-r298107/Makefile.depend a libopenbsd-r298107/Makefile a libopenbsd-r298107/ohash.c a libopenbsd-r298107/ohash.h a libopenbsd-r298107/ohash_interval.3 a libopenbsd-r298107/getdtablecount.c a libopenbsd-r298107/imsg-buffer.c a libopenbsd-r298107/README a libopenbsd-r298107/unistd.h a libopenbsd-r298107/sys a libopenbsd-r298107/sys/sysctl.h /usr/bin/sed -i.bak -i '' '/^PORTVERSION=/s/r.*/r298107/' /usr/ports/devel/libopenbsd/Makefile ===> Fetching all distfiles required by libopenbsd-r298107 for building ===> Extracting for libopenbsd-r298107 => SHA256 Checksum mismatch for libopenbsd-r298107.tar.xz. ===> Refetch for 1 more times files: libopenbsd-r298107.tar.xz ===> License ISCL accepted by the user ===> libopenbsd-r298107 depends on file: /usr/local/sbin/pkg - found ===> libopenbsd-r298107 depends on executable: svn - found /bin/mkdir -p /usr/ports/devel/libopenbsd/work svn export -r298107 https://svn.freebsd.org/base/head/lib/libopenbsd/ /usr/ports/devel/libopenbsd/work/libopenbsd-r298107 svn: E155000: Destination directory exists; please remove the directory or use --force to overwrite svn: E155000: '/usr/ports/devel/libopenbsd/work/libopenbsd-r298107' already exists *** Error code 1
Diffstat (limited to 'games')
-rw-r--r--games/openbor/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/games/openbor/Makefile b/games/openbor/Makefile
index 79ff9f82b61c..c7cc65c0c901 100644
--- a/games/openbor/Makefile
+++ b/games/openbor/Makefile
@@ -69,14 +69,18 @@ SVN_REV?= ${PORTVERSION:E:S/r//}
.if defined(BOOTSTRAP) || defined(SVN_FETCH)
FETCH_DEPENDS+= svn:devel/subversion
+NO_CHECKSUM= yes
+
do-fetch:
${MKDIR} ${WRKDIR}
svn export -r${SVN_REV} ${_MASTER_SITES_svn} ${WRKSRC}
(cd ${WRKDIR} && ${TAR} cJvf \
${_DISTDIR}/${DISTNAME}${EXTRACT_SUFX} \
--uid 0 --gid 0 ${DISTNAME})
+. ifmake makesum
${REINPLACE_CMD} -i '' '/^PORTVERSION=/s/r.*/r${SVN_REV}/' \
${MASTERDIR}/Makefile
+. endif
. if ${USER} == ${MAINTAINER:C/@.*//}
-scp ${_DISTDIR}/${DISTNAME}${EXTRACT_SUFX} \
freefall.freebsd.org:public_distfiles/