aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2012-10-01 21:27:48 +0800
committergahr <gahr@FreeBSD.org>2012-10-01 21:27:48 +0800
commit5f8674be49d4863e0a4ac7c1d028bb86b0e9980b (patch)
tree503511b97d556ab51018244ca09ab64cb5e040f4 /games
parentad2145eb5bb53b6fd3283ab50d88fe2e07044fb2 (diff)
downloadfreebsd-ports-gnome-5f8674be49d4863e0a4ac7c1d028bb86b0e9980b.tar.gz
freebsd-ports-gnome-5f8674be49d4863e0a4ac7c1d028bb86b0e9980b.tar.zst
freebsd-ports-gnome-5f8674be49d4863e0a4ac7c1d028bb86b0e9980b.zip
- Convert to OptionsNG
Notified by: http://wiki.freebsd.org/Ports/Options/ConvertingToOptionsNG
Diffstat (limited to 'games')
-rw-r--r--games/atr3d/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/games/atr3d/Makefile b/games/atr3d/Makefile
index 75c7b04b3142..6108746c59da 100644
--- a/games/atr3d/Makefile
+++ b/games/atr3d/Makefile
@@ -16,7 +16,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= gahr@FreeBSD.org
COMMENT= 3D asteroids-like multiplayer game
-OPTIONS= SOUND "Enable sound" ON
+OPTIONS_DEFINE= OPENAL
+OPTIONS_DEFAULT=OPENAL
SDL_CONFIG?= ${LOCALBASE}/bin/sdl-config
@@ -27,16 +28,15 @@ USE_GL= glut glu
USE_XORG= xmu xi x11
USE_PERL5_BUILD=yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-sound
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
USE_AUTOTOOLS= automake autoconf
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_SOUND)
+.if ${PORT_OPTIONS:MOPENAL}
USE_OPENAL= alut
CONFIGURE_ARGS+= --enable-sound
.else
@@ -60,4 +60,4 @@ post-configure:
's|-lpthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/Makefile
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>