aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2013-03-18 00:54:51 +0800
committerdanfe <danfe@FreeBSD.org>2013-03-18 00:54:51 +0800
commit60575d4441476224c6d30516f73806fd2af0f5e1 (patch)
tree1ee77192df78c8fcda22ff7fe6cc79f50f3f16d8 /games
parent8c5298f90f63fc0beff01b1479c75bd11804be2d (diff)
downloadfreebsd-ports-gnome-60575d4441476224c6d30516f73806fd2af0f5e1.tar.gz
freebsd-ports-gnome-60575d4441476224c6d30516f73806fd2af0f5e1.tar.zst
freebsd-ports-gnome-60575d4441476224c6d30516f73806fd2af0f5e1.zip
- Trim old-school Makefile header per recent agreements
- Convert to modern OPTIONS framework (courtesy of jgh@) - Use more explicit "gl" or "glu" to simple "yes" in USE_GL - Drop shlib ABI versions from LIB_DEPENDS - Mute MKDIR's, generally cleanup Makefiles - Synchronize GAME_DESC description text between ports
Diffstat (limited to 'games')
-rw-r--r--games/egl/Makefile6
-rw-r--r--games/q2p/Makefile81
-rw-r--r--games/q2p/pkg-descr2
-rw-r--r--games/q2p/pkg-plist3
-rw-r--r--games/qudos/Makefile132
-rw-r--r--games/qudos/pkg-descr4
-rw-r--r--games/r1q2/Makefile2
7 files changed, 112 insertions, 118 deletions
diff --git a/games/egl/Makefile b/games/egl/Makefile
index bc69740b04ed..cd579ed61305 100644
--- a/games/egl/Makefile
+++ b/games/egl/Makefile
@@ -28,15 +28,14 @@ OPTIONS_DEFAULT= CLIENT DEDICATED GAME OPTIMIZED_CFLAGS
CLIENT_DESC= Build client
DEDICATED_DESC= Build dedicated server
-GAME_DESC= Build main game modification
+GAME_DESC= Build main game (default mod)
-.include "${.CURDIR}/../quake2-data/Makefile.include"
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MCLIENT}
LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
png15:${PORTSDIR}/graphics/png
-USE_GL= yes
+USE_GL= gl
CFLAGS+= -I${LOCALBASE}/include/libpng15
MAKE_ENV*= CFLAGS="${CFLAGS}"
PLIST_SUB+= CLIENT=""
@@ -74,4 +73,5 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/release/baseq2/*.so ${LIBDIR}/baseq2
${INSTALL_DATA} ${DISTDIR}/egl.pkz ${LIBDIR}/baseq2
+.include "${.CURDIR}/../quake2-data/Makefile.include"
.include <bsd.port.mk>
diff --git a/games/q2p/Makefile b/games/q2p/Makefile
index bfe9665af27b..eb2b9e87e78b 100644
--- a/games/q2p/Makefile
+++ b/games/q2p/Makefile
@@ -1,55 +1,53 @@
-# New ports collection makefile for: q2p
-# Date created: 2007-01-05
-# Whom: Alejandro Pulver <alepulver@FreeBSD.org>
-#
+# Created by: Alejandro Pulver <alepulver@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= q2p
PORTVERSION= 0.2.20061231
PORTREVISION= 12
CATEGORIES= games
-MASTER_SITES= http://qudos.quakedev.com/linux/quake2/engines/Q2P/
+MASTER_SITES= http://bfeared.com/library/quake/archive/quakedev/qudos/quake2/engines/Q2P/
DISTNAME= Q2P-0.2-2006-12-31
MAINTAINER= danfe@FreeBSD.org
-COMMENT= Enhanced OpenGL only Quake II engine
+COMMENT= Enhanced OpenGL-only Quake II engine
USE_BZIP2= yes
USE_XORG= xxf86dga xext xxf86vm x11
USE_GMAKE= yes
ALL_TARGET= release
-OPTIONS= CLIENT "Build client" on \
- CTF "Build CTF (Capture The Flag) modification" off \
- DEDICATED "Build dedicated server" on \
- GAME "Build a main game .so modification" off \
- GLX "Build OpenGL renderer" on \
- OPTIMIZED_CFLAGS "Enable compilation optimizations" on \
- OSS "Enable Open Sound System sound support" on \
- SDL "Enable SDL sound support" on \
- SDLGL "Build SDL OpenGL renderer" on
-
MAKE_ENV= DATADIR="${Q2DIR}" LIBDIR="${LIBDIR}"
PLIST_SUB= LIBDIR="${LIBDIR:S/${PREFIX}\///}"
LIBDIR= ${PREFIX}/lib/${PORTNAME}
-.include "${.CURDIR}/../quake2-data/Makefile.include"
+PORTDOCS= Q2P_readme.txt Ogg_readme.txt
+
+OPTIONS_DEFINE= CLIENT CTF DEDICATED GAME GLX OPTIMIZED_CFLAGS OSS \
+ SDL SDLGL DOCS
+OPTIONS_DEFAULT= CLIENT DEDICATED GLX OPTIMIZED_CFLAGS OSS SDL SDLGL
-.include <bsd.port.pre.mk>
+CLIENT_DESC= Build client
+CTF_DESC= Build CTF (Capture The Flag) mod
+DEDICATED_DESC= Build dedicated server
+GAME_DESC= Build main game (default mod)
+GLX_DESC= Build OpenGL renderer
+SDL_DESC= Sound support via SDL
+SDLGL_DESC= Build SDL OpenGL renderer
-.if !defined(WITHOUT_GLX) || !defined(WITHOUT_SDLGL)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MGLX} || ${PORT_OPTIONS:MSDLGL}
USE_GL= glu
-LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg \
+LIB_DEPENDS+= jpeg:${PORTSDIR}/graphics/jpeg \
png15:${PORTSDIR}/graphics/png
.endif
-.if !defined(WITHOUT_SDL) || !defined(WITHOUT_SDLGL)
+.if ${PORT_OPTIONS:MSDL} || ${PORT_OPTIONS:MSDLGL}
USE_SDL= sdl
.endif
-.if !defined(WITHOUT_CLIENT)
-LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
+.if ${PORT_OPTIONS:MCLIENT}
+LIB_DEPENDS+= vorbis:${PORTSDIR}/audio/libvorbis
MAKE_ENV+= BUILD_Q2P=YES
PLIST_SUB+= CLIENT=""
Q2BIN+= ${PORTNAME}
@@ -57,14 +55,14 @@ Q2BIN+= ${PORTNAME}
PLIST_SUB+= CLIENT="@comment "
.endif
-.if defined(WITH_CTF)
+.if ${PORT_OPTIONS:MCTF}
MAKE_ENV+= BUILD_CTF=YES
PLIST_SUB+= CTF=""
.else
PLIST_SUB+= CTF="@comment "
.endif
-.if !defined(WITHOUT_DEDICATED)
+.if ${PORT_OPTIONS:MDEDICATED}
MAKE_ENV+= BUILD_DEDICATED=YES
PLIST_SUB+= DEDICATED=""
Q2BIN+= ${PORTNAME}-ded
@@ -72,7 +70,7 @@ Q2BIN+= ${PORTNAME}-ded
PLIST_SUB+= DEDICATED="@comment "
.endif
-.if defined(WITH_GAME)
+.if ${PORT_OPTIONS:MGAME}
MAKE_ENV+= BUILD_GAME=YES
PLIST_SUB+= GAME=""
.else
@@ -80,20 +78,20 @@ PLIST_SUB+= GAME="@comment "
.endif
.for opt in GLX SDLGL
-. if !defined(WITHOUT_${opt})
+. if ${PORT_OPTIONS:M${opt}}
MAKE_ENV+= BUILD_${opt}=YES
PLIST_SUB+= ${opt}=""
Q2REF+= ${opt:L:S/glx/gl/:S/sdlgl/sdl/}
-. else
+. else
PLIST_SUB+= ${opt}="@comment "
-. endif
+. endif
.endfor
-.if !defined(WITH_OPTIMIZED_CFLAGS)
+.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
MAKE_ENV+= OPTIMIZE=YES
.endif
-.if !defined(WITHOUT_OSS)
+.if ${PORT_OPTIONS:MOSS}
MAKE_ENV+= BUILD_OSS_SND=YES
PLIST_SUB+= OSS=""
Q2SND+= oss
@@ -101,7 +99,7 @@ Q2SND+= oss
PLIST_SUB+= OSS="@comment "
.endif
-.if !defined(WITHOUT_SDL)
+.if ${PORT_OPTIONS:MSDL}
MAKE_ENV+= BUILD_SDL_SND=YES
PLIST_SUB+= SDL=""
Q2SND+= sdl
@@ -118,24 +116,25 @@ do-install:
.for bin in ${Q2BIN}
${INSTALL_PROGRAM} ${WRKSRC}/quake2/${bin} ${PREFIX}/bin
.endfor
- ${MKDIR} ${LIBDIR}/baseq2
+ @${MKDIR} ${LIBDIR}/baseq2
.for ref in ${Q2REF}
${INSTALL_PROGRAM} ${WRKSRC}/quake2/vid_${ref}.so ${LIBDIR}
.endfor
.for snd in ${Q2SND}
${INSTALL_PROGRAM} ${WRKSRC}/quake2/snd_${snd}.so ${LIBDIR}
.endfor
-.if defined(WITH_CTF)
- ${MKDIR} ${LIBDIR}/ctf
+.if ${PORT_OPTIONS:MCTF}
+ @${MKDIR} ${LIBDIR}/ctf
${INSTALL_PROGRAM} ${WRKSRC}/quake2/ctf/game.so ${LIBDIR}/ctf
.endif
-.if defined(WITH_GAME)
+.if ${PORT_OPTIONS:MGAME}
${INSTALL_PROGRAM} ${WRKSRC}/quake2/baseq2/game.so ${LIBDIR}/baseq2
.endif
${INSTALL_DATA} ${WRKSRC}/data/baseq2/* ${LIBDIR}/baseq2
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} Q2P_readme.txt Ogg_readme.txt ${DOCSDIR}
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include "${.CURDIR}/../quake2-data/Makefile.include"
+.include <bsd.port.mk>
diff --git a/games/q2p/pkg-descr b/games/q2p/pkg-descr
index f67f16bef572..58c4832b7c0f 100644
--- a/games/q2p/pkg-descr
+++ b/games/q2p/pkg-descr
@@ -1 +1 @@
-Enhanced OpenGL only Quake II engine.
+Enhanced, OpenGL-only Quake II engine.
diff --git a/games/q2p/pkg-plist b/games/q2p/pkg-plist
index 767d678b94ef..88cc6e871387 100644
--- a/games/q2p/pkg-plist
+++ b/games/q2p/pkg-plist
@@ -8,9 +8,6 @@
%%SDL%%%%LIBDIR%%/snd_sdl.so
%%GLX%%%%LIBDIR%%/vid_gl.so
%%SDLGL%%%%LIBDIR%%/vid_sdl.so
-%%PORTDOCS%%%%DOCSDIR%%/Ogg_readme.txt
-%%PORTDOCS%%%%DOCSDIR%%/Q2P_readme.txt
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%LIBDIR%%/baseq2
%%CTF%%@dirrm %%LIBDIR%%/ctf
@dirrm %%LIBDIR%%
diff --git a/games/qudos/Makefile b/games/qudos/Makefile
index da9ec9d572f4..7123e91a0285 100644
--- a/games/qudos/Makefile
+++ b/games/qudos/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: QuDos
-# Date created: 24 May 2006
-# Whom: Alejandro Pulver <alepulver@FreeBSD.org>
-#
+# Created by: Alejandro Pulver <alepulver@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= qudos
PORTVERSION= 0.40.1
@@ -16,34 +12,11 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= danfe@FreeBSD.org
-COMMENT= Enhanced OpenGL only Quake II engine
+COMMENT= Enhanced OpenGL-only Quake II engine
USE_BZIP2= yes
USE_GMAKE= yes
-OPTIONS= 3ZB2 "Build 3zb2 modification (bots)" on \
- ARTS "Enable support for aRts sound daemon" off \
- BOTS "Enable Ace Bot support in modifications" on \
- CLIENT "Build client" on \
- CTF "Build CTF (Capture The Flag) modification" off \
- DEDICATED "Build dedicated server" on \
- GAME "Build a main game .so modification" off \
- GAME_MOD "Enable custom addons in main modification" on \
- GLX "Build OpenGL renderer" on \
- IPV6 "Enable IPv6 support" off \
- JABOT "Build JABot modification (bots)" off \
- JOYSTICK "Enable joystick support" off \
- OSS "Enable Open Sound System sound support" on \
- QMAX "Enable fancier OpenGL graphics" on \
- REDBLUE "Enable red-blue 3d glasses renderer" off \
- RETEXTURE "Enable support for retextured graphics" off \
- ROGUE "Build Ground Zero (Rogue) mission pack" off \
- SDL "Enable SDL sound support" on \
- SDLGL "Build SDL OpenGL renderer" on \
- X86_ASM "Enable x86 assembly support" on \
- XATRIX "Build The Reckoning (Xatrix) mission pack" off \
- ZAERO "Build Zaero modification" off
-
MAKE_ENV= WITH_DATADIR=YES WITH_LIBDIR=YES WITH_XMMS=NO \
DATADIR="${Q2DIR}" LIBDIR="${LIBDIR}"
PLIST_SUB= LIBDIR="${LIBDIR:S/${PREFIX}\///}" VER="${PORTVERSION}"
@@ -51,32 +24,58 @@ LIBDIR= ${PREFIX}/lib/${PORTNAME}
MOD_LIST= 3ZB2 CTF JABOT ROGUE XATRIX ZAERO
-.include "${.CURDIR}/../quake2-data/Makefile.include"
-
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= 3ZB2 ARTS BOTS CLIENT CTF DEDICATED GAME GAME_MOD \
+ GLX IPV6 JABOT JOYSTICK OSS QMAX REDBLUE RETEXTURE \
+ ROGUE SDL SDLGL XATRIX ZAERO DOCS
+OPTIONS_DEFINE_i386= ASM
+OPTIONS_DEFINE_amd64= ASM
+OPTIONS_DEFAULT_i386= ASM
+OPTIONS_DEFAULT_amd64= ASM
+
+OPTIONS_DEFAULT= 3ZB2 BOTS CLIENT DEDICATED GAME_MOD GLX JOYSTICK OSS \
+ QMAX SDL SDLGL
+
+3ZB2_DESC= Build 3zb2 mod (bots)
+BOTS_DESC= Ace Bot support in mods
+CLIENT_DESC= Build client
+CTF_DESC= Build CTF (Capture The Flag) mod
+DEDICATED_DESC= Build dedicated server
+GAME_DESC= Build main game (default mod)
+GAME_MOD_DESC= Add custom add-ons to the main game
+JABOT_DESC= Build JABot mod (bots)
+JOYSTICK_DESC= Joystick support
+QMAX_DESC= Enable fancier OpenGL graphics
+REDBLUE_DESC= Enable red-blue 3D glasses renderer
+RETEXTURE_DESC= Retextured graphics support
+ROGUE_DESC= Build Ground Zero (Rogue) mission pack
+SDLGL_DESC= Build SDL OpenGL renderer
+XATRIX_DESC= Build The Reckoning (Xatrix) mission pack
+ZAERO_DESC= Build Zaero mission pack
+
+.include <bsd.port.options.mk>
.for mod in ${MOD_LIST}
-. if defined(WITH_${mod})
+. if ${PORT_OPTIONS:M${mod}}
MAKE_ENV+= BUILD_${mod}=YES
PLIST_SUB+= ${mod}=""
-. else
+. else
MAKE_ENV+= BUILD_${mod}=NO
PLIST_SUB+= ${mod}="@comment "
-. endif
+. endif
.endfor
-.if !defined(WITHOUT_GLX) || !defined(WITHOUT_SDLGL)
-USE_GL= yes
-LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg \
+.if ${PORT_OPTIONS:MGLX} || ${PORT_OPTIONS:MSDLGL}
+USE_GL= glu
+LIB_DEPENDS+= jpeg:${PORTSDIR}/graphics/jpeg \
png15:${PORTSDIR}/graphics/png
.endif
-.if !defined(WITHOUT_SDL) || !defined(WITHOUT_SDLGL)
+.if ${PORT_OPTIONS:MSDL} || ${PORT_OPTIONS:MSDLGL}
USE_SDL= sdl
.endif
-.if defined(WITH_ARTS)
-LIB_DEPENDS+= artsc.0:${PORTSDIR}/audio/arts
+.if ${PORT_OPTIONS:MARTS}
+LIB_DEPENDS+= artsc:${PORTSDIR}/audio/arts
MAKE_ENV+= BUILD_ARTS_SND=YES
PLIST_SUB+= ARTS=""
Q2SND+= arts
@@ -85,8 +84,8 @@ MAKE_ENV+= BUILD_ARTS_SND=NO
PLIST_SUB+= ARTS="@comment "
.endif
-.if !defined(WITHOUT_CLIENT)
-LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
+.if ${PORT_OPTIONS:MCLIENT}
+LIB_DEPENDS+= vorbis:${PORTSDIR}/audio/libvorbis
MAKE_ENV+= BUILD_QUAKE2=YES
PLIST_SUB+= CLIENT=""
Q2BIN+= ${PORTNAME}
@@ -95,7 +94,7 @@ MAKE_ENV+= BUILD_QUAKE2=NO
PLIST_SUB+= CLIENT="@comment "
.endif
-.if !defined(WITHOUT_DEDICATED)
+.if ${PORT_OPTIONS:MDEDICATED}
MAKE_ENV+= BUILD_DEDICATED=YES
PLIST_SUB+= DEDICATED=""
Q2BIN+= ${PORTNAME}-ded
@@ -104,7 +103,7 @@ MAKE_ENV+= BUILD_DEDICATED=NO
PLIST_SUB+= DEDICATED="@comment "
.endif
-.if defined(WITH_GAME)
+.if ${PORT_OPTIONS:MGAME}
MAKE_ENV+= BUILD_GAME=YES
PLIST_SUB+= GAME=""
.else
@@ -112,36 +111,36 @@ MAKE_ENV+= BUILD_GAME=NO
PLIST_SUB+= GAME="@comment "
.endif
-.if !defined(WITHOUT_GAME_MOD)
+.if ${PORT_OPTIONS:MGAME_MOD}
MAKE_ENV+= WITH_GAME_MOD=YES
.else
MAKE_ENV+= WITH_GAME_MOD=NO
.endif
.for opt in GLX SDLGL
-. if !defined(WITHOUT_${opt})
+. if ${PORT_OPTIONS:M${opt}}
MAKE_ENV+= BUILD_${opt}=YES
PLIST_SUB+= ${opt}=""
Q2REF+= ${opt:L}
-. else
+. else
MAKE_ENV+= BUILD_${opt}=NO
PLIST_SUB+= ${opt}="@comment "
-. endif
+. endif
.endfor
-.if defined(WITH_IPV6)
+.if ${PORT_OPTIONS:MIPV6}
MAKE_ENV+= WITH_IPV6=YES
.else
MAKE_ENV+= WITH_IPV6=NO
.endif
-.if defined(WITH_JOYSTICK)
+.if ${PORT_OPTIONS:MJOYSTICK}
MAKE_ENV+= WITH_JOYSTICK=YES
.else
MAKE_ENV+= WITH_JOYSTICK=NO
.endif
-.if !defined(WITHOUT_OSS)
+.if ${PORT_OPTIONS:MOSS}
MAKE_ENV+= BUILD_OSS_SND=YES
PLIST_SUB+= OSS=""
Q2SND+= oss
@@ -150,25 +149,25 @@ MAKE_ENV+= BUILD_OSS_SND=NO
PLIST_SUB+= OSS="@comment "
.endif
-.if !defined(WITHOUT_QMAX)
+.if ${PORT_OPTIONS:MQMAX}
MAKE_ENV+= WITH_QMAX=YES
.else
MAKE_ENV+= WITH_QMAX=NO
.endif
-.if defined(WITH_REDBLUE)
+.if ${PORT_OPTIONS:MREDBLUE}
MAKE_ENV+= WITH_REDBLUE=YES
.else
MAKE_ENV+= WITH_REDBLUE=NO
.endif
-.if defined(WITH_RETEXTURE)
+.if ${PORT_OPTIONS:MRETEXTURE}
MAKE_ENV+= WITH_RETEXTURE=YES
.else
MAKE_ENV+= WITH_RETEXTURE=NO
.endif
-.if !defined(WITHOUT_SDL)
+.if ${PORT_OPTIONS:MSDL}
MAKE_ENV+= BUILD_SDL_SND=YES
PLIST_SUB+= SDL=""
Q2SND+= sdl
@@ -177,7 +176,7 @@ MAKE_ENV+= BUILD_SDL_SND=NO
PLIST_SUB+= SDL="@comment "
.endif
-.if !defined(WITHOUT_X86_ASM)
+.if ${PORT_OPTIONS:MASM}
MAKE_ENV+= WITH_X86_ASM=YES
.else
MAKE_ENV+= WITH_X86_ASM=NO
@@ -197,27 +196,28 @@ do-install:
.for bin in ${Q2BIN}
${INSTALL_PROGRAM} ${WRKSRC}/quake2/${bin} ${PREFIX}/bin
.endfor
- ${MKDIR} ${LIBDIR}/baseq2
+ @${MKDIR} ${LIBDIR}/baseq2
.for ref in ${Q2REF}
${INSTALL_PROGRAM} ${WRKSRC}/quake2/ref_q2${ref}.so ${LIBDIR}
.endfor
.for snd in ${Q2SND}
${INSTALL_PROGRAM} ${WRKSRC}/quake2/snd_${snd}.so ${LIBDIR}
.endfor
-.if defined(WITH_GAME)
+.if ${PORT_OPTIONS:MGAME}
${INSTALL_PROGRAM} ${WRKSRC}/quake2/baseq2/game.so ${LIBDIR}/baseq2
.endif
.for mod in ${MOD_LIST:L}
-.if defined(WITH_${mod:U})
- ${MKDIR} ${LIBDIR}/${mod}
+.if ${PORT_OPTIONS:M${mod:U}}
+ @${MKDIR} ${LIBDIR}/${mod}
${INSTALL_PROGRAM} ${WRKSRC}/quake2/${mod}/game.so ${LIBDIR}/${mod}
.endif
.endfor
${INSTALL_DATA} ${_DISTDIR}/QuDos-${PORTVERSION}.pk3 ${LIBDIR}/baseq2
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/docs/QuDos.txt ${WRKSRC}/docs/Ogg_readme.txt \
- ${DOCSDIR}
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/QuDos.txt \
+ ${WRKSRC}/docs/Ogg_readme.txt ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include "${.CURDIR}/../quake2-data/Makefile.include"
+.include <bsd.port.mk>
diff --git a/games/qudos/pkg-descr b/games/qudos/pkg-descr
index d3ab099177ae..58c4832b7c0f 100644
--- a/games/qudos/pkg-descr
+++ b/games/qudos/pkg-descr
@@ -1,3 +1 @@
-Enhanced OpenGL only Quake II engine.
-
-WWW: http://qudos.quakedev.com/
+Enhanced, OpenGL-only Quake II engine.
diff --git a/games/r1q2/Makefile b/games/r1q2/Makefile
index 3ccad930dc04..864e4f428382 100644
--- a/games/r1q2/Makefile
+++ b/games/r1q2/Makefile
@@ -34,7 +34,7 @@ OPTIONS_DEFAULT= CLIENT DEDICATED REF_GL
CLIENT_DESC= Build client
DEDICATED_DESC= Build dedicated server
-GAME_DESC= Build main game shared object file
+GAME_DESC= Build main game (default mod)
REF_GL_DESC= Build renderer (required for client)
.include <bsd.port.options.mk>