aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-11-27 17:53:12 +0800
committermiwi <miwi@FreeBSD.org>2011-11-27 17:53:12 +0800
commit62b5f11a615c43e13fd4ad2fdb2e77338472baa5 (patch)
tree9680e2f74b3b0c428444ed8fd452d90ccb89c0e0 /games
parentc616014567cd31e7eb8075509cc66d86b33c884b (diff)
downloadfreebsd-ports-gnome-62b5f11a615c43e13fd4ad2fdb2e77338472baa5.tar.gz
freebsd-ports-gnome-62b5f11a615c43e13fd4ad2fdb2e77338472baa5.tar.zst
freebsd-ports-gnome-62b5f11a615c43e13fd4ad2fdb2e77338472baa5.zip
- Update MASTER_SITES and WWW: line
- Support PTHREAD_LIBS properly PR: 162857 Submitted by: Ports Fury Feature safe: yes
Diffstat (limited to 'games')
-rw-r--r--games/freecell-solver/Makefile27
-rw-r--r--games/freecell-solver/pkg-descr7
2 files changed, 19 insertions, 15 deletions
diff --git a/games/freecell-solver/Makefile b/games/freecell-solver/Makefile
index 9e7a84bcbad8..8b235b660342 100644
--- a/games/freecell-solver/Makefile
+++ b/games/freecell-solver/Makefile
@@ -10,7 +10,7 @@ PORTNAME= freecell-solver
PORTVERSION= 3.8.0
PORTREVISION= 1
CATEGORIES= games
-MASTER_SITES= BERLIOS/fc-solve
+MASTER_SITES= http://fc-solve.shlomifish.org/downloads/fc-solve/
MAINTAINER= ports@FreeBSD.org
COMMENT= A program that automatically solves games of Freecell
@@ -18,11 +18,15 @@ COMMENT= A program that automatically solves games of Freecell
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING.txt
-USE_BZIP2= yes
-USE_PERL5_BUILD= yes
-USE_CMAKE= yes
-USE_LDCONFIG= yes
-MAKE_JOBS_SAFE= yes
+OPTIONS= TCMALLOC "Use Google's TCMalloc" off
+
+USE_BZIP2= yes
+USE_PERL5_BUILD=yes
+USE_CMAKE= yes
+USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
+
+CFLAGS+= -I${LOCALBASE}/include
MAN6= fc-solve-board_gen.6 fc-solve.6 \
freecell-solver-range-parallel-solve.6 \
@@ -30,11 +34,7 @@ MAN6= fc-solve-board_gen.6 fc-solve.6 \
make_pysol_freecell_board.py.6 \
pi-make-microsoft-freecell-board.6
-CFLAGS+= -I${LOCALBASE}/include
-
-OPTIONS= TCMALLOC "Use Google's TCMalloc" off
-
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if defined(WITH_TCMALLOC)
LIB_DEPENDS+= tcmalloc.2:${PORTSDIR}/devel/google-perftools
@@ -43,6 +43,9 @@ CMAKE_ARGS+= -DFCS_AVOID_TCMALLOC:BOOL=ON
.endif
post-patch:
+.for f in CMakeLists.txt
+ @${REINPLACE_CMD} -e 's|"pthread"|"${PTHREAD_LIBS}"|' ${WRKSRC}/${f}
+.endfor
.for f in children-playing-ball.sh sentient-pearls.sh
@${REINPLACE_CMD} -e 's|/bin/bash|/bin/sh|' ${WRKSRC}/Presets/presets/${f}
.endfor
@@ -62,4 +65,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/freecell-solver/pkg-descr b/games/freecell-solver/pkg-descr
index 2c646a5a2d6c..7ff6b897a8ee 100644
--- a/games/freecell-solver/pkg-descr
+++ b/games/freecell-solver/pkg-descr
@@ -1,4 +1,5 @@
-This is Freecell Solver - a program that automatically solves games of Freecell
-and similar Solitaire variants such as Eight Off, Forecell and Seahaven Towers.
+This is Freecell Solver - a program that automatically solves games of
+Freecell and similar Solitaire variants such as Eight Off, Forecell and
+Seahaven Towers.
-WWW: http://fc-solve.berlios.de/
+WWW: http://fc-solve.shlomifish.org/