aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorbarner <barner@FreeBSD.org>2005-11-17 19:44:27 +0800
committerbarner <barner@FreeBSD.org>2005-11-17 19:44:27 +0800
commit663a771f0902d0b6e04576e7c637e2d67bed2bf0 (patch)
tree557634f629d7f8e1655f98a12786e1fce1a4bbcf /games
parent69b46800041d96f06cd44306da4fce1c9e9822a4 (diff)
downloadfreebsd-ports-gnome-663a771f0902d0b6e04576e7c637e2d67bed2bf0.tar.gz
freebsd-ports-gnome-663a771f0902d0b6e04576e7c637e2d67bed2bf0.tar.zst
freebsd-ports-gnome-663a771f0902d0b6e04576e7c637e2d67bed2bf0.zip
- Integrate with "doom-data".
- Add OPTIONS. - Use SUB_FILES for generating pkg-message. - Merge BROKEN and NOT_FOR_ARCHS into ONLY_FOR_ARCHS=i386. - Add patch to fix the segmentation fault when exitting the program - Update WWW PR: ports/86440 Submitted by: Alejandro Pulver <alejandro@varnet.biz> Tweaked by: Igor Pokrovsky <ip@doom.homeunix.org> Approved by: Igor Pokrovsky <ip@doom.homeunix.org> (maintainer)
Diffstat (limited to 'games')
-rw-r--r--games/deng/Makefile32
-rw-r--r--games/deng/distinfo1
-rw-r--r--games/deng/files/patch-Src_dd__pinit.c11
-rw-r--r--games/deng/files/pkg-message.in (renamed from games/deng/pkg-message)11
-rw-r--r--games/deng/pkg-descr2
5 files changed, 38 insertions, 19 deletions
diff --git a/games/deng/Makefile b/games/deng/Makefile
index 7b92eb683962..f1d54881fd73 100644
--- a/games/deng/Makefile
+++ b/games/deng/Makefile
@@ -7,6 +7,7 @@
PORTNAME= deng
PORTVERSION= 1.8.6
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,7 +19,6 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
RUN_DEPENDS= ${LOCALBASE}/bin/timidity:${PORTSDIR}/audio/timidity
USE_REINPLACE= yes
-REINPLACE_ARGS= -i ""
USE_AUTOTOOLS= libtool:15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CFLAGS="${CFLAGS} `${SDL_CONFIG} --cflags` -I${LOCALBASE}/include -I${X11BASE}/include" \
@@ -26,9 +26,12 @@ CONFIGURE_ENV= CFLAGS="${CFLAGS} `${SDL_CONFIG} --cflags` -I${LOCALBASE}/include
USE_SDL= sdl mixer net
USE_GL= yes
INSTALLS_SHLIB= yes
-NOT_FOR_ARCHS= amd64
+ONLY_FOR_ARCHS= i386
-PKGMESSAGE= ${WRKDIR}/pkg-message
+SUB_FILES= pkg-message
+SUB_LIST= "PREFIX=${PREFIX}" "DOCSDIR=${DOCSDIR}"
+
+.include "${.CURDIR}/../doom-data/Makefile.include"
.if exists(${LOCALBASE}/lib/libopenal.so.0) || defined(WITH_OPENAL)
WITH_OPENAL= yes
@@ -41,12 +44,6 @@ PLIST_SUB= WITH_OPENAL="@comment "
PLIST_SUB= WITH_OPENAL=""
.endif
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "ia64" || ${ARCH} == "sparc64" || ${ARCH} == "alpha"
-BROKEN= "Does not build on ia64, sparc64 or alpha"
-.endif
-
.ifndef (WITH_OPENAL)
pre-everything::
@${ECHO_CMD} ""
@@ -55,21 +52,20 @@ pre-everything::
.endif
post-patch:
- @${REINPLACE_CMD} -E -e 's/-Wunused-.+ / /g; \
+ @${REINPLACE_CMD} -E -i '' -e 's/-Wunused-.+ / /g; \
s/SDL(\\|\/)//g' ${WRKSRC}/configure
@${FIND} ${WRKSRC} -name '*.[ch]' | \
- ${XARGS} ${REINPLACE_CMD} -E -e 's/SDL(\\|\/)//g'
+ ${XARGS} ${REINPLACE_CMD} -i '' -E -e 's/SDL(\\|\/)//g'
post-install:
.ifndef (NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/Doc/*.txt ${DOCSDIR}
-.for i in jDoom jHeretic jHexen
- @${MKDIR} ${DOCSDIR}/${i}
- ${INSTALL_DATA} ${WRKSRC}/Doc/${i}/*.txt ${DOCSDIR}/${i}
-.endfor
+. for i in jDoom jHeretic jHexen
+ @${MKDIR} ${DOCSDIR}/${i}
+ ${INSTALL_DATA} ${WRKSRC}/Doc/${i}/*.txt ${DOCSDIR}/${i}
+. endfor
.endif
- @(${SED} -e 's|%%PREFIX%%|${PREFIX}|; s|%%DOCSDIR%%|${DOCSDIR}|' \
- <pkg-message >${PKGMESSAGE} && ${CAT} ${PKGMESSAGE})
+ @${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/deng/distinfo b/games/deng/distinfo
index 005c1dd9d0b7..6bc5b14efe63 100644
--- a/games/deng/distinfo
+++ b/games/deng/distinfo
@@ -1,2 +1,3 @@
MD5 (deng-1.8.6.tar.gz) = 1717d0de5bc8efba9076d6b8e2055d08
+SHA256 (deng-1.8.6.tar.gz) = 06e33d9efe3522c72940bda0d6892e58e2b1479f2b261a885b7854b9ce0201a6
SIZE (deng-1.8.6.tar.gz) = 3157590
diff --git a/games/deng/files/patch-Src_dd__pinit.c b/games/deng/files/patch-Src_dd__pinit.c
new file mode 100644
index 000000000000..79f7f7557b89
--- /dev/null
+++ b/games/deng/files/patch-Src_dd__pinit.c
@@ -0,0 +1,11 @@
+--- Src/dd_pinit.c.orig
++++ Src/dd_pinit.c
+@@ -227,7 +227,7 @@
+ FH_Clear();
+ ArgShutdown();
+ free(mainzone);
+- DD_ShutdownDGL();
++// DD_ShutdownDGL();
+
+ // Close the message output file.
+ fclose(outFile);
diff --git a/games/deng/pkg-message b/games/deng/files/pkg-message.in
index 6b571b21be99..bc2e18dfdccf 100644
--- a/games/deng/pkg-message
+++ b/games/deng/files/pkg-message.in
@@ -1,10 +1,21 @@
******************************************************************************
Now you can start playing Doomsday!
+
All three games Doom, Heretic and Hexen could be launched with one executable.
+
A quick start command could be:
+
%%PREFIX%%/bin/doomsday -g ${game} -f ${path_to_game_wad}
+
where
+
game - could be jdoom, jheretic or jhexen;
path_to_game_wad - path to game main wad file.
+
Check documentation in %%DOCSDIR%% for other options.
+
+NOTE: when you run Doomsday it will create about 7 files/dirs in the current
+directory (including temporary files, configuration, etc.) so it's preferable
+to run it in a separate directory.
+
******************************************************************************
diff --git a/games/deng/pkg-descr b/games/deng/pkg-descr
index 88af73b7004f..8e74d7e44fdf 100644
--- a/games/deng/pkg-descr
+++ b/games/deng/pkg-descr
@@ -17,7 +17,7 @@ Some of supported features are:
* Glowing surfaces
* Smart texture filtering using a modified hq2x algorith
-WWW: http://deng.sourceforge.net/
+WWW: http://www.doomsdayhq.com/
- Igor Pokrovsky
ip@doom.homeunix.org