aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2013-05-29 03:38:34 +0800
committerantoine <antoine@FreeBSD.org>2013-05-29 03:38:34 +0800
commit66516d334b78c02feb0f396048cdc4c338d98e05 (patch)
treecc2eb4e06659fd234a73d445690eccdbc0f4c577 /games
parenteb17b4e144bea6c888097f4cb4a4176079c60525 (diff)
downloadfreebsd-ports-gnome-66516d334b78c02feb0f396048cdc4c338d98e05.tar.gz
freebsd-ports-gnome-66516d334b78c02feb0f396048cdc4c338d98e05.tar.zst
freebsd-ports-gnome-66516d334b78c02feb0f396048cdc4c338d98e05.zip
- Unbreak with clang using -Wno-error=return-type (this is old K&R code)
- Trim Makefile header - Use PORT_OPTIONS PORTSDOC DATADIR
Diffstat (limited to 'games')
-rw-r--r--games/xmines/Makefile17
-rw-r--r--games/xmines/pkg-plist8
2 files changed, 11 insertions, 14 deletions
diff --git a/games/xmines/Makefile b/games/xmines/Makefile
index 20fa6b200587..1575d9a78cad 100644
--- a/games/xmines/Makefile
+++ b/games/xmines/Makefile
@@ -1,15 +1,11 @@
-# New ports collection makefile for: xmines
-# Date created: 18 August 1999
-# Whom: Andrey Zakhvatov
-#
+# Created by: Andrey Zakhvatov
# $FreeBSD$
-#
PORTNAME= xmines
PORTVERSION= 1.0
PORTREVISION= 2
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SUNSITE}
+MASTER_SITES= SUNSITE
MASTER_SITE_SUBDIR= games/strategy
DISTNAME= ${PORTNAME}
@@ -17,11 +13,16 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Minesweeper game for the X Window System
USE_XORG= x11 xt
+CFLAGS+= -Wno-error=return-type
+
+PORTDOCS= README
+
+.include <bsd.port.options.mk>
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/games/xmines/pkg-plist b/games/xmines/pkg-plist
index e8af756aca3d..2dfe45e6866e 100644
--- a/games/xmines/pkg-plist
+++ b/games/xmines/pkg-plist
@@ -1,7 +1,3 @@
bin/xmines
-@mode 666
-share/xmines/scores
-@mode
-%%PORTDOCS%%share/doc/xmines/README
-%%PORTDOCS%%@dirrm share/doc/xmines
-@dirrm share/xmines
+%%DATADIR%%/scores
+@dirrm %%DATADIR%%