aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2004-08-21 23:58:14 +0800
committerarved <arved@FreeBSD.org>2004-08-21 23:58:14 +0800
commit6830a545d7195884bbd7e18a1da82a03445a8126 (patch)
tree273ab1e15e226268bdd455f5641dac3717e53474 /games
parent68e0f80145f906dae85b739e7dde79f312ff7f71 (diff)
downloadfreebsd-ports-gnome-6830a545d7195884bbd7e18a1da82a03445a8126.tar.gz
freebsd-ports-gnome-6830a545d7195884bbd7e18a1da82a03445a8126.tar.zst
freebsd-ports-gnome-6830a545d7195884bbd7e18a1da82a03445a8126.zip
Fix build on 64bit platforms
Diffstat (limited to 'games')
-rw-r--r--games/xgospel/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/games/xgospel/Makefile b/games/xgospel/Makefile
index aa4b6659c924..2539bbd6bef6 100644
--- a/games/xgospel/Makefile
+++ b/games/xgospel/Makefile
@@ -17,14 +17,16 @@ LIB_DEPENDS= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
USE_XLIB= yes
USE_XPM= yes
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
CONFIGURE_ARGS= --with-x --with-xpm --with-xaw3d
.include <bsd.port.pre.mk>
-.if ${ARCH} != "i386"
-BROKEN= "Does not compile on !i386"
-.endif
+post-patch:
+ ${REINPLACE_CMD} -e "s,#ifndef _POSIX_SOURCE,#if 0," \
+ ${WRKSRC}/connect.c ${WRKSRC}/relay.c ${WRKSRC}/relog.c \
+ ${WRKSRC}/rport.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/relay ${PREFIX}/bin