aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-01-21 01:47:39 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 06:26:59 +0800
commit6837412f4fd0ee2ae7db937f3852b074919f5130 (patch)
tree2c3b4c50ee45af82535befef51f193ff23660213 /games
parent9e141498e0be67c9fa08721dbca5aacd8515bc65 (diff)
downloadfreebsd-ports-gnome-6837412f4fd0ee2ae7db937f3852b074919f5130.tar.gz
freebsd-ports-gnome-6837412f4fd0ee2ae7db937f3852b074919f5130.tar.zst
freebsd-ports-gnome-6837412f4fd0ee2ae7db937f3852b074919f5130.zip
games/bomns: unbreak build with Clang 6 (C++14 by default)
src/bomns.cpp:565:22: error: non-constant-expression cannot be narrowed from type 'int' to 'Sint16' (aka 'short') in initializer list [-Wc++11-narrowing] SDL_Rect rcDest = {nX, nY, 15, 20}; ^~ src/bomns.cpp:565:22: note: insert an explicit cast to silence this issue SDL_Rect rcDest = {nX, nY, 15, 20}; ^~ static_cast<Sint16>( ) src/bomns.cpp:565:26: error: non-constant-expression cannot be narrowed from type 'int' to 'Sint16' (aka 'short') in initializer list [-Wc++11-narrowing] SDL_Rect rcDest = {nX, nY, 15, 20}; ^~ src/bomns.cpp:565:26: note: insert an explicit cast to silence this issue SDL_Rect rcDest = {nX, nY, 15, 20}; ^~ static_cast<Sint16>( ) Reported by: pkg-fallout
Diffstat (limited to 'games')
-rw-r--r--games/bomns/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/games/bomns/Makefile b/games/bomns/Makefile
index 37cec268db5c..22c8069d2c70 100644
--- a/games/bomns/Makefile
+++ b/games/bomns/Makefile
@@ -21,6 +21,7 @@ GH_TAGNAME= 113be27
USES= cmake localbase
CMAKE_ARGS= -Wno-dev
+USE_CXXSTD= gnu++98
USE_SDL= mixer sdl
USE_GNOME= gtk20
USE_CSTD= gnu89