aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorzeising <zeising@FreeBSD.org>2013-05-25 22:37:02 +0800
committerzeising <zeising@FreeBSD.org>2013-05-25 22:37:02 +0800
commit715298b528f23a6a763e28623a4c98f1365c81ce (patch)
treecf13f962932aab3646f0af684b2923c4e0f0825b /games
parent0f8e632e50d273ba38d9d13f7e446a4a10d95cd4 (diff)
downloadfreebsd-ports-gnome-715298b528f23a6a763e28623a4c98f1365c81ce.tar.gz
freebsd-ports-gnome-715298b528f23a6a763e28623a4c98f1365c81ce.tar.zst
freebsd-ports-gnome-715298b528f23a6a763e28623a4c98f1365c81ce.zip
The FreeBSD x11 team proudly presents
an zeising, kwm, miwi, bapt, eadler production: Xorg 7.7 Starring: xserver 1.12.4 (new xorg only) Mesa 8.0.4, including libGL, libGLU and dri (new xorg only) libX11 1.5.0 libxcb 1.9 libdrm 2.4.42 (new xorg only) freeglut 2.8.1 Also starring: Updates to drivers and other libraries and utilities Additional notes: Change pkgconf to be a build dependency. Add a new USE_XORG, xcb, to depend on libxcb and update all ports to use this. Trim makefile headers. Take maintanership of x11/xcb-proto, ok'd by ashish. If you are running WITH_NEW_XORG=, you need to rebuild all installed drivers, see UPDATING for more information. Various fixes to make ports compile. PR: ports/177942 Exp-run by: miwi Approved by: portmgr (miwi) Thanks to all who helped testing!
Diffstat (limited to 'games')
-rw-r--r--games/capitalism/Makefile5
-rw-r--r--games/gnome-games/Makefile3
-rw-r--r--games/klavaro/Makefile5
-rw-r--r--games/spellathon/Makefile5
4 files changed, 8 insertions, 10 deletions
diff --git a/games/capitalism/Makefile b/games/capitalism/Makefile
index ab295af440c0..32b6a2ef68ad 100644
--- a/games/capitalism/Makefile
+++ b/games/capitalism/Makefile
@@ -18,13 +18,12 @@ LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
png15:${PORTSDIR}/graphics/png \
freetype:${PORTSDIR}/print/freetype2 \
expat:${PORTSDIR}/textproc/expat2 \
- fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
- xcb:${PORTSDIR}/x11/libxcb
+ fontconfig:${PORTSDIR}/x11-fonts/fontconfig
WRKSRC= ${WRKDIR}/Capitalism-${PORTVERSION}
USES= iconv
-USE_XORG= ice sm x11 xau xdmcp xext xrender
+USE_XORG= ice sm x11 xau xcb xdmcp xext xrender
USE_QT4= moc_build qmake_build rcc_build uic_build iconengines imageformats \
corelib gui network script xml
MAKE_JOBS_SAFE= yes
diff --git a/games/gnome-games/Makefile b/games/gnome-games/Makefile
index 472e1a386c36..d45af14848d7 100644
--- a/games/gnome-games/Makefile
+++ b/games/gnome-games/Makefile
@@ -4,7 +4,7 @@
PORTNAME= gnome-games
PORTVERSION= 2.32.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -25,6 +25,7 @@ USE_PYTHON= yes
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
USE_GMAKE= yes
+USE_GL= gl
USES= pathfix gettext
USE_GNOME= gnomeprefix intlhack librsvg2 desktopfileutils \
pygnomedesktop gnomedocutils
diff --git a/games/klavaro/Makefile b/games/klavaro/Makefile
index 9fedf73ce24a..87bd222bb921 100644
--- a/games/klavaro/Makefile
+++ b/games/klavaro/Makefile
@@ -19,13 +19,12 @@ LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
freetype:${PORTSDIR}/print/freetype2 \
expat:${PORTSDIR}/textproc/expat2 \
fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
- gtkdatabox:${PORTSDIR}/x11-toolkits/gtkdatabox \
- xcb:${PORTSDIR}/x11/libxcb
+ gtkdatabox:${PORTSDIR}/x11-toolkits/gtkdatabox
USES= pkgconfig gettext iconv
USE_BZIP2= yes
USE_GMAKE= yes
-USE_XORG= pixman x11 xau xcomposite xcursor xdamage xdmcp xext \
+USE_XORG= pixman x11 xau xcb xcomposite xcursor xdamage xdmcp xext \
xfixes xi xinerama xrandr xrender
USE_GNOME= gtk20
USE_LDCONFIG= yes
diff --git a/games/spellathon/Makefile b/games/spellathon/Makefile
index 3b8c885cbf61..a84e1ef4a8d7 100644
--- a/games/spellathon/Makefile
+++ b/games/spellathon/Makefile
@@ -17,14 +17,13 @@ LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
png15:${PORTSDIR}/graphics/png \
freetype:${PORTSDIR}/print/freetype2 \
expat:${PORTSDIR}/textproc/expat2 \
- fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
- xcb:${PORTSDIR}/x11/libxcb
+ fontconfig:${PORTSDIR}/x11-fonts/fontconfig
CXXFLAGS+= -fPIC
USES= gettext iconv
USE_GNOME= glib20
USE_QT4= corelib gui moc_build qmake_build rcc_build uic_build
-USE_XORG= ice sm x11 xau xdmcp xext xrender
+USE_XORG= ice sm x11 xau xcb xdmcp xext xrender
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes