aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoranholt <anholt@FreeBSD.org>2005-05-05 10:27:28 +0800
committeranholt <anholt@FreeBSD.org>2005-05-05 10:27:28 +0800
commit71feccea5caad73fcc10d0a04a7bf7f22856f2b6 (patch)
treea6175e55ae8939aa1c03cc61f228d7720291a435 /games
parent686f2a5d5c176ac562cc501b8ea951613d23abec (diff)
downloadfreebsd-ports-gnome-71feccea5caad73fcc10d0a04a7bf7f22856f2b6.tar.gz
freebsd-ports-gnome-71feccea5caad73fcc10d0a04a7bf7f22856f2b6.tar.zst
freebsd-ports-gnome-71feccea5caad73fcc10d0a04a7bf7f22856f2b6.zip
Fix build on 64 bit by being careful with an integer size.
Diffstat (limited to 'games')
-rw-r--r--games/csmash/Makefile8
-rw-r--r--games/csmash/files/patch-loadparts.cpp11
2 files changed, 12 insertions, 7 deletions
diff --git a/games/csmash/Makefile b/games/csmash/Makefile
index f1db947e871c..b8cbe342eaf9 100644
--- a/games/csmash/Makefile
+++ b/games/csmash/Makefile
@@ -25,14 +25,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} != "i386"
-BROKEN= "Does not compile on !i386"
-.endif
-
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|/games/|/|g'
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/csmash/files/patch-loadparts.cpp b/games/csmash/files/patch-loadparts.cpp
new file mode 100644
index 000000000000..cab4e05cc796
--- /dev/null
+++ b/games/csmash/files/patch-loadparts.cpp
@@ -0,0 +1,11 @@
+--- loadparts.cpp.orig Wed May 4 19:19:33 2005
++++ loadparts.cpp Wed May 4 19:19:48 2005
+@@ -245,7 +245,7 @@
+
+ while ('\\' == line[l-1]) {
+ // concat next line(s)
+- int bufsize = clamp(0U, sizeof(line)-l, sizeof(line)-1);
++ int bufsize = clamp(0UL, sizeof(line)-l, sizeof(line)-1);
+ fgets(&line[l-2], bufsize, fp);
+ if (feof((FILE*)fp)) break;
+ l = strlen(line);