aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-12-06 02:13:46 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 06:04:42 +0800
commit73124528bd3dbc804da7fd0c1251e4cd36aef54a (patch)
tree02dd47ed804a5dc7c15f973759b2a7c0fd9ddfee /games
parent3d29c75b6cee6d13d918f2bb1e4d1fbc15abad04 (diff)
downloadfreebsd-ports-gnome-73124528bd3dbc804da7fd0c1251e4cd36aef54a.tar.gz
freebsd-ports-gnome-73124528bd3dbc804da7fd0c1251e4cd36aef54a.tar.zst
freebsd-ports-gnome-73124528bd3dbc804da7fd0c1251e4cd36aef54a.zip
- Update to 0.2.9
Diffstat (limited to 'games')
-rw-r--r--games/maxr/Makefile27
-rw-r--r--games/maxr/distinfo5
-rw-r--r--games/maxr/files/patch-src_config_selectplatformconfig.h11
3 files changed, 25 insertions, 18 deletions
diff --git a/games/maxr/Makefile b/games/maxr/Makefile
index 4de80489310e..1d4f435ef226 100644
--- a/games/maxr/Makefile
+++ b/games/maxr/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= maxr
-PORTVERSION= 0.2.8
-PORTREVISION= 4
+PORTVERSION= 0.2.9
CATEGORIES= games
MASTER_SITES= http://www.maxr.org/downloads/ \
http://mirror.amdmi3.ru/distfiles/
@@ -12,18 +11,14 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Mechanized Assault and Exploration Reloaded
LICENSE= GPLv2+
-LICENSE_FILE= ${WRKSRC}/COPYING
+LICENSE_FILE= ${WRKSRC}/data/COPYING
-USES= localbase
-GNU_CONFIGURE= yes
-USE_SDL= sdl mixer net
+USES= cmake compiler:c++11-lib dos2unix
+DOS2UNIX_FILES= src/config/selectplatformconfig.h
+USE_SDL= sdl2 mixer2 net2
PLIST_FILES= bin/${PORTNAME}
PORTDATA= *
-PLIST_DIRS= %%DATADIR%%/voices \
- %%DATADIR%%/vehicles/sub/sub \
- %%DATADIR%%/save \
- %%DATADIR%%/mve
DESKTOP_ENTRIES="M.A.X.R." \
"" \
@@ -32,10 +27,10 @@ DESKTOP_ENTRIES="M.A.X.R." \
"Game;StrategyGame;" \
false
-post-patch:
- @${REINPLACE_CMD} -e '/^LIBS=/ s|-lSDL_|`${SDL_CONFIG} --libs` &|' \
- -e '/^LIBS=/ s|-lSDL |`${SDL_CONFIG} --libs` |' \
- ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|cp -a|cp -RpP|' ${WRKSRC}/Makefile.in
+.include <bsd.port.pre.mk>
-.include <bsd.port.mk>
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1100000
+BROKEN= does not build on 10.x
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/games/maxr/distinfo b/games/maxr/distinfo
index 12c9e7d196af..f8d03681b5da 100644
--- a/games/maxr/distinfo
+++ b/games/maxr/distinfo
@@ -1,2 +1,3 @@
-SHA256 (maxr-0.2.8.tar.gz) = d083fdc73d7ca12fa7bd21cee0ecada3612be62f4fed5c87f73e5cb654867e98
-SIZE (maxr-0.2.8.tar.gz) = 14738324
+TIMESTAMP = 1467908301
+SHA256 (maxr-0.2.9.tar.gz) = 5f0afebcef5ca6449de175e5abf0e3772c4f238a0103361a50efb6349b2185ff
+SIZE (maxr-0.2.9.tar.gz) = 14847180
diff --git a/games/maxr/files/patch-src_config_selectplatformconfig.h b/games/maxr/files/patch-src_config_selectplatformconfig.h
new file mode 100644
index 000000000000..508a3106e370
--- /dev/null
+++ b/games/maxr/files/patch-src_config_selectplatformconfig.h
@@ -0,0 +1,11 @@
+--- src/config/selectplatformconfig.h.orig 2016-06-03 22:11:14 UTC
++++ src/config/selectplatformconfig.h
+@@ -19,7 +19,7 @@
+
+ #ifndef MAXR_PLATFORM_CONFIG
+
+-#if (defined(linux) || defined(__linux) || defined(__linux__) || defined(__GNU__) || defined(__GLIBC__)) && !defined(_CRAYC)
++#if (defined(linux) || defined(__linux) || defined(__linux__) || defined(__GNU__) || defined(__GLIBC__) || defined(__FreeBSD__)) && !defined(_CRAYC)
+ # define MAXR_PLATFORM_CONFIG "config/platform/linux.h"
+ #elif defined(__CYGWIN__)
+ # define MAXR_PLATFORM_CONFIG "config/platform/cygwin.h"