aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2008-03-30 07:09:35 +0800
committeralepulver <alepulver@FreeBSD.org>2008-03-30 07:09:35 +0800
commit7381b7b08d01a6404d1cc2c11aef69e25056635d (patch)
tree2d11004be401c6fd2f99f634759c12ba3f0c2efe /games
parent328ea91f0b9df23510e60513e0da233d867e2047 (diff)
downloadfreebsd-ports-gnome-7381b7b08d01a6404d1cc2c11aef69e25056635d.tar.gz
freebsd-ports-gnome-7381b7b08d01a6404d1cc2c11aef69e25056635d.tar.zst
freebsd-ports-gnome-7381b7b08d01a6404d1cc2c11aef69e25056635d.zip
- USE_XLIB -> USE_XORG clean up.
Reported by: miwi
Diffstat (limited to 'games')
-rw-r--r--games/iourbanterror/Makefile2
-rw-r--r--games/q3cellshading/Makefile2
-rw-r--r--games/quake2forge/Makefile5
-rw-r--r--games/worldofpadman/Makefile2
4 files changed, 7 insertions, 4 deletions
diff --git a/games/iourbanterror/Makefile b/games/iourbanterror/Makefile
index b30fee7cad74..3e03bf33069e 100644
--- a/games/iourbanterror/Makefile
+++ b/games/iourbanterror/Makefile
@@ -94,7 +94,7 @@ USE_SDL= sdl
MAKE_ENV+= USE_SDL_VIDEO=1
. else
USE_GL= yes
-USE_XLIB= yes
+USE_XORG= xxf86dga
. endif
# Vorbis
. if defined(WITH_VORBIS)
diff --git a/games/q3cellshading/Makefile b/games/q3cellshading/Makefile
index 2df4dcdc5f08..f67d74d6c7fa 100644
--- a/games/q3cellshading/Makefile
+++ b/games/q3cellshading/Makefile
@@ -59,7 +59,7 @@ MAKE_ENV+= DLL_ONLY=true
.if !defined(WITHOUT_CLIENT) || !defined(WITHOUT_SMP)
USE_GL= yes
-USE_XLIB= yes
+USE_XORG= xxf86dga
.endif
.if !defined(WITHOUT_CLIENT)
diff --git a/games/quake2forge/Makefile b/games/quake2forge/Makefile
index 0f40e6862b5b..14db55b89f82 100644
--- a/games/quake2forge/Makefile
+++ b/games/quake2forge/Makefile
@@ -36,6 +36,10 @@ LIBDIR= ${PREFIX}/lib/${PORTNAME}
.include <bsd.port.pre.mk>
+.if defined(WITH_GL) || defined(WITH_X11)
+USE_XORG= xxf86dga
+.endif
+
.if defined(WITH_AO)
LIB_DEPENDS+= ao.3:${PORTSDIR}/audio/libao
CONFIGURE_ARGS+=--with-ao=${LOCALBASE}
@@ -93,7 +97,6 @@ PLIST_SUB+= SVGA="@comment "
.endif
.if defined(WITH_X11)
-USE_XLIB= yes
CONFIGURE_ARGS+=--with-x
PLIST_SUB+= X11=""
.else
diff --git a/games/worldofpadman/Makefile b/games/worldofpadman/Makefile
index 1e72cb3d24e0..29131c5d70c0 100644
--- a/games/worldofpadman/Makefile
+++ b/games/worldofpadman/Makefile
@@ -101,7 +101,7 @@ USE_SDL= sdl
MAKE_ENV+= USE_SDL_VIDEO=1
. else
USE_GL= yes
-USE_XLIB= yes
+USE_XORG= xxf86dga
. endif
# Vorbis
. if defined(WITH_VORBIS)