aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-12-10 19:22:29 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 06:06:18 +0800
commit762afcba1871633bd13976bb5fc762903f4a6dc7 (patch)
treeb9e87100c5510e8e62878b8a64b44196efa855dc /games
parenta4c133168b6e727f930b7a1a8bdf4e99b353abe6 (diff)
downloadfreebsd-ports-gnome-762afcba1871633bd13976bb5fc762903f4a6dc7.tar.gz
freebsd-ports-gnome-762afcba1871633bd13976bb5fc762903f4a6dc7.tar.zst
freebsd-ports-gnome-762afcba1871633bd13976bb5fc762903f4a6dc7.zip
- Remove arch limitations
Diffstat (limited to 'games')
-rw-r--r--games/legesmotus/Makefile6
-rw-r--r--games/legesmotus/files/patch-common.mk16
2 files changed, 17 insertions, 5 deletions
diff --git a/games/legesmotus/Makefile b/games/legesmotus/Makefile
index 68f0ad9ad430..d1c4c1ee9c20 100644
--- a/games/legesmotus/Makefile
+++ b/games/legesmotus/Makefile
@@ -11,10 +11,8 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Team-based, networked, 2D shooter set in zero-gravity
LICENSE= GPLv2 GPLv3
-LICENSE_COMB= dual
-
-NOT_FOR_ARCHS= aarch64 armv6 armv7
-NOT_FOR_ARCHS_REASON= fails to build: Disallowed architecture for this platform
+LICENSE_COMB= dual # not GPLv2+
+LICENSE_FILE_GPLv2= ${WRKSRC}/COPYING
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix="${PREFIX}" \
diff --git a/games/legesmotus/files/patch-common.mk b/games/legesmotus/files/patch-common.mk
index 30aaed68355f..e92d58d1463d 100644
--- a/games/legesmotus/files/patch-common.mk
+++ b/games/legesmotus/files/patch-common.mk
@@ -8,7 +8,21 @@
#UNIVERSAL = 1
#NOBUNDLE = 1
-@@ -174,12 +173,10 @@ CXXFLAGS += -Wnon-virtual-dtor
+@@ -84,13 +83,6 @@ ifeq ($(ARCHS),)
+ endif
+ endif
+
+-# Only Mac OS X can use fat binaries
+-ifneq ($(filter $(ARCH),$(ARCHS)),$(ARCH))
+- ifneq ($(MACHINE)-$(ARCH),Darwin-universal)
+- $(error Disallowed architecture for this platform: $(ARCH))
+- endif
+-endif
+-
+ ifeq ($(MACHINE)$(NOBUNDLE),Darwin)
+ export MACOSX_DEPLOYMENT_TARGET=10.4
+ FLAGS_SDL = -I$(FRAMEWORKS)/SDL.framework/Headers
+@@ -174,12 +166,10 @@ CXXFLAGS += -Wnon-virtual-dtor
ifeq ($(DEBUG),1)
RELEASE = debug