aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2000-05-18 23:19:43 +0800
committerade <ade@FreeBSD.org>2000-05-18 23:19:43 +0800
commit79d9191a1688eeaddfd7a68f2a7263d83c81fe27 (patch)
tree9f3a7b48ad3c0ed99b7b3a863bb65b063f25904d /games
parentfbe1c951371e95dcefe09bbd1498d8a134557250 (diff)
downloadfreebsd-ports-gnome-79d9191a1688eeaddfd7a68f2a7263d83c81fe27.tar.gz
freebsd-ports-gnome-79d9191a1688eeaddfd7a68f2a7263d83c81fe27.tar.zst
freebsd-ports-gnome-79d9191a1688eeaddfd7a68f2a7263d83c81fe27.zip
glife is a GNOME version of Conway's classic game of life
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/glife/Makefile26
-rw-r--r--games/glife/distinfo1
-rw-r--r--games/glife/files/patch-ab11
-rw-r--r--games/glife/pkg-comment1
-rw-r--r--games/glife/pkg-descr12
-rw-r--r--games/glife/pkg-plist20
7 files changed, 72 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 336749086ae2..a23c5d8c2a16 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -57,6 +57,7 @@
SUBDIR += gemdropx
SUBDIR += glasteroids
SUBDIR += gleyes
+ SUBDIR += glife
SUBDIR += gltron
SUBDIR += gma
SUBDIR += gno3dtet
diff --git a/games/glife/Makefile b/games/glife/Makefile
new file mode 100644
index 000000000000..714fa80341fa
--- /dev/null
+++ b/games/glife/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: glife
+# Date created: 18th May 2000
+# Whom: Ade Lovett <ade@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= glife
+PORTVERSION= 0.2.1
+CATEGORIES= games gnome
+MASTER_SITES= http://download.sourceforge.net/glife/
+DISTNAME= gLife-${PORTVERSION}
+
+MAINTAINER= ade@FreeBSD.org
+
+LIB_DEPENDS= gnome.3:${PORTSDIR}/x11/gnomelibs \
+ glade.3:${PORTSDIR}/devel/libglade
+
+USE_X_PREFIX= yes
+USE_LIBTOOL= yes
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/games/glife/distinfo b/games/glife/distinfo
new file mode 100644
index 000000000000..2c15ca43a47e
--- /dev/null
+++ b/games/glife/distinfo
@@ -0,0 +1 @@
+MD5 (gLife-0.2.1.tar.gz) = 1176413bec7aad8410f492d8fda43706
diff --git a/games/glife/files/patch-ab b/games/glife/files/patch-ab
new file mode 100644
index 000000000000..e9c873ec9df7
--- /dev/null
+++ b/games/glife/files/patch-ab
@@ -0,0 +1,11 @@
+--- po/Makefile.in.in.orig Fri May 5 04:13:34 2000
++++ po/Makefile.in.in Thu May 18 10:05:59 2000
+@@ -19,7 +19,7 @@
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+ datadir = $(prefix)/@DATADIRNAME@
+-localedir = $(datadir)/locale
++localedir = $(prefix)/share/locale
+ gnulocaledir = $(prefix)/share/locale
+ gettextsrcdir = $(prefix)/share/gettext/po
+ subdir = po
diff --git a/games/glife/pkg-comment b/games/glife/pkg-comment
new file mode 100644
index 000000000000..02c01f6649d2
--- /dev/null
+++ b/games/glife/pkg-comment
@@ -0,0 +1 @@
+Conway's Game of Life for GNOME
diff --git a/games/glife/pkg-descr b/games/glife/pkg-descr
new file mode 100644
index 000000000000..d6728fc652f0
--- /dev/null
+++ b/games/glife/pkg-descr
@@ -0,0 +1,12 @@
+An artificial life implementation using GNOME :)
+
+It will try to emulate an Artificial Society. It will implement
+reproduction, and movement. Movement will be based on the 'vision'
+of the animals. In the future there will also be terrain interaction
+(consume food, and food 'reproduction rate') - this will also come along
+with animal 'metabolism' rates. After this is done, combat and
+'culture' factors will be added - Maybe inheritance.
+
+Among other things :) The aim is to keep everything HIGHLY configurable.
+
+WWW: http://glife.sourceforge.net/
diff --git a/games/glife/pkg-plist b/games/glife/pkg-plist
new file mode 100644
index 000000000000..5c8f62468909
--- /dev/null
+++ b/games/glife/pkg-plist
@@ -0,0 +1,20 @@
+bin/glife
+share/gnome/apps/Games/glife.desktop
+share/gnome/glife/glife.glade
+share/gnome/help/glife/C/appearance.html
+share/gnome/help/glife/C/docbook.css
+share/gnome/help/glife/C/glife-attributes.html
+share/gnome/help/glife/C/glife-bugs.html
+share/gnome/help/glife/C/glife-coord-info.html
+share/gnome/help/glife/C/glife-credits.html
+share/gnome/help/glife/C/glife-intro.html
+share/gnome/help/glife/C/glife-menus.html
+share/gnome/help/glife/C/glife-preferences.html
+share/gnome/help/glife/C/glife-rules.html
+share/gnome/help/glife/C/index.html
+share/gnome/help/glife/C/ln18.html
+share/gnome/help/glife/C/topic.dat
+share/locale/ru/LC_MESSAGES/gLife.mo
+@dirrm share/gnome/help/glife/C
+@dirrm share/gnome/help/glife
+@dirrm share/gnome/glife