aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2013-05-23 10:04:46 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2013-05-23 10:04:46 +0800
commit82b68fd881e226a7d8f1ae852c960351ce6f0eb0 (patch)
tree9ca87be412d4b0cbae9795dd9420bd312336feb8 /games
parenteb86f0b9577f96340a3b3367fbce35434bfe0cd6 (diff)
downloadfreebsd-ports-gnome-82b68fd881e226a7d8f1ae852c960351ce6f0eb0.tar.gz
freebsd-ports-gnome-82b68fd881e226a7d8f1ae852c960351ce6f0eb0.tar.zst
freebsd-ports-gnome-82b68fd881e226a7d8f1ae852c960351ce6f0eb0.zip
- Trim Makefile header
- OptionsNG
Diffstat (limited to 'games')
-rw-r--r--games/agame/Makefile10
-rw-r--r--games/rezerwar/Makefile10
-rw-r--r--games/sdl-ball/Makefile10
-rw-r--r--games/volleyball/Makefile10
4 files changed, 16 insertions, 24 deletions
diff --git a/games/agame/Makefile b/games/agame/Makefile
index 1fb5ca924c4d..caeedc638adf 100644
--- a/games/agame/Makefile
+++ b/games/agame/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: agame
-# Date created: 30 Jul 2006
-# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
-#
+# Created by: Dmitry Marakasov <amdmi3@amdmi3.ru>
# $FreeBSD$
-#
PORTNAME= agame
PORTVERSION= 1577
@@ -35,6 +31,8 @@ DESKTOP_ENTRIES="game" \
"Game;BlocksGame;" \
false
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -Ee 's,wav/|mp3/|img/,${DATADIR}/&,g' ${WRKSRC}/main.c
@@ -45,7 +43,7 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/${dir}/* ${DATADIR}/${dir}/
.endfor
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
post-install:
${MKDIR} ${DOCSDIR}
.for f in ${PORTDOCS}
diff --git a/games/rezerwar/Makefile b/games/rezerwar/Makefile
index 0fe68ce9f798..d06dc78503c4 100644
--- a/games/rezerwar/Makefile
+++ b/games/rezerwar/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: rezerwar
-# Date created: 09 Jul 2009
-# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
-#
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= rezerwar
PORTVERSION= 0.4.2
@@ -26,7 +22,9 @@ CONFIGURE_ENV= TARGET_BIN=${PREFIX}/bin \
PORTDOCS= *
-.if defined(NOPORTDOCS)
+.include <bsd.port.options.mk>
+
+.if ! ${PORT_OPTIONS:MDOCS}
post-patch:
@${REINPLACE_CMD} -e '/TARGET_DOC/ d' ${WRKSRC}/mkfiles/Makefile.main
.endif
diff --git a/games/sdl-ball/Makefile b/games/sdl-ball/Makefile
index 2039af142292..2f09b77a73fd 100644
--- a/games/sdl-ball/Makefile
+++ b/games/sdl-ball/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: sdl-ball
-# Date created: 22 Apr 2008
-# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
-#
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= sdl-ball
PORTVERSION= 1.01
@@ -23,11 +19,13 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
PORTDOCS= *
+.include <bsd.port.options.mk>
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/sdl-ball ${PREFIX}/bin/
${MKDIR} ${DATADIR}
cd ${WRKSRC}/themes && ${COPYTREE_SHARE} . ${DATADIR}/
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
.endif
diff --git a/games/volleyball/Makefile b/games/volleyball/Makefile
index 45a55533126f..69f38bef6a9c 100644
--- a/games/volleyball/Makefile
+++ b/games/volleyball/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: volleyball
-# Date created: 09 Oct 2005
-# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
-#
+# Created by: Dmitry Marakasov <amdmi3@amdmi3.ru>
# $FreeBSD$
-#
PORTNAME= volleyball
PORTVERSION= 0.8.6
@@ -37,6 +33,8 @@ DESKTOP_ENTRIES="Pocket Volleyball" \
"Game;SportsGame;ArcadeGame;" \
false
+.include <bsd.port.options.mk>
+
post-configure:
cd ${WRKDIR}/${PORTNAME}-data-${DATAVERSION} && \
${SETENV} ${CONFIGURE_ENV} ./${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS}
@@ -45,7 +43,7 @@ post-install:
cd ${WRKDIR}/${PORTNAME}-data-${DATAVERSION} && \
${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/