aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2017-12-24 21:55:42 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 06:13:36 +0800
commit85af0885b601fd9eaabddf5bb9d77a1eff440cdf (patch)
tree7b600f481f263f4789843d03be54246a178799bc /games
parente099f0f949f3c59b2b803051726244bc982f839a (diff)
downloadfreebsd-ports-gnome-85af0885b601fd9eaabddf5bb9d77a1eff440cdf.tar.gz
freebsd-ports-gnome-85af0885b601fd9eaabddf5bb9d77a1eff440cdf.tar.zst
freebsd-ports-gnome-85af0885b601fd9eaabddf5bb9d77a1eff440cdf.zip
Convert to USES=autoreconf.
Diffstat (limited to 'games')
-rw-r--r--games/cheech/Makefile15
1 files changed, 5 insertions, 10 deletions
diff --git a/games/cheech/Makefile b/games/cheech/Makefile
index 506db1996711..4dd04fff0290 100644
--- a/games/cheech/Makefile
+++ b/games/cheech/Makefile
@@ -19,9 +19,8 @@ BROKEN= fails to compile: ustring.h: expected ';' at end of declaration list
OPTIONS_DEFINE= DOCS
-USES= gmake pkgconfig tar:tgz
+USES= autoreconf gmake libtool pkgconfig tar:tgz
USE_GNOME= gtkmm24
-USE_AUTOTOOLS= automake:env
GNU_CONFIGURE= yes
DESKTOP_ENTRIES="cheech" \
@@ -32,18 +31,14 @@ DESKTOP_ENTRIES="cheech" \
"false"
post-patch:
- @${REINPLACE_CMD} -e \
- 's|$${prefix}/doc|$$(datadir)/doc| ; \
- /^cheechdoc_DATA/s|COPYING||' ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e \
- '/^AM_CXXFLAGS/s|[[:blank:]]-g||' ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} \
+ -e 's|$${prefix}/doc|$$(datadir)/doc|' \
+ -e 's|COPYING||' ${WRKSRC}/Makefile.am
+ @${REINPLACE_CMD} -e 's|[[:blank:]]-g$$||' ${WRKSRC}/src/Makefile.am
@${REINPLACE_CMD} -e \
's|\([[:blank:]]\)usleep|\1Glib::usleep|' ${WRKSRC}/src/utility.cc
@${REINPLACE_CMD} -e \
's|connect(SigC::slot|connect(sigc::mem_fun|g ; \
s|#include <sigc++\/compatibility\.h>||g' ${WRKSRC}/src/*.cc
-pre-configure:
- @${LN} -sf ${AUTOMAKE_DIR}/install-sh ${WRKSRC}
-
.include <bsd.port.mk>