aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2011-08-13 03:53:09 +0800
committerehaupt <ehaupt@FreeBSD.org>2011-08-13 03:53:09 +0800
commit861ceb5d53894c38af7cbe070c15eebee8bb84c6 (patch)
tree6ef48213593a0377d8caf2755cf6abce166e0a8a /games
parent0e46661a9f28f84166e7b80c1ab35a7d83f76120 (diff)
downloadfreebsd-ports-gnome-861ceb5d53894c38af7cbe070c15eebee8bb84c6.tar.gz
freebsd-ports-gnome-861ceb5d53894c38af7cbe070c15eebee8bb84c6.tar.zst
freebsd-ports-gnome-861ceb5d53894c38af7cbe070c15eebee8bb84c6.zip
- Update MASTER_SITES and WWW: line
- Support OPTIONS to select Motif/GTK toolkit - Add LICENSE - Add MAKE_JOBS_SAFE PR: 159470 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Diffstat (limited to 'games')
-rw-r--r--games/znibbles/Makefile55
-rw-r--r--games/znibbles/files/patch-src::getopt.c10
-rw-r--r--games/znibbles/files/patch-src__Motif__menus.C20
-rw-r--r--games/znibbles/pkg-descr2
-rw-r--r--games/znibbles/pkg-plist3
5 files changed, 67 insertions, 23 deletions
diff --git a/games/znibbles/Makefile b/games/znibbles/Makefile
index e1324814f26b..a4fff68eaa46 100644
--- a/games/znibbles/Makefile
+++ b/games/znibbles/Makefile
@@ -7,22 +7,59 @@
PORTNAME= znibbles
PORTVERSION= 0.0.7
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= games
-MASTER_SITES= http://koala.ilog.fr/ftp/pub/games/znibbles/
+MASTER_SITES= http://old.koalateam.com/ftp/pub/games/znibbles/ \
+ http://www.jfouffa.com/vmallet/archives/
MAINTAINER= ports@FreeBSD.org
COMMENT= A multi-player networked nibbles game
-DEPRECATED= No more public distfiles
-EXPIRATION_DATE= 2011-09-01
+LICENSE= GPLv2 GPLv3
+LICENSE_COMB= dual
+
+OPTIONS= GTK "Build GTK+ client" on
USE_MOTIF= yes
-USE_GNOME= gtk12
+WANT_GNOME= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --without-motif \
- --disable-motif
+MAKE_JOBS_SAFE= yes
+
+MAN6= nibbles.6 znibbles.6 znibblesX.6
+PLIST_FILES= bin/nibbles bin/znibbles bin/znibblesX
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_GTK)
+CONFIGURE_ARGS+=--disable-gtk
+.else
+USE_GNOME+= gtk12
+MAN6+= gznibbles.6
+PLIST_FILES+= bin/gznibbles
+.endif
+
+post-extract:
+ @${RM} -f ${WRKSRC}/src/getopt.h
+# @${LN} -sf /usr/include/getopt.h ${WRKSRC}/src
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ '/^SUBDIRS/s|doc||g' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e \
+ '/^getopt/d ; \
+ s|getopt.[cho]||g ; \
+ s|getopt1.[co]||g' ${WRKSRC}/src/Makefile.in
+.for dir in GTK Motif X11
+ @${REINPLACE_CMD} -e \
+ 's|../getopt.h||g' ${WRKSRC}/src/${dir}/Makefile.in
+.endfor
-MAN6= nibbles.6 znibbles.6 gznibbles.6 znibblesX.6
+post-install:
+ ${INSTALL_MAN} ${WRKSRC}/doc/nibbles.6 ${MAN6PREFIX}/man/man6
+ ${INSTALL_MAN} ${WRKSRC}/doc/znibbles.6 ${MAN6PREFIX}/man/man6
+ ${INSTALL_MAN} ${WRKSRC}/doc/znibblesX.6 ${MAN6PREFIX}/man/man6
+.if !defined(WITHOUT_GTK)
+ ${INSTALL_MAN} ${WRKSRC}/doc/gznibbles.6 ${MAN6PREFIX}/man/man6
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/znibbles/files/patch-src::getopt.c b/games/znibbles/files/patch-src::getopt.c
deleted file mode 100644
index 9ba3f2f0bcae..000000000000
--- a/games/znibbles/files/patch-src::getopt.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/getopt.c Tue Apr 27 09:38:18 1999
-+++ src/getopt.c Sat Oct 26 00:48:50 2002
-@@ -40,6 +40,7 @@
- #endif
-
- #include <stdio.h>
-+#include <string.h>
-
- /* Comment out all this code if we are using the GNU C Library, and are not
- actually compiling the library itself. This code is part of the GNU C
diff --git a/games/znibbles/files/patch-src__Motif__menus.C b/games/znibbles/files/patch-src__Motif__menus.C
new file mode 100644
index 000000000000..154fe9ce08dc
--- /dev/null
+++ b/games/znibbles/files/patch-src__Motif__menus.C
@@ -0,0 +1,20 @@
+--- src/Motif/menus.C.orig 1999-04-14 23:50:14.000000000 +0900
++++ src/Motif/menus.C 2011-08-11 02:41:55.000000000 +0900
+@@ -52,7 +52,7 @@
+ {
+ w = w; cbs = cbs;
+
+- switch( (int) client_data) {
++ switch( (unsigned long) client_data) {
+ case ItemFileQuit:
+ quit();
+ break;
+@@ -64,7 +64,7 @@
+ {
+ w = w; cbs = cbs;
+
+- switch( (int) client_data) {
++ switch( (unsigned long) client_data) {
+ case ItemHelpAbout:
+ if (NULL != mythis->about)
+ mythis->about->show_dialog();
diff --git a/games/znibbles/pkg-descr b/games/znibbles/pkg-descr
index 48d78f3ab190..792487d1f972 100644
--- a/games/znibbles/pkg-descr
+++ b/games/znibbles/pkg-descr
@@ -18,4 +18,4 @@ Once compiled, you get the files:
Run "nibbles" first as the ZNibbles server, and then run its clients to play.
-WWW: http://www.jfouffa.com/v
+WWW: http://www.jfouffa.com/vmallet/ZNibbles.html
diff --git a/games/znibbles/pkg-plist b/games/znibbles/pkg-plist
deleted file mode 100644
index deed2d5b52d0..000000000000
--- a/games/znibbles/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-bin/nibbles
-bin/gznibbles
-bin/znibblesX