aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorlippe <lippe@FreeBSD.org>2013-06-29 02:15:30 +0800
committerlippe <lippe@FreeBSD.org>2013-06-29 02:15:30 +0800
commit86356607c6936b5e2ef3470b0082e43067975f39 (patch)
treefab7f477d436a44a6007d947024c1b0437ed0b57 /games
parentd844002d21f5f93f8015c35dafc0632bb36e4f51 (diff)
downloadfreebsd-ports-gnome-86356607c6936b5e2ef3470b0082e43067975f39.tar.gz
freebsd-ports-gnome-86356607c6936b5e2ef3470b0082e43067975f39.tar.zst
freebsd-ports-gnome-86356607c6936b5e2ef3470b0082e43067975f39.zip
- Trim Makefile
PR: ports/179935 Submitted by: nemysis <nemysis@gmx.ch>
Diffstat (limited to 'games')
-rw-r--r--games/tuxpuck/Makefile31
-rw-r--r--games/tuxpuck/files/patch-utils::Makefile15
2 files changed, 15 insertions, 31 deletions
diff --git a/games/tuxpuck/Makefile b/games/tuxpuck/Makefile
index 6d9c699dab6e..c92208c19af7 100644
--- a/games/tuxpuck/Makefile
+++ b/games/tuxpuck/Makefile
@@ -1,44 +1,43 @@
-# ex:ts=8
-# New ports collection makefile for: tuxpuck
-# Date created: 25 April 2002
-# Whom: Jan Stocker <Jan.Stocker@t-online.de>
-#
+# Created by: Jan Stocker <Jan.Stocker@t-online.de>
# $FreeBSD$
-#
PORTNAME= tuxpuck
PORTVERSION= 0.8.2
-PORTREVISION= 17
+PORTREVISION= 18
CATEGORIES= games
MASTER_SITES= http://www.sourcefiles.org/Games/Sports/Miscellaneous/
MAINTAINER= ports@FreeBSD.org
COMMENT= Shufflepuck Cafe Clone
-LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
+LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
png15:${PORTSDIR}/graphics/png \
- vorbis.4:${PORTSDIR}/audio/libvorbis \
- freetype.9:${PORTSDIR}/print/freetype2
+ vorbis:${PORTSDIR}/audio/libvorbis \
+ freetype:${PORTSDIR}/print/freetype2
USE_SDL= sdl
USE_GMAKE= yes
-ALL_TARGET= tuxpuck
+ALL_TARGET= ${PORTNAME}
MAKE_JOBS_UNSAFE= yes
CFLAGS+= -I${LOCALBASE}/include/libpng15
+
MANCOMPRESSED= yes
-MAN6= tuxpuck.6
-PLIST_FILES= bin/tuxpuck
+
+PLIST_FILES= bin/${PORTNAME}
+
+MAN6= ${PORTNAME}.6
.include <bsd.port.pre.mk>
post-patch:
cd ${WRKSRC}; \
- ${REINPLACE_CMD} "s,timer_create,_timer_create,g" \
+ ${REINPLACE_CMD} 's|timer_create|_timer_create|g' \
tuxpuck.c video.c timer.c intro.c tuxpuck.h
+ ${REINPLACE_CMD} -e 's|sdl-config|$$(SDL_CONFIG)|g' ${WRKSRC}/utils/Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/tuxpuck ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/man/tuxpuck.6.gz ${MANPREFIX}/man/man6
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/man/${MAN6}.gz ${MAN6PREFIX}/man/man6
.include <bsd.port.post.mk>
diff --git a/games/tuxpuck/files/patch-utils::Makefile b/games/tuxpuck/files/patch-utils::Makefile
deleted file mode 100644
index 7e2754fd012e..000000000000
--- a/games/tuxpuck/files/patch-utils::Makefile
+++ /dev/null
@@ -1,15 +0,0 @@
---- utils/Makefile.orig Fri Nov 8 11:50:29 2002
-+++ utils/Makefile Wed Dec 25 15:41:44 2002
-@@ -9,10 +9,10 @@
- $(CC) $(CFLAGS) ttf2font.c `freetype-config --cflags --libs` -o ttf2font
-
- data2c : data2c.c
-- $(CC) $(CFLAGS) data2c.c `sdl-config --cflags --libs` -o data2c
-+ $(CC) $(CFLAGS) data2c.c `$(SDL_CONFIG) --cflags --libs` -o data2c
-
- anim : anim.c
-- $(CC) $(CFLAGS) anim.c `sdl-config --cflags --libs` -o anim
-+ $(CC) $(CFLAGS) anim.c `$(SDL_CONFIG) --cflags --libs` -o anim
-
- clean :
- rm -f *~ data2c ttf2font anim