aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-07-14 03:40:14 +0800
committerpav <pav@FreeBSD.org>2005-07-14 03:40:14 +0800
commit88040637a88d10478cb7ae590a96a2d3a4ebaab5 (patch)
tree24f6460532858330077786411ea375f9d21332f8 /games
parent10257fb6698deb9cd2c784039a4bd282635d25e4 (diff)
downloadfreebsd-ports-gnome-88040637a88d10478cb7ae590a96a2d3a4ebaab5.tar.gz
freebsd-ports-gnome-88040637a88d10478cb7ae590a96a2d3a4ebaab5.tar.zst
freebsd-ports-gnome-88040637a88d10478cb7ae590a96a2d3a4ebaab5.zip
An 3D Air Hockey, which uses SDL & OpenGL with some features like single, and
multiplayer mode, sound fx, music, camera control, etc. PR: ports/83342 Submitted by: Alejandro Pulver <alejandro@varnet.biz>
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/airrox/Makefile103
-rw-r--r--games/airrox/distinfo2
-rw-r--r--games/airrox/files/patch-jogo.cpp20
-rw-r--r--games/airrox/files/pkg-message.in6
-rw-r--r--games/airrox/files/readme.txt41
-rw-r--r--games/airrox/pkg-descr7
-rw-r--r--games/airrox/pkg-plist50
8 files changed, 230 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index bb36fb10343c..13e3114c9165 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -23,6 +23,7 @@
SUBDIR += adonthell
SUBDIR += affenspiel
SUBDIR += afternoonstalker
+ SUBDIR += airrox
SUBDIR += alephone
SUBDIR += alephone-data
SUBDIR += alienblaster
diff --git a/games/airrox/Makefile b/games/airrox/Makefile
new file mode 100644
index 000000000000..172d796a138c
--- /dev/null
+++ b/games/airrox/Makefile
@@ -0,0 +1,103 @@
+# New ports collection makefile for: airrox
+# Date created: 12 Jul 2005
+# Whom: Alejandro Pulver <alejandro@varnet.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= airrox
+PORTVERSION= 0.0.4
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-0.04
+
+MAINTAINER= alejandro@varnet.biz
+COMMENT= An 3D Air Hockey, which uses SDL & OpenGL
+
+LIB_DEPENDS= glut.3:${PORTSDIR}/graphics/libglut
+
+USE_GMAKE= yes
+USE_SDL= mixer net sdl
+USE_GL= yes
+USE_REINPLACE= yes
+REINPLACE_ARGS= -i ''
+
+WRKSRC= ${WRKDIR}/${PORTNAME}/source
+
+OPTIONS= OPTIMIZED_CFLAGS "Enable compilation optimizations" on
+
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+ALL_TARGET= linux
+
+DATADIRS= audio icones imagens meshs texturas
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= need sscanf() interface in libc
+.endif
+
+post-patch:
+# Fix Makefile
+ @${REINPLACE_CMD} -e 's|/usr/X11R6|${X11BASE}|g ; \
+ s|-lSDL ||g ; \
+ s|-lpthread||g ; \
+ s|sdl-config|${SDL_CONFIG}|g ; \
+ s|\(-O2\)|${CFLAGS} -I${X11BASE}/include \
+ `${SDL_CONFIG} --cflags` \1| ; \
+ s|$$(INCLUDEWIN)||g ; \
+ s|g++|${CXX}|g' \
+ ${WRKSRC}/${MAKEFILE}
+
+# Fix SDL include statement
+.for f in *.cpp *.h
+ @${FIND} ${WRKSRC} -type f -name "${f}" -print0 | \
+ ${XARGS} -0 ${REINPLACE_CMD} -e \
+ 's|\(#include.*\)SDL/\(SDL.*\)|\1\2|'
+.endfor
+
+# Fix paths to ${DATADIR}
+.for d in ${DATADIRS}
+ @${REINPLACE_CMD} -e 's|../\(${d}/\)|${DATADIR}/\1|' \
+ ${WRKSRC}/*.cpp ${WRKSRC}/*.h
+.endfor
+
+# Enable/disable compilation optimizations
+.if !defined(WITH_OPTIMIZED_CFLAGS)
+ @${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${MAKEFILE}
+.endif
+
+do-install:
+# Program
+ @${INSTALL_PROGRAM} ${WRKSRC}/air ${PREFIX}/bin/${PORTNAME}
+
+# Data
+ @${MKDIR} ${DATADIR}
+
+# Data: directories
+.for d in ${DATADIRS}
+ @${CP} -R ${WRKDIR}/${PORTNAME}/${d} ${DATADIR}
+.endfor
+
+# Data: config.txt
+ @${INSTALL_DATA} ${WRKSRC}/config.txt ${DATADIR}
+
+# Remove CVS directories
+ @${FIND} ${DATADIR} -type d -name "CVS" -print0 | \
+ ${XARGS} -0 ${RM} -rf
+
+# Documentation (optional)
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${FILESDIR}/readme.txt ${DOCSDIR}
+.endif
+
+post-install:
+ @${ECHO_CMD}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_CMD}
+
+.include <bsd.port.post.mk>
diff --git a/games/airrox/distinfo b/games/airrox/distinfo
new file mode 100644
index 000000000000..55e9bc4a2e97
--- /dev/null
+++ b/games/airrox/distinfo
@@ -0,0 +1,2 @@
+MD5 (airrox-0.04.tar.gz) = aff01d8a559478185b2e1be19fda8ad2
+SIZE (airrox-0.04.tar.gz) = 2750961
diff --git a/games/airrox/files/patch-jogo.cpp b/games/airrox/files/patch-jogo.cpp
new file mode 100644
index 000000000000..3e63c68bb123
--- /dev/null
+++ b/games/airrox/files/patch-jogo.cpp
@@ -0,0 +1,20 @@
+--- jogo.cpp.orig Sat Oct 9 10:35:22 2004
++++ jogo.cpp Tue Jul 12 15:28:30 2005
+@@ -45,7 +45,16 @@
+
+ void Jogo::inicializacao()
+ {
+- config = new Config("config.txt");
++ char *home, *pathtocfg, *cfgname = ".airrox";
++ int len1, len2;
++
++ home = getenv("HOME");
++ len1 = strlen(home);
++ len2 = strlen(cfgname);
++ pathtocfg = new char[len1 + len2];
++ sprintf(pathtocfg, "%s/%s", home, cfgname);
++
++ config = new Config(pathtocfg);
+ // parametros de configuracao
+ config->cria("TelaLargura", INT);
+ config->cria("TelaAltura", INT);
diff --git a/games/airrox/files/pkg-message.in b/games/airrox/files/pkg-message.in
new file mode 100644
index 000000000000..d42e1f828321
--- /dev/null
+++ b/games/airrox/files/pkg-message.in
@@ -0,0 +1,6 @@
+To play airrox you have to copy the file %%DATADIR%%/config.txt to your
+home directory, with the name ".airrox".
+
+Example:
+
+cp %%DATADIR%%/config.txt ~/.airrox
diff --git a/games/airrox/files/readme.txt b/games/airrox/files/readme.txt
new file mode 100644
index 000000000000..7d67f481b06c
--- /dev/null
+++ b/games/airrox/files/readme.txt
@@ -0,0 +1,41 @@
+Match options:
+
+Key Esc - Exit game
+
+Visualization options:
+
+Key F11 - Decrease video resolution
+Key F12 - Increase video resolution
+Key Ctrl F - Toggle Full Screen
+
+Control options:
+
+Key F9 - Decrease mouse sensibility
+Key F10 - Increase mouse sensibility
+
+Player movement:
+
+Mouse
+
+Camera options:
+
+Key Up - Increase Zoom
+Key Down - Decrease Zoom
+Key Right - Rotate Right
+Key Left - Rotate Left
+Key F5 - Stop Camera
+Key F6 - Complete turn around the table
+Key F7 - TV Camera Mode
+Mouse Wheel - Move camera vertically
+
+Sound options:
+
+Key + - Increase music volume
+Key - - Decrease music volume
+
+Command-line options:
+
+Server: airrox S <port>
+Client: airrox C <host> <port>
+Spectator: airrox O <host> <port>
+Single Player: airrox P
diff --git a/games/airrox/pkg-descr b/games/airrox/pkg-descr
new file mode 100644
index 000000000000..f13f8b5b5e23
--- /dev/null
+++ b/games/airrox/pkg-descr
@@ -0,0 +1,7 @@
+An 3D Air Hockey, which uses SDL & OpenGL with some features like single, and
+multiplayer mode, sound fx, music, camera control, etc.
+
+WWW: http://twiki.im.ufba.br/bin/view/Indigente/AirroX
+
+- Alejandro Pulver
+alejandro@varnet.biz
diff --git a/games/airrox/pkg-plist b/games/airrox/pkg-plist
new file mode 100644
index 000000000000..5ec3c940fa82
--- /dev/null
+++ b/games/airrox/pkg-plist
@@ -0,0 +1,50 @@
+bin/airrox
+%%DATADIR%%/audio/fx/colisaodiscojogador.wav
+%%DATADIR%%/audio/fx/colisaodiscomesa.wav
+%%DATADIR%%/audio/fx/fxlist
+%%DATADIR%%/audio/fx/gol.wav
+%%DATADIR%%/audio/music/playlist
+%%DATADIR%%/audio/music/soumn_-_now_is_the_time_to_try_something_new.ogg
+%%DATADIR%%/icones/airrox.bmp
+%%DATADIR%%/imagens/mjogar.bmp
+%%DATADIR%%/imagens/mjogar1.bmp
+%%DATADIR%%/imagens/mjogar1h.bmp
+%%DATADIR%%/imagens/mjogar2.bmp
+%%DATADIR%%/imagens/mjogar2h.bmp
+%%DATADIR%%/imagens/mjogar3.bmp
+%%DATADIR%%/imagens/mjogar3h.bmp
+%%DATADIR%%/imagens/mjogarh.bmp
+%%DATADIR%%/imagens/mobs.bmp
+%%DATADIR%%/imagens/mobsh.bmp
+%%DATADIR%%/imagens/msair.bmp
+%%DATADIR%%/imagens/msairh.bmp
+%%DATADIR%%/meshs/mallet.3ds
+%%DATADIR%%/meshs/mesa.3ds
+%%DATADIR%%/meshs/placar.3ds
+%%DATADIR%%/meshs/puck.3ds
+%%DATADIR%%/texturas/display0.bmp
+%%DATADIR%%/texturas/display1.bmp
+%%DATADIR%%/texturas/display2.bmp
+%%DATADIR%%/texturas/display3.bmp
+%%DATADIR%%/texturas/display4.bmp
+%%DATADIR%%/texturas/display5.bmp
+%%DATADIR%%/texturas/display6.bmp
+%%DATADIR%%/texturas/display7.bmp
+%%DATADIR%%/texturas/display8.bmp
+%%DATADIR%%/texturas/display9.bmp
+%%DATADIR%%/texturas/logomesa.bmp
+%%DATADIR%%/texturas/mallet.bmp
+%%DATADIR%%/texturas/mesa.bmp
+%%DATADIR%%/texturas/placar.bmp
+%%DATADIR%%/texturas/puck.bmp
+%%DATADIR%%/config.txt
+%%PORTDOCS%%%%DOCSDIR%%/readme.txt
+@dirrm %%DATADIR%%/texturas
+@dirrm %%DATADIR%%/meshs
+@dirrm %%DATADIR%%/imagens
+@dirrm %%DATADIR%%/icones
+@dirrm %%DATADIR%%/audio/music
+@dirrm %%DATADIR%%/audio/fx
+@dirrm %%DATADIR%%/audio
+@dirrm %%DATADIR%%
+@dirrm %%DOCSDIR%%