aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2013-09-29 19:16:46 +0800
committermadpilot <madpilot@FreeBSD.org>2013-09-29 19:16:46 +0800
commit906fae7f20d1c5c03c811fc1a10459ef51569c72 (patch)
tree9dc563d29bb217e06d2c7d6010af07123764935c /games
parent9d37c25d198c5a305edb5cc5cc3a3b10a745d28c (diff)
downloadfreebsd-ports-gnome-906fae7f20d1c5c03c811fc1a10459ef51569c72.tar.gz
freebsd-ports-gnome-906fae7f20d1c5c03c811fc1a10459ef51569c72.tar.zst
freebsd-ports-gnome-906fae7f20d1c5c03c811fc1a10459ef51569c72.zip
- Support staging
- Convert to new LIB_DEPENDS format - Use options helpers - Don't check for ARCH in compiler conditional.
Diffstat (limited to 'games')
-rw-r--r--games/corsix-th/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/games/corsix-th/Makefile b/games/corsix-th/Makefile
index 310764972009..809ca2e37845 100644
--- a/games/corsix-th/Makefile
+++ b/games/corsix-th/Makefile
@@ -27,14 +27,14 @@ OPTIONS_DEFINE= MOVIES
OPTIONS_DEFAULT= MOVIES
MOVIES_DESC= Play in-game movies
-NO_STAGE= yes
+MOVIES_CMAKE_ON= -DWITH_MOVIES=ON
+MOVIES_CMAKE_OFF= -DWITH_MOVIES=OFF
+MOVIES_LIB_DEPENDS= libswresample1.so:${PORTSDIR}/multimedia/ffmpeg1
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MMOVIES}
-CMAKE_ARGS+= -DWITH_MOVIES=ON
-LIB_DEPENDS+= swresample1:${PORTSDIR}/multimedia/ffmpeg1
# partly copied from editors/libreoffice
-.if ${ARCH} == "i386"
.if exists(/usr/bin/clang) && ${OSVERSION} > 900014
CC= /usr/bin/clang
CPP= /usr/bin/clang-cpp
@@ -43,9 +43,6 @@ CXX= /usr/bin/clang++
USE_GCC= yes
.endif
.endif
-.else
-CMAKE_ARGS+= -DWITH_MOVIES=OFF
-.endif
post-patch:
# Allow the game to find its resources without wrapper scripts
@@ -54,10 +51,10 @@ post-patch:
${WRKSRC}/CorsixTH/Src/main.cpp
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/CorsixTH/CorsixTH ${PREFIX}/bin
- @${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/CorsixTH/CorsixTH.lua ${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/CorsixTH/CorsixTH ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/CorsixTH/CorsixTH.lua ${STAGEDIR}${DATADIR}
cd ${WRKSRC}/CorsixTH && ${COPYTREE_SHARE} "Bitmap Levels Lua" \
- ${DATADIR}
+ ${STAGEDIR}${DATADIR}
.include <bsd.port.mk>