aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2013-09-25 11:47:08 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2013-09-25 11:47:08 +0800
commit97a4c2caa8dc0acb750e9540f6cf442340b2d7c2 (patch)
tree7e6176f7f75bb337ea041150330055510a415b01 /games
parent0715806f8b977a6b0e611bbd0506056d4810497d (diff)
downloadfreebsd-ports-gnome-97a4c2caa8dc0acb750e9540f6cf442340b2d7c2.tar.gz
freebsd-ports-gnome-97a4c2caa8dc0acb750e9540f6cf442340b2d7c2.tar.zst
freebsd-ports-gnome-97a4c2caa8dc0acb750e9540f6cf442340b2d7c2.zip
- Support staging
- Use new LIB_DEPENDS syntax - Fix NLS support in games/plee-the-bear
Diffstat (limited to 'games')
-rw-r--r--games/plee-the-bear/Makefile26
-rw-r--r--games/plee-the-bear/pkg-plist2
2 files changed, 13 insertions, 15 deletions
diff --git a/games/plee-the-bear/Makefile b/games/plee-the-bear/Makefile
index a9e086af2075..73625c810e2e 100644
--- a/games/plee-the-bear/Makefile
+++ b/games/plee-the-bear/Makefile
@@ -12,13 +12,13 @@ COMMENT= 2D platform jump and run game
LICENSE= GPLv2 CCbySA3
LICENSE_COMB= dual
-LICENSE_NAME_CCbySA3=Attribution-ShareAlike 3.0 Unported
-LICENSE_FILE_CCbySA3=${WRKSRC}/CCPL
-LICENSE_PERMS_CCbySA3=dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+LICENSE_NAME_CCbySA3= Attribution-ShareAlike 3.0 Unported
+LICENSE_FILE_CCbySA3= ${WRKSRC}/CCPL
+LICENSE_PERMS_CCbySA3= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
BUILD_DEPENDS= docbook-to-man:${PORTSDIR}/textproc/docbook-to-man
-LIB_DEPENDS= boost_filesystem:${PORTSDIR}/devel/boost-libs \
- claw_application:${PORTSDIR}/devel/libclaw
+LIB_DEPENDS= libboost_filesystem.so:${PORTSDIR}/devel/boost-libs \
+ libclaw_application.so:${PORTSDIR}/devel/libclaw
USE_SDL= sdl mixer
USE_GL= gl glu
@@ -26,26 +26,22 @@ WANT_GNOME= yes
INSTALLS_ICONS= yes
USE_LDCONFIG= yes
-USES= cmake
+# gettext dep is unconditional; NLS option just disables translations install
+USES= cmake gettext
CMAKE_ARGS= -Dlibclaw_DIR="${LOCALBASE}/share/libclaw/cmake" \
-DBEAR_NO_EDITOR=YES
-MAN6= plee-the-bear.6 running-bear.6
+OPTIONS_DEFINE= NLS
+OPTIONS_DEFAULT=NLS
+OPTIONS_SUB= yes
-NO_STAGE= yes
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-PLIST_SUB+= NLS="@comment "
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|share/man|man|' ${WRKSRC}/CMakeLists.txt
.if ! ${PORT_OPTIONS:MNLS}
@${REINPLACE_CMD} -e 's|locale||' \
+ ${WRKSRC}/bear-factory/desktop/CMakeLists.txt \
${WRKSRC}/bear-engine/desktop/CMakeLists.txt \
${WRKSRC}/plee-the-bear/desktop/CMakeLists.txt
.endif
diff --git a/games/plee-the-bear/pkg-plist b/games/plee-the-bear/pkg-plist
index d9083b50cff9..d28e336924a6 100644
--- a/games/plee-the-bear/pkg-plist
+++ b/games/plee-the-bear/pkg-plist
@@ -13,6 +13,8 @@ lib/libbear_time.so
lib/libbear_universe.so
lib/libbear_visual.so
lib/libplee_the_bear.so
+man/man6/plee-the-bear.6.gz
+man/man6/running-bear.6.gz
share/applications/plee-the-bear.desktop
share/bear-factory/plee-the-bear/item-description/action_file_recorder.xml
share/bear-factory/plee-the-bear/item-description/add_ingame_layers.xml