aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2013-04-17 21:46:37 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2013-04-17 21:46:37 +0800
commit9c52e007c4ab62f267719435c77922e756e1c24b (patch)
treeda15a3dab308809e455aea31f8ef0f8238ae3cb7 /games
parent7c22b64b259c77bc6444f8e6ef430da46d55643e (diff)
downloadfreebsd-ports-gnome-9c52e007c4ab62f267719435c77922e756e1c24b.tar.gz
freebsd-ports-gnome-9c52e007c4ab62f267719435c77922e756e1c24b.tar.zst
freebsd-ports-gnome-9c52e007c4ab62f267719435c77922e756e1c24b.zip
- Update to 1.4
Feature safe: yes
Diffstat (limited to 'games')
-rw-r--r--games/redeclipse/Makefile37
-rw-r--r--games/redeclipse/distinfo4
-rw-r--r--games/redeclipse/files/patch-src-core.mk (renamed from games/redeclipse/files/patch-src_Makefile)8
-rw-r--r--games/redeclipse/files/reclient.in3
-rw-r--r--games/redeclipse/files/redeclipse.in3
-rw-r--r--games/redeclipse/files/redeclipse_server.in3
-rw-r--r--games/redeclipse/files/reserver.in3
7 files changed, 34 insertions, 27 deletions
diff --git a/games/redeclipse/Makefile b/games/redeclipse/Makefile
index b1c102b59fd1..3d93f94f1472 100644
--- a/games/redeclipse/Makefile
+++ b/games/redeclipse/Makefile
@@ -2,11 +2,10 @@
# $FreeBSD$
PORTNAME= redeclipse
-PORTVERSION= 1.3.1
-PORTREVISION= 1
+PORTVERSION= 1.4
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}_${PORTVERSION:C/^([0-9]+\.[0-9]+)\..*/\1/}
-DISTNAME= ${PORTNAME}_${PORTVERSION}_nix_bsd
+DISTNAME= ${PORTNAME}_${PORTVERSION}_nix
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Single-player and multi-player first-person ego-shooter
@@ -21,17 +20,19 @@ GNU_CONFIGURE= yes
USE_BZIP2= yes
CONFIGURE_WRKSRC= ${WRKSRC}/src/enet
CONFIGURE_ARGS= --enable-shared=no --enable-static=yes
+USE_AUTOTOOLS= aclocal:env automake:env autoconf:env
BUILD_WRKSRC= ${WRKSRC}/src
-WRKSRC= ${WRKDIR}/${PORTNAME}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-ALL_TARGET= libenet ${BINARIES}
+ALL_TARGET= libenet
MAKE_JOBS_SAFE= yes
-SUB_FILES= reclient reserver
+SUB_FILES= redeclipse redeclipse_server
PORTDATA= *
+PORTDOCS= *
-OPTIONS_DEFINE= OPTIMIZED_CFLAGS
+OPTIONS_DEFINE= OPTIMIZED_CFLAGS DOCS
OPTIONS_MULTI= COMPONENTS
OPTIONS_MULTI_COMPONENTS=CLIENT DEDICATED
OPTIONS_DEFAULT=CLIENT DEDICATED OPTIMIZED_CFLAGS
@@ -47,20 +48,22 @@ BROKEN= does not build on sparc64
.if ${PORT_OPTIONS:MCLIENT}
USE_GL= yes
USE_SDL= image mixer sdl
-PLIST_FILES+= bin/reclient libexec/reclient share/pixmaps/redeclipse.ico
-BINARIES+= client
+PLIST_FILES+= bin/redeclipse libexec/redeclipse share/pixmaps/redeclipse.ico
+BINARIES+= redeclipse
+ALL_TARGET+= client
DESKTOP_ENTRIES="Red Eclipse" \
"${COMMENT}" \
"${PREFIX}/share/pixmaps/redeclipse.ico" \
- "reclient" \
+ "redeclipse" \
"Game;" \
false
.endif
.if ${PORT_OPTIONS:MDEDICATED}
-PLIST_FILES+= bin/reserver libexec/reserver
-BINARIES+= server
+PLIST_FILES+= bin/redeclipse_server libexec/redeclipse_server
+BINARIES+= redeclipse_server
+ALL_TARGET+= server
.endif
.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
@@ -70,12 +73,16 @@ CXXFLAGS+= -O3 -fomit-frame-pointer
do-install:
.for f in ${BINARIES}
- ${INSTALL_SCRIPT} ${WRKDIR}/re${f} ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/re${f} ${PREFIX}/libexec
+ ${INSTALL_SCRIPT} ${WRKDIR}/${f} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${f} ${PREFIX}/libexec
.endfor
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC}/doc && ${COPYTREE_SHARE} "*" ${DOCSDIR}/
+.endif
.if !defined(NOPORTDATA)
${MKDIR} ${DATADIR}
- cd ${WRKSRC}/data && ${COPYTREE_SHARE} "." ${DATADIR}/
+ cd ${WRKSRC} && ${COPYTREE_SHARE} "game data" ${DATADIR}/
.endif
.if ${PORT_OPTIONS:MCLIENT}
${INSTALL_DATA} ${WRKSRC}/src/redeclipse.ico ${PREFIX}/share/pixmaps/
diff --git a/games/redeclipse/distinfo b/games/redeclipse/distinfo
index 45e1ee95576e..ce8e5cd094b9 100644
--- a/games/redeclipse/distinfo
+++ b/games/redeclipse/distinfo
@@ -1,2 +1,2 @@
-SHA256 (redeclipse_1.3.1_nix_bsd.tar.bz2) = e29bc8a148c00b8a62b0e77752b7494f0d36f428cb4f24e9b5dc40cdcd67254e
-SIZE (redeclipse_1.3.1_nix_bsd.tar.bz2) = 505092683
+SHA256 (redeclipse_1.4_nix.tar.bz2) = a0dfc527b0f437170a423b55df68a97e1b6e60d8c9fb6c842519b6670c1e69bf
+SIZE (redeclipse_1.4_nix.tar.bz2) = 678617164
diff --git a/games/redeclipse/files/patch-src_Makefile b/games/redeclipse/files/patch-src-core.mk
index cf4e5b55f3f6..8171278c6e52 100644
--- a/games/redeclipse/files/patch-src_Makefile
+++ b/games/redeclipse/files/patch-src-core.mk
@@ -1,14 +1,14 @@
---- src/Makefile.orig 2012-08-31 09:59:06.000000000 +0400
-+++ src/Makefile 2012-09-03 02:40:29.298539115 +0400
+--- src/core.mk.orig 2013-03-21 23:45:14.000000000 +0400
++++ src/core.mk 2013-04-16 21:14:33.351621428 +0400
@@ -3,7 +3,6 @@
- APPSERVER=reserver
+ APPSERVER=$(APPNAME)_server
#CXXFLAGS= -ggdb3
-CXXFLAGS= -O3 -fomit-frame-pointer
override CXXFLAGS+= -Wall -fsigned-char -fno-exceptions -fno-rtti
PLATFORM= $(shell uname -s)
-@@ -41,8 +40,8 @@
+@@ -65,8 +64,8 @@
CLIENT_INCLUDES= $(INCLUDES) -Iinclude
CLIENT_LIBS= -mwindows $(STD_LIBS) -L$(WINBIN) -L$(WINLIB) -lSDL -lSDL_image -lSDL_mixer -lzlib1 -lopengl32 -lenet -lws2_32 -lwinmm
else
diff --git a/games/redeclipse/files/reclient.in b/games/redeclipse/files/reclient.in
deleted file mode 100644
index 9f2c486c229d..000000000000
--- a/games/redeclipse/files/reclient.in
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-
-cd %%DATADIR%% && exec %%PREFIX%%/libexec/reclient "$@"
diff --git a/games/redeclipse/files/redeclipse.in b/games/redeclipse/files/redeclipse.in
new file mode 100644
index 000000000000..5e85841d7f38
--- /dev/null
+++ b/games/redeclipse/files/redeclipse.in
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+cd %%DATADIR%% && exec %%PREFIX%%/libexec/redeclipse "$@"
diff --git a/games/redeclipse/files/redeclipse_server.in b/games/redeclipse/files/redeclipse_server.in
new file mode 100644
index 000000000000..97aa8ccf3779
--- /dev/null
+++ b/games/redeclipse/files/redeclipse_server.in
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+cd %%DATADIR%% && exec %%PREFIX%%/libexec/redeclipse_server "$@"
diff --git a/games/redeclipse/files/reserver.in b/games/redeclipse/files/reserver.in
deleted file mode 100644
index 2ea2528cf46b..000000000000
--- a/games/redeclipse/files/reserver.in
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-
-cd %%DATADIR%% && exec %%PREFIX%%/libexec/reserver "$@"