aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2013-09-14 01:14:53 +0800
committermadpilot <madpilot@FreeBSD.org>2013-09-14 01:14:53 +0800
commita449e66640f4e67f3d5033c093a6215fcc21316f (patch)
treedb7d60e9baca3e8f203bee4b35e80db32ed1fe56 /games
parented34fae3a7e3b290ef9af0be0e39c448dfdc8f83 (diff)
downloadfreebsd-ports-gnome-a449e66640f4e67f3d5033c093a6215fcc21316f.tar.gz
freebsd-ports-gnome-a449e66640f4e67f3d5033c093a6215fcc21316f.tar.zst
freebsd-ports-gnome-a449e66640f4e67f3d5033c093a6215fcc21316f.zip
- Fix build after iconv change [1]
- Fix build with clang/libc++ ([2] for graphics/ipe) While here for databases/spatialite: - Trim Makefile headers - Remove check for unsupported FreeBSD versions Submitted by: marino [1] Reported by: swills, antoine [1] Submitted by: bsam [2] Approved by: portmgr (bapt, implicit)
Diffstat (limited to 'games')
-rw-r--r--games/macopix/Makefile4
-rw-r--r--games/macopix/files/patch-src-callbacks.c20
-rw-r--r--games/macopix/files/patch-src-gui.c20
-rw-r--r--games/macopix/files/patch-src-mail.c20
-rw-r--r--games/macopix/files/patch-src-sockmsg.c11
-rw-r--r--games/supertux-devel/Makefile3
-rw-r--r--games/supertux-devel/files/patch-src-scripting-sound_error.hpp10
-rw-r--r--games/supertux-devel/files/patch-src-scripting-squirrel_error.hpp10
-rw-r--r--games/teg/Makefile4
-rw-r--r--games/tuxtype/Makefile2
-rw-r--r--games/valyriatear/Makefile2
11 files changed, 99 insertions, 7 deletions
diff --git a/games/macopix/Makefile b/games/macopix/Makefile
index 2ab9e5647212..f504b8f16b13 100644
--- a/games/macopix/Makefile
+++ b/games/macopix/Makefile
@@ -30,13 +30,13 @@ RESTRICTED_FILES= \
macopix-mascot-HxB-euc-ja-0.30.tar.gz
WANT_GNOME= yes
-USES= gettext gmake pkgconfig
+USES= gettext gmake iconv pkgconfig
GNU_CONFIGURE= yes
MAN1= macopix.1
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
.if defined(WITH_GNUTLS)
LIB_DEPENDS+= gnutls.26:${PORTSDIR}/security/gnutls
diff --git a/games/macopix/files/patch-src-callbacks.c b/games/macopix/files/patch-src-callbacks.c
new file mode 100644
index 000000000000..9e0243b61d61
--- /dev/null
+++ b/games/macopix/files/patch-src-callbacks.c
@@ -0,0 +1,20 @@
+--- src/callbacks.c.orig 2008-05-25 07:40:08.000000000 +0200
++++ src/callbacks.c 2013-09-13 17:00:08.911683055 +0200
+@@ -509,7 +509,7 @@
+ if((win_bar_size==0)&&(mascot->no_capbar)){
+ // for windows w/o title bar
+ flag_homepos=mascot->homepos_nb;
+- if(flag_homepos==HOMEPOS_NEVER) return;
++ if(flag_homepos==HOMEPOS_NEVER) return(0);
+ }
+ }
+ //win_bar_size=0;
+@@ -538,7 +538,7 @@
+ if((win_bar_size==0)&&(mascot->no_capbar)){
+ // for windows w/o title bar
+ flag_homepos=mascot->homepos_nb;
+- if(flag_homepos==HOMEPOS_NEVER) return;
++ if(flag_homepos==HOMEPOS_NEVER) return(0);
+ }
+ break;
+ }
diff --git a/games/macopix/files/patch-src-gui.c b/games/macopix/files/patch-src-gui.c
new file mode 100644
index 000000000000..f87ab45ff531
--- /dev/null
+++ b/games/macopix/files/patch-src-gui.c
@@ -0,0 +1,20 @@
+--- src/gui.c.orig 2008-06-24 06:44:20.000000000 +0200
++++ src/gui.c 2013-09-13 14:36:40.096276204 +0200
+@@ -4557,7 +4557,7 @@
+ gchar *dest_file;
+
+ if(flagChildDialog){
+- return;
++ return(NULL);
+ }
+ else{
+ flagChildDialog=TRUE;
+@@ -4637,7 +4637,7 @@
+ char win_title[64];
+
+ if(flagChildDialog){
+- return;
++ return(NULL);
+ }
+ else{
+ flagChildDialog=TRUE;
diff --git a/games/macopix/files/patch-src-mail.c b/games/macopix/files/patch-src-mail.c
new file mode 100644
index 000000000000..d631d7be6aca
--- /dev/null
+++ b/games/macopix/files/patch-src-mail.c
@@ -0,0 +1,20 @@
+--- src/mail.c.orig 2008-05-24 01:14:42.000000000 +0200
++++ src/mail.c 2013-09-13 17:37:30.649560538 +0200
+@@ -1422,7 +1422,7 @@
+ froms=strbuf(NULL);
+
+ if((fp=fopen(mascot->mail.file,"r"))==NULL){
+- return;
++ return(NULL);
+ }
+
+ while(!feof(fp)){
+@@ -1545,7 +1545,7 @@
+ froms=strbuf(NULL);
+
+ if ((dp=opendir(mascot->mail.file))==NULL){
+- return;
++ return(NULL);
+ }
+
+
diff --git a/games/macopix/files/patch-src-sockmsg.c b/games/macopix/files/patch-src-sockmsg.c
new file mode 100644
index 000000000000..014e1739c78a
--- /dev/null
+++ b/games/macopix/files/patch-src-sockmsg.c
@@ -0,0 +1,11 @@
+--- src/sockmsg.c.orig 2008-05-02 16:05:30.000000000 +0200
++++ src/sockmsg.c 2013-09-13 17:59:53.072457158 +0200
+@@ -276,7 +276,7 @@
+
+ fd_close(fd);
+
+- if(readsize<4) return;
++ if(readsize<4) return(0);
+
+ strncpy(tmp,buf,2);
+ mode=atoi(tmp);
diff --git a/games/supertux-devel/Makefile b/games/supertux-devel/Makefile
index 0da111f58681..32655a488001 100644
--- a/games/supertux-devel/Makefile
+++ b/games/supertux-devel/Makefile
@@ -18,7 +18,8 @@ USE_BZIP2= yes
USE_SDL= image
USE_OPENAL= al
USE_GL= glew
-USES= cmake:outsource
+USES= cmake:outsource iconv
+LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
post-patch:
${REINPLACE_CMD} -e '/^Icon=/s,supertux.png,supertux2.png,' \
diff --git a/games/supertux-devel/files/patch-src-scripting-sound_error.hpp b/games/supertux-devel/files/patch-src-scripting-sound_error.hpp
new file mode 100644
index 000000000000..7af70a199150
--- /dev/null
+++ b/games/supertux-devel/files/patch-src-scripting-sound_error.hpp
@@ -0,0 +1,10 @@
+--- src/audio/sound_error.hpp.orig 2013-07-09 01:03:45.000000000 +0200
++++ src/audio/sound_error.hpp 2013-09-13 17:09:14.252645154 +0200
+@@ -18,6 +18,7 @@
+ #define HEADER_SUPERTUX_AUDIO_SOUND_ERROR_HPP
+
+ #include <stdexcept>
++#include <string>
+
+ class SoundError : public std::exception
+ {
diff --git a/games/supertux-devel/files/patch-src-scripting-squirrel_error.hpp b/games/supertux-devel/files/patch-src-scripting-squirrel_error.hpp
new file mode 100644
index 000000000000..71b5cfa7eac6
--- /dev/null
+++ b/games/supertux-devel/files/patch-src-scripting-squirrel_error.hpp
@@ -0,0 +1,10 @@
+--- src/scripting/squirrel_error.hpp.orig 2013-07-09 01:03:45.000000000 +0200
++++ src/scripting/squirrel_error.hpp 2013-09-13 14:48:42.828225953 +0200
+@@ -19,6 +19,7 @@
+
+ #include <squirrel.h>
+ #include <stdexcept>
++#include <string>
+
+ namespace scripting {
+
diff --git a/games/teg/Makefile b/games/teg/Makefile
index f16ca86e9d3f..c5e0b9faaf09 100644
--- a/games/teg/Makefile
+++ b/games/teg/Makefile
@@ -10,11 +10,11 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= A turn-based strategy game for GNOME
-USES= pathfix gmake pkgconfig
+USES= pathfix gmake iconv pkgconfig
USE_GNOME= gnomeprefix intlhack libgnomeui
USE_AUTOTOOLS= libtool
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
CONFIGURE_ARGS= --disable-ggz
GCONF_SCHEMAS= teg.schemas
diff --git a/games/tuxtype/Makefile b/games/tuxtype/Makefile
index 8f9b03d3ea7f..b680dffa74fa 100644
--- a/games/tuxtype/Makefile
+++ b/games/tuxtype/Makefile
@@ -33,7 +33,7 @@ CONFIGURE_ENV= T4K_COMMON_CFLAGS="-I${T4K_WRKSRC}/src" \
CPPFLAGS+= $$(pkg-config --cflags SDL_Pango) -I${LOCALBASE}/include \
-DHAVE_ALPHASORT -DHAVE_SCANDIR -DHAVE_FSYNC -DICONV_CONST=""
-LDFLAGS+= $$(pkg-config --libs SDL_Pango) -L${LOCALBASE}/lib
+LDFLAGS+= $$(pkg-config --libs SDL_Pango) -L${LOCALBASE}/lib ${ICONV_LIB}
T4K_NAME= t4k_common
T4K_VERSION= 0.1.1
diff --git a/games/valyriatear/Makefile b/games/valyriatear/Makefile
index 64a29128e019..0d1fab0d1988 100644
--- a/games/valyriatear/Makefile
+++ b/games/valyriatear/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= boost_thread:${PORTSDIR}/devel/boost-libs \
png15:${PORTSDIR}/graphics/png \
jpeg:${PORTSDIR}/graphics/jpeg
-USES= cmake gettext
+USES= cmake gettext iconv
USE_SDL= sdl image ttf
USE_GL= gl
USE_OPENAL= yes