aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2013-06-23 05:38:17 +0800
committerrakuco <rakuco@FreeBSD.org>2013-06-23 05:38:17 +0800
commita6d5f14c323acb9ab5b3c6a40c06c3ded370d1c9 (patch)
tree9628a75b33db6ca91b748d32b346ebcd995fe2bc /games
parent7edc737af83db8816cfa63fb9a25ca2b3ca5eb7e (diff)
downloadfreebsd-ports-gnome-a6d5f14c323acb9ab5b3c6a40c06c3ded370d1c9.tar.gz
freebsd-ports-gnome-a6d5f14c323acb9ab5b3c6a40c06c3ded370d1c9.tar.zst
freebsd-ports-gnome-a6d5f14c323acb9ab5b3c6a40c06c3ded370d1c9.zip
- Bump PORTREVISION
- Fix MASTER_SITES - Add Desktop entry file for Solutions - Add SOLUTIONS Option - Add files/holotz-castle-solutions.in - Trim files/pkg-message.in - Update WWW - Trim pkg-plist PR: ports/179671 Submitted by: nemysis <nemysis@gmx.ch> (maintainer)
Diffstat (limited to 'games')
-rw-r--r--games/holotz-castle/Makefile34
-rw-r--r--games/holotz-castle/distinfo2
-rw-r--r--games/holotz-castle/files/holotz-castle-solutions.in16
-rw-r--r--games/holotz-castle/files/pkg-message.in4
-rw-r--r--games/holotz-castle/pkg-descr2
-rw-r--r--games/holotz-castle/pkg-plist24
6 files changed, 75 insertions, 7 deletions
diff --git a/games/holotz-castle/Makefile b/games/holotz-castle/Makefile
index e42d5cc8afcd..82a546f5600f 100644
--- a/games/holotz-castle/Makefile
+++ b/games/holotz-castle/Makefile
@@ -3,11 +3,13 @@
PORTNAME= holotz-castle
PORTVERSION= 1.3.14
+PORTREVISION= 1
CATEGORIES= games
-MASTER_SITES= http://www.mainreactor.net/holotzcastle/download/ \
- SF/nemysisfreebsdp/:icons
+MASTER_SITES= SF/nemysisfreebsdp/holotz-castle/
DISTFILES= ${PORTNAME}-${DISTVERSION}-src${EXTRACT_SUFX} \
- ${PORTNAME}_icons${EXTRACT_SUFX}:icons
+ ${PORTNAME}_icons${EXTRACT_SUFX}
+EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}-src${EXTRACT_SUFX} \
+ ${PORTNAME}_icons${EXTRACT_SUFX}
MAINTAINER= nemysis@gmx.ch
COMMENT= Platform game with high doses of mystery
@@ -28,11 +30,30 @@ MAN6= ${PORTNAME}.6 ${PORTNAME}-editor.6
INSTALLS_ICONS= yes
ICON_SIZES= 32x32 48x48 64x64 72x72 96x96 128x128
-SUB_FILES= pkg-message
+SUB_FILES= pkg-message ${PORTNAME}-solutions
DESKTOP_ENTRIES="Holotz's Castle" "${COMMENT}" ${PORTNAME} \
"${PORTNAME}" "Game;LogicGame;" false
+DESKTOP_ENTRIES="Holotz's Castle Solutions" "${COMMENT}" ${PORTNAME} \
+ "xterm -e ${PORTNAME}-solutions" "Game;LogicGame;" false
+
+OPTIONS_DEFINE= SOLUTIONS
+OPTIONS_DEFAULT=SOLUTIONS
+SOLUTIONS_DESC= Solutions for Holotz's Castle
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MSOLUTIONS}
+DISTFILES+= ${PORTNAME}_solutions${EXTRACT_SUFX}
+EXTRACT_ONLY+= ${PORTNAME}_solutions${EXTRACT_SUFX}
+RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer \
+ xterm:${PORTSDIR}/x11/xterm
+PLIST_SUB+= SOLUTIONS=""
+.else
+PLIST_SUB+= SOLUTIONS="@comment "
+.endif
+
post-install:
.for s in ${ICON_SIZES}
${MKDIR} ${PREFIX}/share/icons/hicolor/${s}/apps
@@ -42,8 +63,13 @@ post-install:
${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png ${PREFIX}/share/pixmaps
(cd ${WRKSRC}/man && ${INSTALL_MAN} ${MAN6} ${MAN6PREFIX}/man/man6)
+.if ${PORT_OPTIONS:MSOLUTIONS}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}-solutions ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}/solutions
+ @(cd ${WRKDIR} ; ${INSTALL_DATA} *.avi ${DATADIR}/solutions)
@${ECHO_CMD}
@${CAT} ${PKGMESSAGE}
@${ECHO_CMD}
+.endif
.include <bsd.port.mk>
diff --git a/games/holotz-castle/distinfo b/games/holotz-castle/distinfo
index 92d528b9889e..4024e528aa7d 100644
--- a/games/holotz-castle/distinfo
+++ b/games/holotz-castle/distinfo
@@ -2,3 +2,5 @@ SHA256 (holotz-castle-1.3.14-src.tar.gz) = 42903559a9821b39eac6eba7730be0fcba12c
SIZE (holotz-castle-1.3.14-src.tar.gz) = 3691364
SHA256 (holotz-castle_icons.tar.gz) = 5ca3aee3d7abddbb8baff9961460497c0a2ec8418570c755f2df581f5605960b
SIZE (holotz-castle_icons.tar.gz) = 35328
+SHA256 (holotz-castle_solutions.tar.gz) = c4fd9c02c82fde1d0c63c94495ce2b47142ab2741b81742527a02c76edc70cc4
+SIZE (holotz-castle_solutions.tar.gz) = 129568789
diff --git a/games/holotz-castle/files/holotz-castle-solutions.in b/games/holotz-castle/files/holotz-castle-solutions.in
new file mode 100644
index 000000000000..40da5e652111
--- /dev/null
+++ b/games/holotz-castle/files/holotz-castle-solutions.in
@@ -0,0 +1,16 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+echo ""
+echo -n "Which Solution for Holotz's Castle would You see?"
+cd %%DATADIR%%/solutions
+echo ""
+echo ""
+ls
+echo ""
+read SOLUTIONS
+
+mplayer "%%DATADIR%%/solutions/$SOLUTIONS"
+
diff --git a/games/holotz-castle/files/pkg-message.in b/games/holotz-castle/files/pkg-message.in
index b9343ab3700f..580c0411f7b4 100644
--- a/games/holotz-castle/files/pkg-message.in
+++ b/games/holotz-castle/files/pkg-message.in
@@ -2,8 +2,8 @@
Holotz's Castle has been installed.
-You can download the solutions to some Levels from here
+You can look some Solutions for Holotz's Castle with
-http://www.mainreactor.net/holotzcastle/en/holotzcastle_en.html#SOLUTIONS
+ %%PREFIX%%/bin/holotz-castle-solutions
===============================================================================
diff --git a/games/holotz-castle/pkg-descr b/games/holotz-castle/pkg-descr
index cb513d9dd47e..0e594c5e72fe 100644
--- a/games/holotz-castle/pkg-descr
+++ b/games/holotz-castle/pkg-descr
@@ -6,4 +6,4 @@ castle?
Test your dexterity with this tremendously exciting platform game!
-WWW: http://www.mainreactor.net/holotzcastle/en/index_en.html
+WWW: http://web.archive.org/web/20130606213511/http://mainreactor.net/
diff --git a/games/holotz-castle/pkg-plist b/games/holotz-castle/pkg-plist
index ed4c4d02b866..ae5312672fca 100644
--- a/games/holotz-castle/pkg-plist
+++ b/games/holotz-castle/pkg-plist
@@ -1,5 +1,6 @@
bin/holotz-castle
bin/holotz-castle-editor
+%%SOLUTIONS%%bin/holotz-castle-solutions
%%DATADIR%%/editor/EnemyMenu/0.tga
%%DATADIR%%/editor/EnemyMenu/0_hi.tga
%%DATADIR%%/editor/EnemyMenu/1.tga
@@ -1324,6 +1325,28 @@ bin/holotz-castle-editor
%%DATADIR%%/game/theme/dungeons/rope/2/edge.tga
%%DATADIR%%/game/theme/dungeons/rope/2/middle.tga
%%DATADIR%%/game/theme/dungeons/rope/2/top.tga
+%%SOLUTIONS%%%%DATADIR%%/solutions/holotz_castle_high_03.avi
+%%SOLUTIONS%%%%DATADIR%%/solutions/holotz_castle_high_04.avi
+%%SOLUTIONS%%%%DATADIR%%/solutions/holotz_castle_high_05.avi
+%%SOLUTIONS%%%%DATADIR%%/solutions/holotz_castle_high_06.avi
+%%SOLUTIONS%%%%DATADIR%%/solutions/holotz_castle_high_08.avi
+%%SOLUTIONS%%%%DATADIR%%/solutions/holotz_castle_high_09.avi
+%%SOLUTIONS%%%%DATADIR%%/solutions/holotz_castle_high_10.avi
+%%SOLUTIONS%%%%DATADIR%%/solutions/holotz_castle_high_11.avi
+%%SOLUTIONS%%%%DATADIR%%/solutions/holotz_castle_high_12.avi
+%%SOLUTIONS%%%%DATADIR%%/solutions/holotz_castle_high_13.avi
+%%SOLUTIONS%%%%DATADIR%%/solutions/holotz_castle_high_15.avi
+%%SOLUTIONS%%%%DATADIR%%/solutions/holotz_castle_high_17.avi
+%%SOLUTIONS%%%%DATADIR%%/solutions/holotz_castle_high_18.avi
+%%SOLUTIONS%%%%DATADIR%%/solutions/holotz_castle_high_21.avi
+%%SOLUTIONS%%%%DATADIR%%/solutions/holotz_castle_high_22.avi
+%%SOLUTIONS%%%%DATADIR%%/solutions/holotz_castle_high_23.avi
+%%SOLUTIONS%%%%DATADIR%%/solutions/holotz_castle_high_24.avi
+%%SOLUTIONS%%%%DATADIR%%/solutions/holotz_castle_high_26.avi
+%%SOLUTIONS%%%%DATADIR%%/solutions/holotz_castle_high_27.avi
+%%SOLUTIONS%%%%DATADIR%%/solutions/holotz_castle_high_28.avi
+%%SOLUTIONS%%%%DATADIR%%/solutions/holotz_castle_high_29.avi
+%%SOLUTIONS%%%%DATADIR%%/solutions/holotz_castle_high_31.avi
share/icons/hicolor/128x128/apps/holotz-castle.png
share/icons/hicolor/32x32/apps/holotz-castle.png
share/icons/hicolor/48x48/apps/holotz-castle.png
@@ -1331,6 +1354,7 @@ share/icons/hicolor/64x64/apps/holotz-castle.png
share/icons/hicolor/72x72/apps/holotz-castle.png
share/icons/hicolor/96x96/apps/holotz-castle.png
share/pixmaps/holotz-castle.png
+%%SOLUTIONS%%@dirrm %%DATADIR%%/solutions
@dirrm %%DATADIR%%/game/theme/dungeons/rope/2
@dirrm %%DATADIR%%/game/theme/dungeons/rope/1
@dirrm %%DATADIR%%/game/theme/dungeons/rope