aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2012-09-17 22:23:30 +0800
committerjhale <jhale@FreeBSD.org>2012-09-17 22:23:30 +0800
commitadc0f4c07c03285ffcbb8065354cdd5c1d5aac26 (patch)
tree0eea39aa0d8268c69c3c698d745c9768f0edc591 /games
parent1f4a9639053a1906417bd2f5d557436992cf7a7a (diff)
downloadfreebsd-ports-gnome-adc0f4c07c03285ffcbb8065354cdd5c1d5aac26.tar.gz
freebsd-ports-gnome-adc0f4c07c03285ffcbb8065354cdd5c1d5aac26.tar.zst
freebsd-ports-gnome-adc0f4c07c03285ffcbb8065354cdd5c1d5aac26.zip
- Clean up Makefile
- Respect PREFIX - Install pixmaps - Convert to pkg-plist PR: ports/171359 Submitted by: nemysis <nemysis at gmx dot ch> (maintainer) Approved by: makc (mentor)
Diffstat (limited to 'games')
-rw-r--r--games/connectagram/Makefile32
-rw-r--r--games/connectagram/pkg-plist11
2 files changed, 20 insertions, 23 deletions
diff --git a/games/connectagram/Makefile b/games/connectagram/Makefile
index a4246f4db2c0..713f3fdd97d4 100644
--- a/games/connectagram/Makefile
+++ b/games/connectagram/Makefile
@@ -7,51 +7,37 @@
PORTNAME= connectagram
PORTVERSION= 1.0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= http://gottcode.org/${PORTNAME}/
-DISTNAME= ${PORTNAME}-${DISTVERSION}-src
+EXTRACT_SUFX= -src.tar.bz2
MAINTAINER= nemysis@gmx.ch
COMMENT= Word unscrambling game
LICENSE= GPLv3
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-
USE_BZIP2= yes
-USE_QT_VER= 4
-QT_COMPONENTS= moc_build qmake_build rcc_build corelib gui iconengines imageformats network
+USE_QT4= moc_build qmake_build rcc_build gui network
INSTALLS_ICONS= yes
-
MAKE_JOBS_SAFE= yes
-PORTDATA= *
PORTDOCS= ChangeLog
-PLIST_FILES= bin/${PORTNAME} \
- share/applications/${PORTNAME}.desktop \
- share/icons/hicolor/48x48/apps/${PORTNAME}.png
-
-PLIST_DIRSTRY= share/icons/hicolor/48x48/apps \
- share/icons/hicolor/48x48 \
- share/icons/hicolor \
- share/icons \
- share/applications
+.include <bsd.port.options.mk>
do-configure:
@cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
- ${QMAKE} ${QMAKEFLAGS}
-
-.include <bsd.port.options.mk>
+ ${QMAKE} ${QMAKEFLAGS} PREFIX=${PREFIX}
post-install:
+# Pixmaps
+ ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png ${PREFIX}/share/pixmaps/
+
# Documentation
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
-. for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-. endfor
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/games/connectagram/pkg-plist b/games/connectagram/pkg-plist
new file mode 100644
index 000000000000..43aeb503a84b
--- /dev/null
+++ b/games/connectagram/pkg-plist
@@ -0,0 +1,11 @@
+bin/connectagram
+share/applications/connectagram.desktop
+share/connectagram/words
+share/icons/hicolor/48x48/apps/connectagram.png
+share/pixmaps/connectagram.png
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
+@dirrm share/connectagram
+@dirrmtry share/applications