aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-12-01 08:10:05 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-12-01 08:10:05 +0800
commitb06c7130d0e72f917cc3fead79081b26f0ac3ab7 (patch)
tree9339445ab7c3fb7b317ddffb94b3af6341495962 /games
parent7c2d1883535193f16c57cb022dd3858b194e0a78 (diff)
downloadfreebsd-ports-gnome-b06c7130d0e72f917cc3fead79081b26f0ac3ab7.tar.gz
freebsd-ports-gnome-b06c7130d0e72f917cc3fead79081b26f0ac3ab7.tar.zst
freebsd-ports-gnome-b06c7130d0e72f917cc3fead79081b26f0ac3ab7.zip
- Update to 1.02
- Clarify LICENSE - Add .desktop file and icon
Diffstat (limited to 'games')
-rw-r--r--games/sdl-ball/Makefile18
-rw-r--r--games/sdl-ball/distinfo4
-rw-r--r--games/sdl-ball/files/patch-Makefile27
-rw-r--r--games/sdl-ball/files/patch-main.cpp19
4 files changed, 36 insertions, 32 deletions
diff --git a/games/sdl-ball/Makefile b/games/sdl-ball/Makefile
index 0b61aded99fa..96783414cd9c 100644
--- a/games/sdl-ball/Makefile
+++ b/games/sdl-ball/Makefile
@@ -2,15 +2,14 @@
# $FreeBSD$
PORTNAME= sdl-ball
-PORTVERSION= 1.01
-PORTREVISION= 8
+PORTVERSION= 1.02
CATEGORIES= games
MASTER_SITES= SF
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Arkanoid/Breakout clone with pretty graphics
-LICENSE= GPLv3
+LICENSE= GPLv3 # or later
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
USES= tar:bzip2 dos2unix gmake
@@ -19,24 +18,21 @@ USE_GL= gl glu
MAKE_ENV= DATADIR=${DATADIR}/
DOS2UNIX_FILES= main.cpp
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
-PLIST_FILES= bin/${PORTNAME}
+PLIST_FILES= bin/${PORTNAME} \
+ share/applications/${PORTNAME}.desktop \
+ share/pixmaps/${PORTNAME}.png
PORTDOCS= *
PORTDATA= *
OPTIONS_DEFINE= DOCS
-do-build:
- cd ${WRKSRC} && ${CXX} ${CXXFLAGS} `${SDL_CONFIG} --cflags --libs` \
- -lGL -lGLU -lSDL_image -lSDL_ttf -lSDL_mixer \
- -DDATADIR="\"${DATADIR}/\"" main.cpp -o ${PORTNAME}
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
${MKDIR} ${STAGEDIR}${DATADIR}
cd ${WRKSRC}/themes && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/themes/default/icon32.png ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.png
+ ${INSTALL_DATA} ${WRKSRC}/sdl-ball.desktop ${STAGEDIR}${PREFIX}/share/applications/
.include <bsd.port.mk>
diff --git a/games/sdl-ball/distinfo b/games/sdl-ball/distinfo
index d4395d065de0..95bc2163b3f9 100644
--- a/games/sdl-ball/distinfo
+++ b/games/sdl-ball/distinfo
@@ -1,2 +1,2 @@
-SHA256 (sdl-ball-1.01.tar.bz2) = 85e2a857c8c318e81732e3c1e843fc70d7199fa83e2f4efc42239ebbe8d7b9e6
-SIZE (sdl-ball-1.01.tar.bz2) = 3467329
+SHA256 (sdl-ball-1.02.tar.bz2) = 03ae91c0ddbcf055a224b765da55dc5c8417e9b09971eb56280c8e602ba01423
+SIZE (sdl-ball-1.02.tar.bz2) = 3286131
diff --git a/games/sdl-ball/files/patch-Makefile b/games/sdl-ball/files/patch-Makefile
new file mode 100644
index 000000000000..858b9fbb6d3d
--- /dev/null
+++ b/games/sdl-ball/files/patch-Makefile
@@ -0,0 +1,27 @@
+--- Makefile.orig 2008-12-31 03:42:35.000000000 +0300
++++ Makefile 2014-12-01 00:26:16.000000000 +0300
+@@ -2,9 +2,9 @@
+
+ #append -DWITH_WIIUSE to compile with WIIUSE support!
+ #append -DNOSOUND to compile WITHOUT sound support
+-CC=g++ -DDATADIR="\"$(DATADIR)\""
++CXX?=g++
+
+-CFLAGS+=-c -Wall `sdl-config --cflags`
++CXXFLAGS+=-Wall `sdl-config --cflags` -DDATADIR="\"$(DATADIR)\""
+
+ #append -lwiiuse to compile with WIIUSE support
+ #remove -lSDL_mixer if compiling with -DNOSOUND
+@@ -18,10 +18,10 @@
+ all: $(SOURCES) $(EXECUTABLE)
+
+ $(EXECUTABLE): $(OBJECTS)
+- $(CC) $(LDFLAGS) $(OBJECTS) $(LIBS) -o $@
++ $(CXX) $(LDFLAGS) $(OBJECTS) $(LIBS) -o $@
+
+ .cpp.o:
+- $(CC) $(CFLAGS) $< -o $@
++ $(CXX) -c $(CXXFLAGS) $< -o $@
+
+ clean:
+ rm -f *.o sdl-ball
diff --git a/games/sdl-ball/files/patch-main.cpp b/games/sdl-ball/files/patch-main.cpp
deleted file mode 100644
index ce3314619dab..000000000000
--- a/games/sdl-ball/files/patch-main.cpp
+++ /dev/null
@@ -1,19 +0,0 @@
---- main.cpp.orig 2013-09-13 20:14:07.890226440 +0400
-+++ main.cpp 2013-09-13 20:14:24.001226100 +0400
-@@ -31,6 +31,7 @@
- #include <vector>
- #include <sys/time.h>
- #include <sys/stat.h>
-+#include <unistd.h> // for usleep()
-
- #include <dirent.h>
-
-@@ -1420,7 +1421,7 @@
- //Leaves an trail of the ball
- class tracer {
- private:
-- GLfloat x[100], y[100], r[100], g[100], b[100], a[100],s[100], cr,cg,cb,;
-+ GLfloat x[100], y[100], r[100], g[100], b[100], a[100],s[100], cr,cg,cb;
- bool active[100];
- int color;
- GLfloat lastX, lastY; //Last position where we spawned one