aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2013-06-14 20:25:13 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2013-06-14 20:25:13 +0800
commitb536a2f6214b62f1c1eeafe7eb537d48267f3cc3 (patch)
treed9bcc4ec2b532390b2f3c15a062d7cd4c1da69fd /games
parent22654735d30f826bdd9d85906925db718866545c (diff)
downloadfreebsd-ports-gnome-b536a2f6214b62f1c1eeafe7eb537d48267f3cc3.tar.gz
freebsd-ports-gnome-b536a2f6214b62f1c1eeafe7eb537d48267f3cc3.tar.zst
freebsd-ports-gnome-b536a2f6214b62f1c1eeafe7eb537d48267f3cc3.zip
- Fix WWW
- Add LICENSE - Make NLS optional - Install manpages PR: 179329 Submitted by: nemysis <nemysis@gmx.ch>
Diffstat (limited to 'games')
-rw-r--r--games/plee-the-bear/Makefile30
-rw-r--r--games/plee-the-bear/pkg-descr2
-rw-r--r--games/plee-the-bear/pkg-plist8
3 files changed, 33 insertions, 7 deletions
diff --git a/games/plee-the-bear/Makefile b/games/plee-the-bear/Makefile
index cea924f1f4bb..78438b90814f 100644
--- a/games/plee-the-bear/Makefile
+++ b/games/plee-the-bear/Makefile
@@ -3,13 +3,20 @@
PORTNAME= plee-the-bear
PORTVERSION= 0.6.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/Plee%20the%20Bear/${PORTVERSION:R}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= 2D platform jump and run game
+LICENSE= GPLv2 CCbySA3
+LICENSE_COMB= dual
+LICENSE_NAME_CCbySA3=Attribution-ShareAlike 3.0 Unported
+LICENSE_FILE_CCbySA3=${WRKSRC}/CCPL
+LICENSE_PERMS_CCbySA3=dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+BUILD_DEPENDS= docbook-to-man:${PORTSDIR}/textproc/docbook-to-man
LIB_DEPENDS= boost_filesystem:${PORTSDIR}/devel/boost-libs \
claw_application:${PORTSDIR}/devel/libclaw
@@ -21,8 +28,27 @@ USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
USE_GCC= 4.6+
-USES= cmake gettext
+USES= cmake
CMAKE_ARGS= -Dlibclaw_DIR="${LOCALBASE}/share/libclaw/cmake" \
-DBEAR_NO_EDITOR=YES
+MAN6= plee-the-bear.6 running-bear.6
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
+PLIST_SUB+= NLS=""
+.else
+PLIST_SUB+= NLS="@comment "
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|share/man|man|' ${WRKSRC}/CMakeLists.txt
+.if ! ${PORT_OPTIONS:MNLS}
+ @${REINPLACE_CMD} -e 's|locale||' \
+ ${WRKSRC}/bear-engine/desktop/CMakeLists.txt \
+ ${WRKSRC}/plee-the-bear/desktop/CMakeLists.txt
+.endif
+
.include <bsd.port.mk>
diff --git a/games/plee-the-bear/pkg-descr b/games/plee-the-bear/pkg-descr
index dc4198be88a3..9cded3a5af00 100644
--- a/games/plee-the-bear/pkg-descr
+++ b/games/plee-the-bear/pkg-descr
@@ -3,4 +3,4 @@ the best platform games of the 90's (the golden age of this kind
of games). You're a bear, trying to catch his son, which ran away
after he ate all your honey.
-WWW: http://plee-the-bear.sourceforge.net/
+WWW: http://sourceforge.net/projects/plee-the-bear/
diff --git a/games/plee-the-bear/pkg-plist b/games/plee-the-bear/pkg-plist
index 11feb9809d2c..d9083b50cff9 100644
--- a/games/plee-the-bear/pkg-plist
+++ b/games/plee-the-bear/pkg-plist
@@ -108,10 +108,10 @@ share/icons/hicolor/24x24/apps/ptb.png
share/icons/hicolor/32x32/apps/ptb.png
share/icons/hicolor/48x48/apps/ptb.png
share/icons/hicolor/64x64/apps/ptb.png
-share/locale/fr/LC_MESSAGES/bear-engine.mo
-share/locale/fr/LC_MESSAGES/plee-the-bear.mo
-share/locale/nn/LC_MESSAGES/bear-engine.mo
-share/locale/nn/LC_MESSAGES/plee-the-bear.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/bear-engine.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/plee-the-bear.mo
+%%NLS%%share/locale/nn/LC_MESSAGES/bear-engine.mo
+%%NLS%%share/locale/nn/LC_MESSAGES/plee-the-bear.mo
share/pixmaps/ptb.png
share/pixmaps/ptb.xpm
%%DATADIR%%/animation/air_bubble_generator.canim