aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-01-26 20:30:01 +0800
committermarino <marino@FreeBSD.org>2014-01-26 20:30:01 +0800
commitb5db857b014e6fb7a7402f5eff1593d050bea926 (patch)
tree9f611e9473d30cd8abca78ad43135fbae8c11128 /games
parent2f70c1b427f7acbdaf43b49c55990bcf8e8ec50c (diff)
downloadfreebsd-ports-gnome-b5db857b014e6fb7a7402f5eff1593d050bea926.tar.gz
freebsd-ports-gnome-b5db857b014e6fb7a7402f5eff1593d050bea926.tar.zst
freebsd-ports-gnome-b5db857b014e6fb7a7402f5eff1593d050bea926.zip
games/armagetron: Update to version 0.2.8.3.2 and support stage.
The previous version was 0.2.8.2.1. Addition changes include: * Removal of PORTREVISION; this resets to 0 when PORTVERSION changes * convert USE_GMAKE to USES=gmake * Remove now unsupported armagetronad_dedicated.in processing * Convert LIBDEPENDS to new specification * Support stage PR: ports/184800 Submitted by: Peter Kosyh Approved by: maintainer (Ian Wagner) Fixed by: marino@
Diffstat (limited to 'games')
-rw-r--r--games/armagetron/Makefile17
-rw-r--r--games/armagetron/distinfo4
-rw-r--r--games/armagetron/files/armagetronad_dedicated.in34
-rw-r--r--games/armagetron/files/patch-Makefile.in11
-rw-r--r--games/armagetron/files/patch-batch-install.in36
-rw-r--r--games/armagetron/files/patch-configure32
-rw-r--r--games/armagetron/files/patch-src-engine_eGrid.h10
-rw-r--r--games/armagetron/files/patch-src-engine_eVoter.cpp11
-rw-r--r--games/armagetron/files/patch-src-engine_eWall.h10
-rw-r--r--games/armagetron/files/patch-src-tron_gCycle.h14
10 files changed, 30 insertions, 149 deletions
diff --git a/games/armagetron/Makefile b/games/armagetron/Makefile
index 3409a6b46009..a15f8c07d3c0 100644
--- a/games/armagetron/Makefile
+++ b/games/armagetron/Makefile
@@ -2,25 +2,24 @@
# $FreeBSD$
PORTNAME= armagetron
-PORTVERSION= 0.2.8.2.1
-PORTREVISION= 7
+PORTVERSION= 0.2.8.3.2
CATEGORIES= games
-MASTER_SITES= SF/${PORTNAME}ad/${PORTNAME}ad-src/${PORTVERSION}
+MASTER_SITES= SF/${PORTNAME}ad/stable/${PORTVERSION}/
DISTNAME= armagetronad-${PORTVERSION}
-EXTRACT_SUFX= .src.tar.gz
+EXTRACT_SUFX= .src.tar.bz2
MAINTAINER= ianthetechie@gmail.com
COMMENT= A multiplayer networked Tron clone in 3D
-USE_GMAKE= yes
+USES= gmake
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-etc --disable-initscripts
CXXFLAGS+= ${CFLAGS} -I${LOCALBASE}/include
BUILD_DEPENDS+= bash:${PORTSDIR}/shells/bash
-LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg \
- png15:${PORTSDIR}/graphics/png \
- xml2.5:${PORTSDIR}/textproc/libxml2
+LIB_DEPENDS+= libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libpng.so:${PORTSDIR}/graphics/png \
+ libxml2.so:${PORTSDIR}/textproc/libxml2
OPTIONS_DEFINE= MUSIC ARMA_SERVER_ONLY
MUSIC_DESC= Compile in support for background music
@@ -28,14 +27,12 @@ ARMA_SERVER_ONLY_DESC= Build dedicated server only
OPTIONS_DEFAULT= MUSIC
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MARMA_SERVER_ONLY}
CONFIGURE_ARGS+= --disable-glout
PLIST_SUB+= CLIENT="@comment " SERVER="" SUFFIX="-dedicated"
PKGNAMESUFFX= -dedicated
-USE_RC_SUBR= armagetronad_dedicated
.else
USE_GL= gl
USE_SDL= sdl image
diff --git a/games/armagetron/distinfo b/games/armagetron/distinfo
index 3a769a3a28b9..77edc365bb87 100644
--- a/games/armagetron/distinfo
+++ b/games/armagetron/distinfo
@@ -1,2 +1,2 @@
-SHA256 (armagetronad-0.2.8.2.1.src.tar.gz) = ef6ce4d913079cb7d26647c42107a165a87e96041b311b8d5059ac04ece1d859
-SIZE (armagetronad-0.2.8.2.1.src.tar.gz) = 1874858
+SHA256 (armagetronad-0.2.8.3.2.src.tar.bz2) = f444e481de94e6c0e3933c709d46effd2adfe823f5ef44768adcc8003b8ba7c5
+SIZE (armagetronad-0.2.8.3.2.src.tar.bz2) = 1841407
diff --git a/games/armagetron/files/armagetronad_dedicated.in b/games/armagetron/files/armagetronad_dedicated.in
deleted file mode 100644
index 4732d5247c5b..000000000000
--- a/games/armagetron/files/armagetronad_dedicated.in
+++ /dev/null
@@ -1,34 +0,0 @@
-#!/bin/sh
-
-# $FreeBSD$
-#
-# PROVIDE: armagetronad_dedicated
-# REQUIRE: LOGIN
-# KEYWORD: shutdown
-#
-# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
-# to enable this service:
-#
-# armagetronad_dedicated_enable (bool): Set to NO by default.
-# Set it to YES to enable armagetron server.
-# armagetronad_dedicated_flags (str): Set to "-d" by default.
-# Extra flags passed to start command
-#
-
-. /etc/rc.subr
-
-name="armagetronad_dedicated"
-rcvar=armagetronad_dedicated_enable
-
-command=%%PREFIX%%/bin/${name}
-pidfile=/var/run/${name}.pid
-
-load_rc_config $name
-
-: ${armagetronad_dedicated_enable="NO"}
-: ${armagetronad_dedicated_flags="-d"}
-
-command="%%PREFIX%%/bin/armagetronad-dedicated"
-command_args="${armagetronad_dedicated_flags} &"
-
-run_rc_command "$1"
diff --git a/games/armagetron/files/patch-Makefile.in b/games/armagetron/files/patch-Makefile.in
deleted file mode 100644
index 486c352c3906..000000000000
--- a/games/armagetron/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig 2008-06-08 21:26:57.000000000 +0800
-+++ Makefile.in 2008-06-08 21:27:08.000000000 +0800
-@@ -1130,7 +1130,7 @@
-
- install-first:
- # uninstall previous version (if it exists), ignoring errors
-- test -x $(uninstall_location) && $(uninstall_location) || true
-+@USE_UNINSTALL_TRUE@ test -x $(uninstall_location) && $(uninstall_location) || true
-
- distclean-local:
- rm -f uninstall.sh batch/relocate.in universal_variable* extrapaths src/tUniversalVariables.h*
diff --git a/games/armagetron/files/patch-batch-install.in b/games/armagetron/files/patch-batch-install.in
deleted file mode 100644
index afec92f8fd10..000000000000
--- a/games/armagetron/files/patch-batch-install.in
+++ /dev/null
@@ -1,36 +0,0 @@
---- batch/install.in.orig Sat Feb 19 17:54:22 2005
-+++ batch/install.in Sun Nov 13 01:26:26 2005
-@@ -8,7 +8,7 @@
-
- #find old configuration
- if test @enable_etc@ = yes ; then
-- CONFIG=@rpmroot@/etc/@prognamebase@
-+ CONFIG=@rpmroot@@prefix@/etc/@prognamebase@
- else
- CONFIG=$INSTALL/config
- fi
-@@ -114,10 +114,6 @@
- cp $INSTALL/config/* $CONFIG
- fi
-
--rm -rf $CONFIG_NEW
--mkdir $CONFIG_NEW
--cp $CONFIG/* $CONFIG_NEW
--
- if test "$UPDATE" = "yes" && test -d $CONFIG_ORIG; then
- echo "Integrating user changes..." #"from $CONFIG_USER to $CONFIG_ORIG and $CONFIG..."
- test -r $CONFIG_USER || mkdir $CONFIG_USER
-@@ -140,13 +136,6 @@
- done
- cd $PWD_OLD
- fi
--
--rm -rf $CONFIG_ORIG
--rm -rf $NEW_CONFIG_ORIG
--mv $CONFIG_NEW $NEW_CONFIG_ORIG
--chmod 755 $NEW_CONFIG_ORIG
--chmod 400 $NEW_CONFIG_ORIG/*
--echo -e "Don't change anything in this directory; it will be needed exactly as it is now\nwhen you upgrate to a new version." >> $NEW_CONFIG_ORIG/README
-
- #delete obsolete configuration
- if test @enable_etc@ = yes ; then
diff --git a/games/armagetron/files/patch-configure b/games/armagetron/files/patch-configure
index c5128c38f4dd..31cfb708b64b 100644
--- a/games/armagetron/files/patch-configure
+++ b/games/armagetron/files/patch-configure
@@ -1,11 +1,21 @@
---- configure.orig 2006-08-05 03:15:57.000000000 +0800
-+++ configure 2008-06-08 14:32:47.000000000 +0800
-@@ -17362,7 +17362,7 @@
- echo " Static data will be installed in : `eval echo ${aa_datadir}`"
- echo " Configuration will be installed in : `eval echo ${aa_sysconfdir}`"
- echo " Documentation will be installed in : `eval echo ${aa_docdir}`"
--test "x$enable_etc" = "xyes" && echo " Link to configuration will go to : /etc/${progname}"
-+test "x$enable_etc" = "xyes" && echo " Link to configuration will go to : $prefix/etc/${progname}"
- echo " Music support: $enable_music"
- echo " Build with Krawall authentication support: $enable_krawall"
- echo " Use dirty SDL initialization: $enable_dirty"
+diff -Nur configure.orig configure
+--- configure.orig 2013-12-16 15:45:20.000000000 +0400
++++ configure 2013-12-16 15:46:48.000000000 +0400
+@@ -10629,12 +10629,12 @@
+ CPPFLAGS="$CPPFLAGS `libpng-config --cflags`"
+ LIBS="$LIBS $PNGLIBS"
+
+-ac_fn_c_check_func "$LINENO" "png_check_sig" "ac_cv_func_png_check_sig"
+-if test "x$ac_cv_func_png_check_sig" = x""yes; then :
++# ac_fn_c_check_func "$LINENO" "png_check_sig" "ac_cv_func_png_check_sig"
++# if test "x$ac_cv_func_png_check_sig" = x""yes; then :
+
+-else
+- as_fn_error "You need libpng to compile Armagetron." "$LINENO" 5
+-fi
++# else
++# as_fn_error "You need libpng to compile Armagetron." "$LINENO" 5
++# fi
+
+
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for main in -ljpeg" >&5
diff --git a/games/armagetron/files/patch-src-engine_eGrid.h b/games/armagetron/files/patch-src-engine_eGrid.h
deleted file mode 100644
index 6b425490eb39..000000000000
--- a/games/armagetron/files/patch-src-engine_eGrid.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/engine/eGrid.h.orig 2007-10-02 18:09:58.000000000 +0200
-+++ src/engine/eGrid.h 2007-10-02 18:10:10.000000000 +0200
-@@ -39,6 +39,7 @@
- class ePoint;
- class eFace;
- class eHalfEdge;
-+class eGameObject;
- class eWall;
- class eGrid;
- class eWallView;
diff --git a/games/armagetron/files/patch-src-engine_eVoter.cpp b/games/armagetron/files/patch-src-engine_eVoter.cpp
deleted file mode 100644
index 47d7b784301f..000000000000
--- a/games/armagetron/files/patch-src-engine_eVoter.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/engine/eVoter.cpp.orig 2006-05-13 22:17:31.000000000 +0800
-+++ src/engine/eVoter.cpp 2008-06-08 14:34:16.000000000 +0800
-@@ -41,6 +41,8 @@
- #include "ePlayer.h"
- #include "eGrid.h"
-
-+class eMenuItemVote;
-+
- // use server controlled votes
- static bool se_useServerControlledKick = false;
- static nSettingItemWatched< bool > se_usc( "VOTE_USE_SERVER_CONTROLLED_KICK", se_useServerControlledKick, nConfItemVersionWatcher::Group_Annoying, 10 );
diff --git a/games/armagetron/files/patch-src-engine_eWall.h b/games/armagetron/files/patch-src-engine_eWall.h
deleted file mode 100644
index 06840892045c..000000000000
--- a/games/armagetron/files/patch-src-engine_eWall.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/engine/eWall.h.orig 2005-11-18 07:38:17.000000000 +0800
-+++ src/engine/eWall.h 2008-06-08 14:35:22.000000000 +0800
-@@ -53,6 +53,7 @@
-
-
- class eWall;
-+class eWallView;
- class eWallHolder;
- class eGameObject;
- class eCamera;
diff --git a/games/armagetron/files/patch-src-tron_gCycle.h b/games/armagetron/files/patch-src-tron_gCycle.h
deleted file mode 100644
index fcca86faf8b1..000000000000
--- a/games/armagetron/files/patch-src-tron_gCycle.h
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/tron/gCycle.h.orig 2006-05-13 22:17:31.000000000 +0800
-+++ src/tron/gCycle.h 2008-06-08 14:37:33.000000000 +0800
-@@ -41,8 +41,10 @@
- #include "gCycleMovement.h"
-
- class rModel;
--class gTextureCycle;
-+class gCycle;
-+class gDestination;
- class eSoundPlayer;
-+class gTextureCycle;
- class gSensor;
- class gNetPlayerWall;
- class gPlayerWall;