aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2013-07-17 07:46:21 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2013-07-17 07:46:21 +0800
commitb69b44459aa80494e672968920949ae90639ac26 (patch)
tree055bc3c8706fee395ed7ef607678098e98831835 /games
parentd37f29590acbafa82052e72707d4625e0dabe5a7 (diff)
downloadfreebsd-ports-gnome-b69b44459aa80494e672968920949ae90639ac26.tar.gz
freebsd-ports-gnome-b69b44459aa80494e672968920949ae90639ac26.tar.zst
freebsd-ports-gnome-b69b44459aa80494e672968920949ae90639ac26.zip
- Install .desktop file
Diffstat (limited to 'games')
-rw-r--r--games/openxcom/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/games/openxcom/Makefile b/games/openxcom/Makefile
index b315260fdd7c..4e6c7bf0ed1e 100644
--- a/games/openxcom/Makefile
+++ b/games/openxcom/Makefile
@@ -30,7 +30,9 @@ MAKEFILE= Makefile.simple
SUB_FILES= pkg-message
-PLIST_FILES= bin/openxcom
+PLIST_FILES= bin/openxcom share/applications/${PORTNAME}.desktop \
+ share/pixmaps/${PORTNAME}.svg
+PLIST_DIRSTRY= share/applications
PORTDOCS= *
PORTDATA= *
@@ -45,6 +47,9 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${PREFIX}/bin/
+ ${MKDIR} ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/res/linux/openxcom.desktop ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/res/linux/icons/openxcom.svg ${PREFIX}/share/pixmaps
.if !defined(NOPORTDATA)
${MKDIR} ${DATADIR}
cd ${WRKSRC}/bin && ${COPYTREE_SHARE} data ${DATADIR}/