aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2013-03-24 05:53:58 +0800
committerjgh <jgh@FreeBSD.org>2013-03-24 05:53:58 +0800
commitb8ed2e4295ea5e3e4a0aba3e6b6f00b9d6af9cf0 (patch)
tree45d5c1254cbc8337a6723534aa0a3dc62c782e0c /games
parentd62f2104493d5c63e948c94c2af7895fd21fd73e (diff)
downloadfreebsd-ports-gnome-b8ed2e4295ea5e3e4a0aba3e6b6f00b9d6af9cf0.tar.gz
freebsd-ports-gnome-b8ed2e4295ea5e3e4a0aba3e6b6f00b9d6af9cf0.tar.zst
freebsd-ports-gnome-b8ed2e4295ea5e3e4a0aba3e6b6f00b9d6af9cf0.zip
add new port: games/f1lt
F1LT is a free unofficial Formula 1 live timing application written for Windows, Linux, Symbian and Android systems. It is an alternative application to the java applet available on the formula1.com site. To use the application you only need an account on the formula1.com site, the same you are using for connecting to Live Timing from formula1.com. Feature list is too long to list here, but please check WWW address for more! WWW: http://f1lt.pl/ Just in time for Malaysia!
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/f1lt/Makefile59
-rw-r--r--games/f1lt/distinfo2
-rw-r--r--games/f1lt/files/patch-src__core__f1ltcore.h29
-rw-r--r--games/f1lt/pkg-descr9
5 files changed, 100 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 16def2e99a11..37df9040c0b5 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -235,6 +235,7 @@
SUBDIR += exmars
SUBDIR += exult
SUBDIR += ezquake
+ SUBDIR += f1lt
SUBDIR += f1spirit-remake
SUBDIR += fairymax
SUBDIR += falconseye
diff --git a/games/f1lt/Makefile b/games/f1lt/Makefile
new file mode 100644
index 000000000000..b6f88ea72ba7
--- /dev/null
+++ b/games/f1lt/Makefile
@@ -0,0 +1,59 @@
+# Created by: Jason Helfman <jgh@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= f1lt
+PORTVERSION= 2.0.0
+CATEGORIES= games
+MASTER_SITES= GOOGLE_CODE
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= jgh@FreeBSD.org
+COMMENT= Unofficial Formula 1 live timing application
+
+LICENSE= GPLv3
+
+OPTIONS_DEFINE= DOCS
+
+USE_QT4= gui network moc_build qmake_build rcc_build uic_build
+WRKSRC= ${PORTNAME}-${PORTVERSION}
+
+HAS_CONFIGURE= yes
+USE_GMAKE= yes
+
+PLIST_FILES= bin/F1LT \
+ share/F1LT/season.dat \
+ share/F1LT/trackdata.dat \
+ share/F1LT/trackrecords.dat
+PLIST_DIRSTRY= share/F1LT
+PORTDOCS= CHANGELOG
+
+.include <bsd.port.pre.mk>
+
+post-patch-script:
+ @${REINPLACE_CMD} -e 's|PREFIX = /opt|PREFIX = /usr/local|g' \
+ ${WRKSRC}/F1LT.pro
+ @${REINPLACE_CMD} -e 's|$$PREFIX/share/|$$PREFIX/share/$$$$TARGET/|g' \
+ ${WRKSRC}/F1LT.pro
+ @${REINPLACE_CMD} -e 's|PREFIX = /usr/local/$$$$TARGET|PREFIX = /usr/local/|g' \
+ ${WRKSRC}/F1LT.pro
+ @${REINPLACE_CMD} -e 's|target.path = $$PREFIX/bin/|target.path = /usr/local/bin/|g' \
+ ${WRKSRC}/F1LT.pro
+.if ${ARCH} == "i386"
+ @${REINPLACE_CMD} -e 's|999999999998|1000000|g' \
+ ${WRKSRC}/src/tools/laptimecomparisondialog.cpp
+.endif
+
+.include <bsd.port.options.mk>
+
+do-configure:
+ @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
+ ${QMAKE} ${QMAKEFLAGS} PREFIX=${PREFIX} F1LT.pro
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/CHANGELOG ${DOCSDIR}
+.endif
+ @${CHMOD} 0664 ${PREFIX}/share/F1LT/trackrecords.dat
+
+.include <bsd.port.post.mk>
diff --git a/games/f1lt/distinfo b/games/f1lt/distinfo
new file mode 100644
index 000000000000..994348ab32a1
--- /dev/null
+++ b/games/f1lt/distinfo
@@ -0,0 +1,2 @@
+SHA256 (f1lt-2.0.0-src.tar.gz) = cb2c61cacc5d7b0b75bd3796d7f27eedf210fab2579daf22c0a80cd2c60ee277
+SIZE (f1lt-2.0.0-src.tar.gz) = 11826566
diff --git a/games/f1lt/files/patch-src__core__f1ltcore.h b/games/f1lt/files/patch-src__core__f1ltcore.h
new file mode 100644
index 000000000000..1d549471b8c0
--- /dev/null
+++ b/games/f1lt/files/patch-src__core__f1ltcore.h
@@ -0,0 +1,29 @@
+--- ./src/core/f1ltcore.h.orig 2013-03-22 16:57:29.000000000 -0700
++++ ./src/core/f1ltcore.h 2013-03-22 16:59:40.000000000 -0700
+@@ -74,7 +74,7 @@
+ QString prefix = STR(INSTALL_PREFIX);
+ QDir dir;
+ if (dir.exists(prefix))
+- return prefix + "/share/season.dat";
++ return prefix + "/share/F1LT/season.dat";
+ else
+ return programHomeDir() + "/season.dat";
+ #endif
+@@ -88,7 +88,7 @@
+ QString prefix = STR(INSTALL_PREFIX);
+ QDir dir;
+ if (dir.exists(prefix))
+- return prefix + "/share/trackdata.dat";
++ return prefix + "/share/F1LT/trackdata.dat";
+ else
+ return programHomeDir() + "/trackdata.dat";
+ #endif
+@@ -102,7 +102,7 @@
+ QString prefix = STR(INSTALL_PREFIX);
+ QDir dir;
+ if (dir.exists(prefix))
+- return prefix + "/share/trackrecords.dat";
++ return prefix + "/share/F1LT/trackrecords.dat";
+ else
+ return programHomeDir() + "/trackrecords.dat";
+ #endif
diff --git a/games/f1lt/pkg-descr b/games/f1lt/pkg-descr
new file mode 100644
index 000000000000..3896c36056de
--- /dev/null
+++ b/games/f1lt/pkg-descr
@@ -0,0 +1,9 @@
+F1LT is a free unofficial Formula 1 live timing application written for
+Windows, Linux, Symbian and Android systems. It is an alternative
+application to the java applet available on the formula1.com site.
+To use the application you only need an account on the formula1.com
+site, the same you are using for connecting to Live Timing from formula1.com.
+
+Feature list is too long to list here, but please check WWW address for more!
+
+WWW: http://f1lt.pl/