aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-11-30 19:36:55 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 06:02:19 +0800
commitb954f6fe36608cc8680fde0d0439e69a8798b3a6 (patch)
treee0eeaee891de150d0542a6a22e771fa70a772f4b /games
parent33ac2363497ed4f24eb1df549e351718ed6d0416 (diff)
downloadfreebsd-ports-gnome-b954f6fe36608cc8680fde0d0439e69a8798b3a6.tar.gz
freebsd-ports-gnome-b954f6fe36608cc8680fde0d0439e69a8798b3a6.tar.zst
freebsd-ports-gnome-b954f6fe36608cc8680fde0d0439e69a8798b3a6.zip
SpaceZero is a Real Time Strategy 2D space combat game for two
players over a network. The objective is to conquer the universe, defeating all enemies. At starting point you have only one ship and one planet, but you have gold to buy more ships to conquer more planets. All ships can be controlled by the computer (automatic mode) or by the player (manual mode). You can easily change among your ships, controlling all of them independently. WWW: http://spacezero.sourceforge.net/
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/spacezero/Makefile57
-rw-r--r--games/spacezero/distinfo3
-rw-r--r--games/spacezero/files/patch-Makefile34
-rw-r--r--games/spacezero/pkg-descr13
5 files changed, 108 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 278bab574a47..cc0653cbf0ee 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -920,6 +920,7 @@
SUBDIR += solarwolf
SUBDIR += sopwith
SUBDIR += spacejunk
+ SUBDIR += spacezero
SUBDIR += speak
SUBDIR += species
SUBDIR += spellathon
diff --git a/games/spacezero/Makefile b/games/spacezero/Makefile
new file mode 100644
index 000000000000..9037550c5404
--- /dev/null
+++ b/games/spacezero/Makefile
@@ -0,0 +1,57 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= spacezero
+PORTVERSION= 0.86.00
+CATEGORIES= games
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20${PORTVERSION:R}/
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= 2D Real Time Strategy space combat game
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libvorbisfile.so:audio/libvorbis
+
+USES= openal:al,alut pkgconfig
+USE_GNOME= gtk20
+USE_XORG= x11
+MAKE_ARGS= DATADIR="${DATADIR}" \
+ INSTALL_DATA_DIR="${DATADIR}"
+ALL_TARGET= ${PORTNAME}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+LDFLAGS+= -lX11
+
+PORTDOCS= *
+PORTDATA= *
+PLIST_FILES= bin/${PORTNAME} \
+ share/pixmaps/${PORTNAME}.ico
+
+DESKTOP_ENTRIES="SpaceZero" \
+ "" \
+ "${PREFIX}/share/pixmaps/${PORTNAME}.ico" \
+ "${PORTNAME}" \
+ "Game;StrategyGame;" \
+ ""
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1101000
+post-patch:
+ @${REINPLACE_CMD} -e 's|fdatasync|fsync|g' ${WRKSRC}/src/spacecomm.c
+.endif
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/html/manual_files/space.ico ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.ico
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+ cd ${WRKSRC}/dat && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}
+
+do-install-DOCS-on:
+ cd ${WRKSRC}/html && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.post.mk>
diff --git a/games/spacezero/distinfo b/games/spacezero/distinfo
new file mode 100644
index 000000000000..68446b5e07bd
--- /dev/null
+++ b/games/spacezero/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1511982829
+SHA256 (spacezero-0.86.00.tar.gz) = 5199ed0b00843092fad5949d27fd0cf612ed54918ea83c21a83bcc9a10a6c665
+SIZE (spacezero-0.86.00.tar.gz) = 2317283
diff --git a/games/spacezero/files/patch-Makefile b/games/spacezero/files/patch-Makefile
new file mode 100644
index 000000000000..2ac8d7eb3b4c
--- /dev/null
+++ b/games/spacezero/files/patch-Makefile
@@ -0,0 +1,34 @@
+--- Makefile.orig 2013-12-21 12:57:43 UTC
++++ Makefile
+@@ -1,4 +1,4 @@
+-CC=gcc
++CC?=gcc
+
+ BINDIR= ./bin
+ DATADIR= ./dat
+@@ -26,8 +26,8 @@ GTKLIBS=`pkg-config --libs gtk+-2.0`
+ GTKLIBS12=`gtk-config --cflags`
+ GTKFLAGS12=`gtk-config --libs`
+
+-CFLAGS= -Wall -O3 --pedantic -I./include -DDATADIR=\"$(DATADIR)\" -DINSTALL_DATA_DIR=\"$(INSTALL_DATA_DIR)\"
+-LDFLAGS= -lm -lpthread $(SOUNDFLAGS) $(GTKLIBS)
++CFLAGS+= -Wall -pedantic -I./include -DDATADIR=\"$(DATADIR)\" -DINSTALL_DATA_DIR=\"$(INSTALL_DATA_DIR)\"
++LDFLAGS+= -lm -lpthread $(SOUNDFLAGS) $(GTKLIBS)
+
+ # DEB pkg
+ #CFLAGS += `dpkg-buildflags --get CFLAGS`
+@@ -50,7 +50,7 @@ PROGRAM_SRCS=$(SRCPATH)spacezero.c $(SRC
+ all: dirs spacezero
+
+ spacezero: $(PROGRAM_OBJS)
+- $(CC) $(PROGRAM_OBJS) $(LDFLAGS) $(CFLAGS) -g -o $(PROGRAM)
++ $(CC) $(PROGRAM_OBJS) $(LDFLAGS) -o $(PROGRAM)
+
+ gtk12: $(PROGRAM_SRCS)
+ $(CC) `gtk-config --cflags` $(PROGRAM_SRCS) $(LDFLAGS12) $(CFLAGS12) -g -o $(PROGRAM) `gtk-config --libs`
+@@ -84,4 +84,4 @@ mrproper: clean
+ rm -f src/*~ include/*~
+
+ .c.o:
+- $(CC) $(CFLAGS) $(LDFLAGS) $(GTKFLAGS) -c $< -o $@
++ $(CC) $(CFLAGS) $(GTKFLAGS) -c $< -o $@
diff --git a/games/spacezero/pkg-descr b/games/spacezero/pkg-descr
new file mode 100644
index 000000000000..c3328be2432d
--- /dev/null
+++ b/games/spacezero/pkg-descr
@@ -0,0 +1,13 @@
+SpaceZero is a Real Time Strategy 2D space combat game for two
+players over a network.
+
+The objective is to conquer the universe, defeating all enemies.
+
+At starting point you have only one ship and one planet, but you
+have gold to buy more ships to conquer more planets.
+
+All ships can be controlled by the computer (automatic mode) or by
+the player (manual mode). You can easily change among your ships,
+controlling all of them independently.
+
+WWW: http://spacezero.sourceforge.net/