aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-01-31 05:04:38 +0800
committerpawel <pawel@FreeBSD.org>2014-01-31 05:04:38 +0800
commitbeded21a1ce6dc059d3f9f2c8c4e72f43022f432 (patch)
tree508e7ac626c8b080dd462c8993ad3cb58097e93c /games
parentb1ed48fd1c0d9db50ceae354a1172a7ea0e03347 (diff)
downloadfreebsd-ports-gnome-beded21a1ce6dc059d3f9f2c8c4e72f43022f432.tar.gz
freebsd-ports-gnome-beded21a1ce6dc059d3f9f2c8c4e72f43022f432.tar.zst
freebsd-ports-gnome-beded21a1ce6dc059d3f9f2c8c4e72f43022f432.zip
- Add LICENSE, desktop entry file [1]
- Convert to new options framework [1] - Fix issues reported by portlint [1] - Use PYGAME for RUN_DEPENDS - Add staging support - Unmute install commands PR: ports/185664 [1] Submitted by: Hardy Schumacher <hardy.schumacher@gmx.de> Approved by: maintainer timeout
Diffstat (limited to 'games')
-rw-r--r--games/pathological/Makefile39
-rw-r--r--games/pathological/pkg-descr2
-rw-r--r--games/pathological/pkg-plist1
3 files changed, 23 insertions, 19 deletions
diff --git a/games/pathological/Makefile b/games/pathological/Makefile
index 5eaaba9ca259..3173b4c550f2 100644
--- a/games/pathological/Makefile
+++ b/games/pathological/Makefile
@@ -3,38 +3,41 @@
PORTNAME= pathological
PORTVERSION= 1.1.3
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= games
MASTER_SITES= SF
MAINTAINER= jmohacsi@bsd.hu
COMMENT= Enriched clone of the game "Logical"
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pygame/__init__.py:${PORTSDIR}/devel/py-game
+LICENSE= GPLv2
+
+RUN_DEPENDS= ${PYGAME}
+
+OPTIONS_DEFINE= DOCS
USE_PYTHON= yes
NO_BUILD= yes
-MAN6= pathological.6
-MANCOMPRESSED= yes
DOC_FILES= favicon.ico index.html
-NO_STAGE= yes
+DESKTOP_ENTRIES="Pathological" \
+ "Logic game" \
+ "${DATADIR}/pathological.ico" \
+ "pathological" \
+ "Game;LogicGame;" \
+ false
+
do-install:
- @${MKDIR} ${DATADIR}
+ @${MKDIR} ${STAGEDIR}${DATADIR}
(cd ${WRKSRC}; tar -cf - circuits graphics music sounds pathological.ico pathological.py pathological.xpm) | \
- (cd ${DATADIR}; tar --unlink -xf -)
- @printf "#!/bin/sh\ncd ${DATADIR} && \
+ (cd ${STAGEDIR}${DATADIR}; tar --unlink -xf -)
+ @${PRINTF} "#!/bin/sh\ncd ${DATADIR} && \
exec ${PYTHON_CMD} ${DATADIR}/pathological.py\n" > ${WRKDIR}/pathological.sh
- @${INSTALL_SCRIPT} ${WRKDIR}/pathological.sh ${PREFIX}/bin/pathological
-.ifndef(NO_INSTALL_MANPAGES)
- ${INSTALL_MAN} ${WRKSRC}/${MAN6}.gz ${MAN6PREFIX}/man/man6/
-.endif
-.ifndef(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for file in ${DOC_FILES}
- @${INSTALL_DATA} ${WRKSRC}/html/${file} ${DOCSDIR}
-.endfor
-.endif
+ ${INSTALL_SCRIPT} ${WRKDIR}/pathological.sh \
+ ${STAGEDIR}${PREFIX}/bin/pathological
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.6.gz ${STAGEDIR}${MANPREFIX}/man/man6
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES:S|^|${WRKSRC}/html/|g} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/games/pathological/pkg-descr b/games/pathological/pkg-descr
index e130492528a0..592e178b23fd 100644
--- a/games/pathological/pkg-descr
+++ b/games/pathological/pkg-descr
@@ -10,4 +10,4 @@ Features
* 50 diverse and challenging levels (more to come...)
* A cool 6-minute ambient soundtrack by an award-winning musician
-WWW: http://pathological.sourceforge.net/
+WWW: http://pathological.sourceforge.net/
diff --git a/games/pathological/pkg-plist b/games/pathological/pkg-plist
index 2e8908f1c5bb..92af7b26fa0d 100644
--- a/games/pathological/pkg-plist
+++ b/games/pathological/pkg-plist
@@ -1,4 +1,5 @@
bin/pathological
+man/man6/pathological.6.gz
%%DATADIR%%/circuits/all-boards
%%DATADIR%%/graphics/backdrop.jpg
%%DATADIR%%/graphics/blank-bg-tile.png