aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2013-06-12 04:56:46 +0800
committerbsam <bsam@FreeBSD.org>2013-06-12 04:56:46 +0800
commitc358a9dc38fa78095104f1c58960da5007039486 (patch)
tree866f6466be94c14d807b229da954fdf707ce0588 /games
parent373984227e79398bb4f60482c17d058abe0e8aa5 (diff)
downloadfreebsd-ports-gnome-c358a9dc38fa78095104f1c58960da5007039486.tar.gz
freebsd-ports-gnome-c358a9dc38fa78095104f1c58960da5007039486.tar.zst
freebsd-ports-gnome-c358a9dc38fa78095104f1c58960da5007039486.zip
. fix build with clang (CFLAGS+=-Wno-return-type);
. trim Makefile headers; . NOPORTDOCS -> PORT_OPTIONS:MDOCS; . get use PLIST_FILES and PORTDOCS; . remove pkg-plist (4 lines); . ${PREFIX}/share/doc/spellcast -> ${DOCSDIR}; . use one install command instead of a .for loop.
Diffstat (limited to 'games')
-rw-r--r--games/spellcast/Makefile22
-rw-r--r--games/spellcast/pkg-plist4
2 files changed, 12 insertions, 14 deletions
diff --git a/games/spellcast/Makefile b/games/spellcast/Makefile
index 47f8db521cdd..f850d0367545 100644
--- a/games/spellcast/Makefile
+++ b/games/spellcast/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: spellcast
-# Date created: 28 June 1998
-# Whom: Andrey Zakhvatov
-#
+# Created by: Andrey Zakhvatov
# $FreeBSD$
-#
PORTNAME= spellcast
PORTVERSION= 1.2
@@ -18,15 +14,21 @@ COMMENT= Multiplayer fight with spells turn based game for X Window System
USE_XORG= x11
MAN6= spellcast.6
+PLIST_FILES= bin/spellcast
+PORTDOCS= README spelllist.ps
+
+CFLAGS+= -Wno-return-type
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/spellcast ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/spellcast.6 ${PREFIX}/man/man6
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/spellcast
-.for file in README spelllist.ps
- ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/spellcast
-.endfor
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/games/spellcast/pkg-plist b/games/spellcast/pkg-plist
deleted file mode 100644
index 74b97902d1b6..000000000000
--- a/games/spellcast/pkg-plist
+++ /dev/null
@@ -1,4 +0,0 @@
-bin/spellcast
-%%PORTDOCS%%share/doc/spellcast/README
-%%PORTDOCS%%share/doc/spellcast/spelllist.ps
-%%PORTDOCS%%@dirrm share/doc/spellcast