aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-05-07 21:12:31 +0800
committerbapt <bapt@FreeBSD.org>2013-05-07 21:12:31 +0800
commitc51dc118d16532cbb0975f6a1283f79f0f639846 (patch)
tree5522ebdbbbc41a02fbc8bf3da8fa96b3719b6d61 /games
parentd6971706dddb262040a6508b9b7e08ba636e3147 (diff)
downloadfreebsd-ports-gnome-c51dc118d16532cbb0975f6a1283f79f0f639846.tar.gz
freebsd-ports-gnome-c51dc118d16532cbb0975f6a1283f79f0f639846.tar.zst
freebsd-ports-gnome-c51dc118d16532cbb0975f6a1283f79f0f639846.zip
Add some shebangfix to allow building most of the ports tree without /usr/bin/perl
Submitted by: John Marino Obtained from: DPorts
Diffstat (limited to 'games')
-rw-r--r--games/eboard/Makefile8
-rw-r--r--games/stepmania-devel/Makefile4
2 files changed, 6 insertions, 6 deletions
diff --git a/games/eboard/Makefile b/games/eboard/Makefile
index 3048ec98d1d2..493eb660caf0 100644
--- a/games/eboard/Makefile
+++ b/games/eboard/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: eboard
-# Date created: 22 June 2001
-# Whom: petef@FreeBSD.org
-#
+# Created by: petef@FreeBSD.org
# $FreeBSD$
-#
PORTNAME= eboard
PORTVERSION= 1.1.1
@@ -23,10 +19,12 @@ COMMENT= GTK+ chess board interface (mainly for FICS and chessd)
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
EXTRAS= 1pl2 2
+USES= shebangfix
USE_BZIP2= yes
HAS_CONFIGURE= yes
USE_PERL5_BUILD=yes
USE_GNOME= gtk20
+SHEBANG_FILES= configure
CONFIGURE_ARGS= --prefix=${PREFIX} \
--extra-inc=${LOCALBASE}/include \
diff --git a/games/stepmania-devel/Makefile b/games/stepmania-devel/Makefile
index 43a18565ba9a..c42eb9dae646 100644
--- a/games/stepmania-devel/Makefile
+++ b/games/stepmania-devel/Makefile
@@ -28,13 +28,15 @@ PROJECTHOST= sm-ssc
USE_BZIP2= yes
USE_XORG= x11 xau xdmcp xext xrandr xrender xtst
USE_GL= gl glu
-USES= pathfix iconv
+USES= pathfix iconv shebangfix
USE_GNOME= gtk20
USE_PERL5_BUILD=yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-ffmpeg
INSTALLS_ICONS= yes
MAKE_JOBS_SAFE= yes
+SHEBANG_FILES= Utils/*.pl \
+ extern/zlib/zlib2ansi
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib