aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoreadler <eadler@FreeBSD.org>2013-03-19 21:04:30 +0800
committereadler <eadler@FreeBSD.org>2013-03-19 21:04:30 +0800
commitcdabc54ad469c80d08327c0d32dfa55c640cff2a (patch)
treeeba3c1f7e94497327507881e3b0eb623013d377e /games
parent3e5b766396a89930130c8530a30308b48d239d4b (diff)
downloadfreebsd-ports-gnome-cdabc54ad469c80d08327c0d32dfa55c640cff2a.tar.gz
freebsd-ports-gnome-cdabc54ad469c80d08327c0d32dfa55c640cff2a.tar.zst
freebsd-ports-gnome-cdabc54ad469c80d08327c0d32dfa55c640cff2a.zip
This changes almost all the "gnomehack" only USE_GNOME cases to USES= pathfix.
If a port used other USE_GNOME items it was untouched. The ports that used other USES were fixed by hand. PR: ports/177081 Reviewed by: bapt Approved by: portmgr (miwi)
Diffstat (limited to 'games')
-rw-r--r--games/abuse_sdl/Makefile2
-rw-r--r--games/ember/Makefile2
-rw-r--r--games/hinversi/Makefile2
-rw-r--r--games/libfov/Makefile2
-rw-r--r--games/libggz/Makefile2
5 files changed, 5 insertions, 5 deletions
diff --git a/games/abuse_sdl/Makefile b/games/abuse_sdl/Makefile
index 14a0ba40ad85..df36edc86fd5 100644
--- a/games/abuse_sdl/Makefile
+++ b/games/abuse_sdl/Makefile
@@ -13,7 +13,7 @@ COMMENT= SDL port of the Abuse game engine
LICENSE= GPLv2
-USE_GNOME= gnomehack
+USES= pathfix
USE_GL= gl
USE_SDL= mixer sdl
GNU_CONFIGURE= yes
diff --git a/games/ember/Makefile b/games/ember/Makefile
index b09d737e8ea5..407f2972d792 100644
--- a/games/ember/Makefile
+++ b/games/ember/Makefile
@@ -36,7 +36,7 @@ USE_LDCONFIG= YES
USE_LUA= 5.1
LUA_COMPS= toluaxx
USE_OPENAL= al alut
-USE_GNOME= gnomehack
+USES= pathfix
USE_BZIP2= YES
CPPFLAGS+= -DBR_NO_MACROS
MAKE_JOBS_SAFE= yes
diff --git a/games/hinversi/Makefile b/games/hinversi/Makefile
index 51f05acbf7ee..2f6c194ef6fd 100644
--- a/games/hinversi/Makefile
+++ b/games/hinversi/Makefile
@@ -18,7 +18,7 @@ OPTIONS_DEFINE= NLS
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
-USE_GNOME= gnomehack
+USES= pathfix
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
diff --git a/games/libfov/Makefile b/games/libfov/Makefile
index 268c8a284633..2ddc9f75300d 100644
--- a/games/libfov/Makefile
+++ b/games/libfov/Makefile
@@ -12,7 +12,7 @@ COMMENT= C library for calculating fields of view on low resolution rasters
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
-USE_GNOME= gnomehack
+USES= pathfix
USE_AUTOTOOLS= libtool
USE_PKGCONFIG= yes
CONFIGURE_ENV= ac_cv_prog_doxygen=no ac_cv_path_SDL_CONFIG=no
diff --git a/games/libggz/Makefile b/games/libggz/Makefile
index 105eb973de4f..72324a07823b 100644
--- a/games/libggz/Makefile
+++ b/games/libggz/Makefile
@@ -17,7 +17,7 @@ COMMENT= The GGZ Gaming Zone - Base Library
LIB_DEPENDS= gcrypt.18:${PORTSDIR}/security/libgcrypt
USE_AUTOTOOLS= libtool
-USE_GNOME= gnomehack
+USES= pathfix
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-debug
USE_LDCONFIG= yes