aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-07-20 23:33:20 +0800
committermat <mat@FreeBSD.org>2016-07-20 23:33:20 +0800
commitdb56f13ef4400c01c2a9ef2ba0e545effb4949f9 (patch)
treed74ba65fed8db0fd098d71428aebd9af6e665d09 /games
parent3152a538183a1b60ad1cc78f4daf75bf3776cbfb (diff)
downloadfreebsd-ports-gnome-db56f13ef4400c01c2a9ef2ba0e545effb4949f9.tar.gz
freebsd-ports-gnome-db56f13ef4400c01c2a9ef2ba0e545effb4949f9.tar.zst
freebsd-ports-gnome-db56f13ef4400c01c2a9ef2ba0e545effb4949f9.zip
Cleanup $() variables in ports Makefiles.
Mostly replace with ${}, but sometime, replace with $$() because it is what was intended in the first place. (I think.) Sponsored by: Absolight
Diffstat (limited to 'games')
-rw-r--r--games/blockrage/Makefile2
-rw-r--r--games/gemdropx/Makefile4
-rw-r--r--games/legend-of-edgar/Makefile2
-rw-r--r--games/miscom/Makefile2
-rw-r--r--games/netwalk/Makefile2
-rw-r--r--games/openbor/Makefile2
-rw-r--r--games/ufoai/Makefile2
-rw-r--r--games/vodovod/Makefile2
8 files changed, 9 insertions, 9 deletions
diff --git a/games/blockrage/Makefile b/games/blockrage/Makefile
index 0acc519991b4..2c19e4b2213f 100644
--- a/games/blockrage/Makefile
+++ b/games/blockrage/Makefile
@@ -37,7 +37,7 @@ post-patch:
's|prefix=/usr/local|prefix=${PREFIX}|; \
s|MYCC=gcc|MYCC?=${CC}|; \
s|-s -O2 -Wall||; \
- s|sdl-config|$(SDL_CONFIG)|; \
+ s|sdl-config|${SDL_CONFIG}|; \
s|MAKE=make|MAKE=${MAKE}|' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|gcc -s|${CC}|' \
diff --git a/games/gemdropx/Makefile b/games/gemdropx/Makefile
index ba5bb6c4e74c..a11146a7394c 100644
--- a/games/gemdropx/Makefile
+++ b/games/gemdropx/Makefile
@@ -29,10 +29,10 @@ DESKTOP_ENTRIES="Gem Drop X" "" "${PORTNAME}" \
post-patch:
@${REINPLACE_CMD} \
- -e 's|sdl-config|$(SDL_CONFIG)| ; \
+ -e 's|sdl-config|${SDL_CONFIG}| ; \
s|CC=gcc|CC?=${CC}| ; \
s|CXX=gcc|CXX?=${CC}| ; \
- s|CFLAGS=-Wall $(SDL_CFLAGS)|CFLAGS+=-w $(SDL_CFLAGS)|' \
+ s|CFLAGS=-Wall ${SDL_CFLAGS}|CFLAGS+=-w ${SDL_CFLAGS}|' \
${WRKSRC}/Makefile
@${FIND} ${WRKDIR} -name .xvpics | ${XARGS} ${RM} -rf
diff --git a/games/legend-of-edgar/Makefile b/games/legend-of-edgar/Makefile
index 69ccba1883c4..935712d29316 100644
--- a/games/legend-of-edgar/Makefile
+++ b/games/legend-of-edgar/Makefile
@@ -38,7 +38,7 @@ post-patch:
s|/share/games/edgar/|/share/edgar/|; \
s|/share/man/|/man/|; \
s|-Wall ||; \
- s|sdl-config|$(SDL_CONFIG)|; \
+ s|sdl-config|${SDL_CONFIG}|; \
s|-s ||' \
${WRKSRC}/makefile
@${REINPLACE_CMD} -e 's|SDL/SDL|${LOCALBASE}/include/SDL/SDL|g' \
diff --git a/games/miscom/Makefile b/games/miscom/Makefile
index a905dc3753aa..b783c274d841 100644
--- a/games/miscom/Makefile
+++ b/games/miscom/Makefile
@@ -30,7 +30,7 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386"
-CFLAGS+= -DSOUNDSDIR='\"$(DATADIR)\"' -DSOUND_SUPPORT -DMORE_SOUNDBUF
+CFLAGS+= -DSOUNDSDIR='\"${DATADIR}\"' -DSOUND_SUPPORT -DMORE_SOUNDBUF
.endif
do-install:
diff --git a/games/netwalk/Makefile b/games/netwalk/Makefile
index 00fe1737c256..1bfaa7781f84 100644
--- a/games/netwalk/Makefile
+++ b/games/netwalk/Makefile
@@ -35,7 +35,7 @@ post-patch:
@${REINPLACE_CMD} -e \
's|CC = gcc|CC = ${CC}|; \
s|CFLAGS=-Wall -O2 -fomit-frame-pointer|CFLAGS+= -fomit-frame-pointer|; \
- s|sdl-config|$(SDL_CONFIG)|; \
+ s|sdl-config|${SDL_CONFIG}|; \
s|PREFIX = /usr|PREFIX = ${PREFIX}|' \
${WRKSRC}/Makefile
diff --git a/games/openbor/Makefile b/games/openbor/Makefile
index ad25f2e31226..2d037ccd11ae 100644
--- a/games/openbor/Makefile
+++ b/games/openbor/Makefile
@@ -21,7 +21,7 @@ MAKE_ENV= BUILD_LINUX=1 SDKPATH="${LOCALBASE}" \
GCC_TARGET="${CONFIGURE_TARGET:S/amd64/x86_64/}"
MAKE_ARGS= CC="${CC}" LIBRARIES="${LOCALBASE}/lib" \
TARGET_ARCH=${ARCH:S/i386/x86/} ARCHFLAGS="" \
- TARGET_FINAL='$(TARGET)' BUILD_MMX=""
+ TARGET_FINAL='${TARGET}' BUILD_MMX=""
LDFLAGS+= -Wl,--as-needed
PLIST_FILES= bin/${PORTNAME} \
share/pixmaps/${PORTNAME}.png
diff --git a/games/ufoai/Makefile b/games/ufoai/Makefile
index 20f604ac7856..097234a23e8b 100644
--- a/games/ufoai/Makefile
+++ b/games/ufoai/Makefile
@@ -97,7 +97,7 @@ post-extract:
post-build:
@cd ${WRKSRC} && ${MAKE_CMD} lang
-.if $(PORT_OPTIONS:MUFORADIANT)
+.if ${PORT_OPTIONS:MUFORADIANT}
@cd ${WRKSRC} && ${MAKE_CMD} uforadiant
.endif
diff --git a/games/vodovod/Makefile b/games/vodovod/Makefile
index ab66352bd53f..8ab97147e308 100644
--- a/games/vodovod/Makefile
+++ b/games/vodovod/Makefile
@@ -42,7 +42,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|PREFIX=/usr|PREFIX=${PREFIX}|' \
-e 's|CC = g++|CC ?= g++|' \
-e 's|CC|CXX|' \
- -e 's|sdl-config|$(SDL_CONFIG)|' \
+ -e 's|sdl-config|${SDL_CONFIG}|' \
-e '/^MY_CFLAGS/ s| = | = ${CXXFLAGS} |' \
${WRKSRC}/Makefile