aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-09-02 06:55:05 +0800
committerbapt <bapt@FreeBSD.org>2013-09-02 06:55:05 +0800
commitdbb49b695b9e069e7cc2cfbdd12f9f79e33780f4 (patch)
tree9ca28fc93c9e5eefd66428678bd8d534fbd1fd88 /games
parent895c8f14a6571e71764559bbba287fcfa0fbff35 (diff)
downloadfreebsd-ports-gnome-dbb49b695b9e069e7cc2cfbdd12f9f79e33780f4.tar.gz
freebsd-ports-gnome-dbb49b695b9e069e7cc2cfbdd12f9f79e33780f4.tar.zst
freebsd-ports-gnome-dbb49b695b9e069e7cc2cfbdd12f9f79e33780f4.zip
Eradiracte USE_GNOME=pkgconfig from games
While here: Convert USE_GMAKE to USES=gmake
Diffstat (limited to 'games')
-rw-r--r--games/openttd/Makefile2
-rw-r--r--games/ufoai/Makefile6
2 files changed, 3 insertions, 5 deletions
diff --git a/games/openttd/Makefile b/games/openttd/Makefile
index 8268e527f667..98cdb2f3c6b2 100644
--- a/games/openttd/Makefile
+++ b/games/openttd/Makefile
@@ -47,7 +47,7 @@ CONFIGURE_ARGS+= --with-midi-arg="${WITH_MIDI_PLAYER_ARGS}"
.endif
.if defined(WITH_DEDICATED_SERVER_ONLY)
-USE_GNOME= pkgconfig # Needed for liblzma support
+USES+= pkgconfig # Needed for liblzma support
CONFIGURE_ARGS+= --enable-dedicated
# Aid it to find lzo2 headers; client build gets it via sdl-config
CFLAGS+= -I${LOCALBASE}/include
diff --git a/games/ufoai/Makefile b/games/ufoai/Makefile
index 3d3d38776e4b..0dfab6e0e654 100644
--- a/games/ufoai/Makefile
+++ b/games/ufoai/Makefile
@@ -1,4 +1,4 @@
-# Created by: Alonso Cardenas Marquez <acm@FreeBSD.org>
+# Created by: Alonso Cardenas Marquez <acm@FreeBSD.org>
# $FreeBSD$
PORTNAME= ufoai
@@ -25,9 +25,7 @@ RUN_DEPENDS= ${LOCALBASE}/share/${PORTNAME}/base/default.cfg:${PORTSDIR}/games/u
USE_BZIP2= yes
USE_GL= yes
USE_SDL= sdl image mixer ttf
-USES= gettext
-USE_GMAKE= yes
-USE_GNOME= pkgconfig
+USES= gettext gmake pkgconfig
USE_OPENAL= soft
HAS_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-release