aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2018-01-19 22:11:13 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 06:26:21 +0800
commite18d15dcee3c6582d5e523f0ae8bb929893efc1a (patch)
tree47bf1cb41b12a3991e81d6d4f20c1ca435b51a40 /games
parentb34ae1e7c330a31c22419e3a5da407a70c30d565 (diff)
downloadfreebsd-ports-gnome-e18d15dcee3c6582d5e523f0ae8bb929893efc1a.tar.gz
freebsd-ports-gnome-e18d15dcee3c6582d5e523f0ae8bb929893efc1a.tar.zst
freebsd-ports-gnome-e18d15dcee3c6582d5e523f0ae8bb929893efc1a.zip
- Remove BROKEN_sparc64 that was originally added in r239630 by linimon@
8.5 years ago for version 4.2.7; current version (4.9.1) installs fine - Correctly set FOO_RUN_DEPENDS knobs and add some readability linefeeds
Diffstat (limited to 'games')
-rw-r--r--games/xboard/Makefile22
1 files changed, 11 insertions, 11 deletions
diff --git a/games/xboard/Makefile b/games/xboard/Makefile
index a32ff684883a..ee50b4ab237d 100644
--- a/games/xboard/Makefile
+++ b/games/xboard/Makefile
@@ -26,6 +26,7 @@ OPTIONS_RADIO?= SOUND
OPTIONS_RADIO_SOUND?= SOX ALSA
OPTIONS_DEFAULT?= XAW
OPTIONS_SUB?= yes
+
ZIPPY_DESC= Add Zippy capability (computer player on ICS)
ENGINES_DESC= Chess Engines
CRAFTY_DESC= Install crafty engine
@@ -37,16 +38,17 @@ FRONTEND_DESC= Front End
XAW_DESC= Xaw GUI toolkit support (default)
XAW3D_DESC= Xaw3d GUI toolkit support (not fully supported)
GTK2_DESC= GTK+ 2 GUI toolkit support (experimental)
-SOUND_DESC= Sound Output (optional)
+SOUND_DESC= Sound output (optional)
SOX_DESC= SoX audio support
-CRAFTY_RUN_DEPENDS+= crafty:games/crafty
-FAIRYMAX_RUN_DEPENDS+= fairymax:games/fairymax
-GNUCHESS_RUN_DEPENDS+= gnuchess:games/gnuchess
-KNIGHTCAP_RUN_DEPENDS+= KnightCap:games/KnightCap
-PHALANX_RUN_DEPENDS+= phalanx:games/phalanx
-XAW3D_DEPENDS+= libXaw3d.so:x11-toolkits/Xaw3d
-SOX_RUN_DEPENDS+= play:audio/sox
-ALSA_RUN_DEPENDS+= aplay:audio/alsa-utils
+
+CRAFTY_RUN_DEPENDS= crafty:games/crafty
+FAIRYMAX_RUN_DEPENDS= fairymax:games/fairymax
+GNUCHESS_RUN_DEPENDS= gnuchess:games/gnuchess
+KNIGHTCAP_RUN_DEPENDS= KnightCap:games/KnightCap
+PHALANX_RUN_DEPENDS= phalanx:games/phalanx
+XAW3D_DEPENDS= libXaw3d.so:x11-toolkits/Xaw3d
+SOX_RUN_DEPENDS= play:audio/sox
+ALSA_RUN_DEPENDS= aplay:audio/alsa-utils
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
ZIPPY_CONFIGURE_ENABLE= zippy
@@ -80,8 +82,6 @@ XBOARDCONF?= ${WRKSRC}/xboard.conf
PORTDOCS= AUTHORS COPYING COPYRIGHT ChangeLog DIFFSTAT FAQ.html NEWS README SHORTLOG TODO
-BROKEN_sparc64= Does not install on sparc64
-
.if ${PORT_OPTIONS:MZIPPY}
USES+= shebangfix
SHEBANG_FILES+= ./texi2man