aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-08-07 21:20:32 +0800
committeraz <az@FreeBSD.org>2013-08-07 21:20:32 +0800
commite1d59bae7d278db3d48c3da263eeed5ffe98e3bf (patch)
tree1d8dce4b39a3357f2e6741d55cb1b9a1fa54d346 /games
parent55cd13e4e11d36f2ede96fa048ad85d6e02b2ba1 (diff)
downloadfreebsd-ports-gnome-e1d59bae7d278db3d48c3da263eeed5ffe98e3bf.tar.gz
freebsd-ports-gnome-e1d59bae7d278db3d48c3da263eeed5ffe98e3bf.tar.zst
freebsd-ports-gnome-e1d59bae7d278db3d48c3da263eeed5ffe98e3bf.zip
- Convert to new perl framework
per port extra changes: devel/p5-Perl-Version remove outage PERL_LEVEL check devel/p5-Devel-LeakTrace-Fast remove perl version requiment 5.12.0- (no need in current version) Approved by: lth@ (maintainer)
Diffstat (limited to 'games')
-rw-r--r--games/p5-Games-Bingo-Bot/Makefile3
-rw-r--r--games/p5-Games-Bingo-Print/Makefile3
-rw-r--r--games/p5-Games-Bingo/Makefile3
3 files changed, 6 insertions, 3 deletions
diff --git a/games/p5-Games-Bingo-Bot/Makefile b/games/p5-Games-Bingo-Bot/Makefile
index 0b7bbc1f68fc..494ea00e056d 100644
--- a/games/p5-Games-Bingo-Bot/Makefile
+++ b/games/p5-Games-Bingo-Bot/Makefile
@@ -17,7 +17,8 @@ COMMENT= A simple class holding IRC related methods for bingo
BUILD_DEPENDS= p5-Games-Bingo>=0:${PORTSDIR}/games/p5-Games-Bingo
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Games::Bingo::Bot.3
diff --git a/games/p5-Games-Bingo-Print/Makefile b/games/p5-Games-Bingo-Print/Makefile
index 8d5c56d41359..d5fb47275eff 100644
--- a/games/p5-Games-Bingo-Print/Makefile
+++ b/games/p5-Games-Bingo-Print/Makefile
@@ -23,7 +23,8 @@ BUILD_DEPENDS= p5-Games-Bingo>=0:${PORTSDIR}/games/p5-Games-Bingo \
p5-Test-Pod-Coverage>=0:${PORTSDIR}/devel/p5-Test-Pod-Coverage
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= bingo_print.pl.1
MAN3= Games::Bingo::Print.3
diff --git a/games/p5-Games-Bingo/Makefile b/games/p5-Games-Bingo/Makefile
index 8d4347c33413..60a4021d450e 100644
--- a/games/p5-Games-Bingo/Makefile
+++ b/games/p5-Games-Bingo/Makefile
@@ -10,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= A bingo game Perl implementation
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN1= bingo.pl.1
MAN3= Games::Bingo.3 \