aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2013-10-02 05:13:17 +0800
committermarino <marino@FreeBSD.org>2013-10-02 05:13:17 +0800
commite2e32fe0d4a9bc0a8dd8f8c305be6f676189589f (patch)
tree9929f120f419350b523a231bd0358c05bdbd0376 /games
parent968249e75cd09da4a04fc643df06ba7e3e7072f7 (diff)
downloadfreebsd-ports-gnome-e2e32fe0d4a9bc0a8dd8f8c305be6f676189589f.tar.gz
freebsd-ports-gnome-e2e32fe0d4a9bc0a8dd8f8c305be6f676189589f.tar.zst
freebsd-ports-gnome-e2e32fe0d4a9bc0a8dd8f8c305be6f676189589f.zip
games/brutalchess: add <unistd.h> for modern compilers
USE_DOS2UNIX was required in order to create and apply the patch. Approved by: portmgr (bapt, implicit)
Diffstat (limited to 'games')
-rw-r--r--games/brutalchess/Makefile2
-rw-r--r--games/brutalchess/files/patch-src_board.h10
2 files changed, 11 insertions, 1 deletions
diff --git a/games/brutalchess/Makefile b/games/brutalchess/Makefile
index 5f720d64a258..f8797f1dca54 100644
--- a/games/brutalchess/Makefile
+++ b/games/brutalchess/Makefile
@@ -18,7 +18,7 @@ USE_XORG= x11 xext xt xmu xi
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
-
+USE_DOS2UNIX= yes
USE_GL= yes
USE_SDL= sdl image
diff --git a/games/brutalchess/files/patch-src_board.h b/games/brutalchess/files/patch-src_board.h
new file mode 100644
index 000000000000..857147f510cb
--- /dev/null
+++ b/games/brutalchess/files/patch-src_board.h
@@ -0,0 +1,10 @@
+--- src/board.h.orig 2013-10-01 21:08:24.000000000 +0000
++++ src/board.h
+@@ -12,6 +12,7 @@
+ #include <cstdio>
+ #include <iostream>
+ #include <vector>
++#include <unistd.h>
+
+ #include "bitboard.h"
+ #include "boardmove.h"