aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2013-08-03 02:52:07 +0800
committermat <mat@FreeBSD.org>2013-08-03 02:52:07 +0800
commitf47f83f9c8923b3b0f740482331aab0d0aa669e9 (patch)
treea4a613f80a0e443c044c2319e43ce75e14c50813 /games
parent16bdaae92136c316b9043fffbf5fb4438dce004e (diff)
downloadfreebsd-ports-gnome-f47f83f9c8923b3b0f740482331aab0d0aa669e9.tar.gz
freebsd-ports-gnome-f47f83f9c8923b3b0f740482331aab0d0aa669e9.tar.zst
freebsd-ports-gnome-f47f83f9c8923b3b0f740482331aab0d0aa669e9.zip
- Convert to new perl framework
- Trim Makefile header - Remove MAKE_JOBS_SAFE=yes, it's the default.
Diffstat (limited to 'games')
-rw-r--r--games/p5-Acme-GuessNumber/Makefile3
-rw-r--r--games/p5-Baseball-Sabermetrics/Makefile3
-rw-r--r--games/p5-Games-Alak/Makefile9
-rw-r--r--games/p5-Games-Tournament-RoundRobin/Makefile9
4 files changed, 10 insertions, 14 deletions
diff --git a/games/p5-Acme-GuessNumber/Makefile b/games/p5-Acme-GuessNumber/Makefile
index a32f03c88900..83e8f3acb2b3 100644
--- a/games/p5-Acme-GuessNumber/Makefile
+++ b/games/p5-Acme-GuessNumber/Makefile
@@ -11,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Automatic number guessing game robot
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Acme::GuessNumber.3
PLIST_FILES= %%SITE_PERL%%/Acme/GuessNumber.pm \
diff --git a/games/p5-Baseball-Sabermetrics/Makefile b/games/p5-Baseball-Sabermetrics/Makefile
index ffa8c15397c5..0c7e3a7657de 100644
--- a/games/p5-Baseball-Sabermetrics/Makefile
+++ b/games/p5-Baseball-Sabermetrics/Makefile
@@ -15,7 +15,8 @@ BUILD_DEPENDS= p5-Data-Serializer>=0.29:${PORTSDIR}/devel/p5-Data-Serializer \
p5-libwww>=5.801:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Baseball::Sabermetrics.3
diff --git a/games/p5-Games-Alak/Makefile b/games/p5-Games-Alak/Makefile
index 50371d615bfb..b0803d644d81 100644
--- a/games/p5-Games-Alak/Makefile
+++ b/games/p5-Games-Alak/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Games-Alak
-# Date created: 2006-08-28
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= Games-Alak
PORTVERSION= 0.19
@@ -17,7 +13,8 @@ COMMENT= Simple game-tree implementation of a gomoku-like game
TEST_DEPENDS= p5-Test-Pod>=0:${PORTSDIR}/devel/p5-Test-Pod \
p5-Test-Pod-Coverage>=0:${PORTSDIR}/devel/p5-Test-Pod-Coverage
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Games::Alak.3
diff --git a/games/p5-Games-Tournament-RoundRobin/Makefile b/games/p5-Games-Tournament-RoundRobin/Makefile
index 6878df58d479..85b981de392f 100644
--- a/games/p5-Games-Tournament-RoundRobin/Makefile
+++ b/games/p5-Games-Tournament-RoundRobin/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Games-Tournament-RoundRobin
-# Date created: 18 Feb 2006
-# Whom: Aaron Dalton <aaron@FreeBSD.org>
-#
+# Created by: Aaron Dalton <aaron@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Games-Tournament-RoundRobin
PORTVERSION= 0.02
@@ -17,6 +13,7 @@ COMMENT= Round-Robin Tournament Schedule Pairings
MAN3= Games::Tournament::RoundRobin.3 \
Games::League::Member.3
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>