aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2008-09-16 02:10:26 +0800
committergahr <gahr@FreeBSD.org>2008-09-16 02:10:26 +0800
commitf85dbba08ee39496fc2dbe295461389c8c229981 (patch)
tree80c420be3ecdadda3f9de3f6770c301b8526d508 /games
parent40b3c06af029a7dd2c99e913f5c62ab6f1fb3205 (diff)
downloadfreebsd-ports-gnome-f85dbba08ee39496fc2dbe295461389c8c229981.tar.gz
freebsd-ports-gnome-f85dbba08ee39496fc2dbe295461389c8c229981.tar.zst
freebsd-ports-gnome-f85dbba08ee39496fc2dbe295461389c8c229981.zip
- Fix build on 64-bits platforms
- UNBREAK on amd64, GCC4.2 Approved by: portmgr (erwin)
Diffstat (limited to 'games')
-rw-r--r--games/znibbles/Makefile8
-rw-r--r--games/znibbles/files/patch-src::GTK::Menus.C11
2 files changed, 12 insertions, 7 deletions
diff --git a/games/znibbles/Makefile b/games/znibbles/Makefile
index 348be34d86db..c9c9c70efa8b 100644
--- a/games/znibbles/Makefile
+++ b/games/znibbles/Makefile
@@ -22,10 +22,4 @@ CONFIGURE_ARGS= --without-motif \
MAN6= nibbles.6 znibbles.6 gznibbles.6 znibblesX.6
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042 && ${ARCH} == amd64
-BROKEN= does not compile
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/znibbles/files/patch-src::GTK::Menus.C b/games/znibbles/files/patch-src::GTK::Menus.C
new file mode 100644
index 000000000000..3ea74f6315f0
--- /dev/null
+++ b/games/znibbles/files/patch-src::GTK::Menus.C
@@ -0,0 +1,11 @@
+--- src/GTK/Menus.C.orig 2008-09-15 17:23:52.000000000 +0000
++++ src/GTK/Menus.C 2008-09-15 17:25:14.000000000 +0000
+@@ -61,7 +61,7 @@
+ // Obligatory basic callback
+ void Menus::menu_callback_static(gpointer data, gpointer action, GtkWidget *w) {
+
+- switch((gint) action) {
++ switch((gulong)action) {
+ case ItemFileOther:
+ Menus::_interface->activate_other_player();
+ gtk_widget_set_sensitive(w, FALSE);