aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2013-10-10 07:12:05 +0800
committermadpilot <madpilot@FreeBSD.org>2013-10-10 07:12:05 +0800
commitf97bb3f392e3e35eb197c15fccecfc837d4ee807 (patch)
tree84e71fb242fb98bb6a21adee0d812bf7e585d5f6 /games
parent3c2aec821e22ba5f6e9d0fe13c9bcaadc16d798c (diff)
downloadfreebsd-ports-gnome-f97bb3f392e3e35eb197c15fccecfc837d4ee807.tar.gz
freebsd-ports-gnome-f97bb3f392e3e35eb197c15fccecfc837d4ee807.tar.zst
freebsd-ports-gnome-f97bb3f392e3e35eb197c15fccecfc837d4ee807.zip
- Convert to USES=compiler
Diffstat (limited to 'games')
-rw-r--r--games/corsix-th/Makefile13
1 files changed, 3 insertions, 10 deletions
diff --git a/games/corsix-th/Makefile b/games/corsix-th/Makefile
index 809ca2e37845..015c2c2337a5 100644
--- a/games/corsix-th/Makefile
+++ b/games/corsix-th/Makefile
@@ -16,7 +16,7 @@ LICENSE= MIT
LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
-USES= cmake pkgconfig
+USES= cmake compiler:c++11-lang pkgconfig
USE_LUA= yes
USE_SDL= mixer
USE_DOS2UNIX= CMake/FindFFmpeg.cmake \
@@ -33,15 +33,8 @@ MOVIES_LIB_DEPENDS= libswresample1.so:${PORTSDIR}/multimedia/ffmpeg1
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MMOVIES}
-# partly copied from editors/libreoffice
-.if exists(/usr/bin/clang) && ${OSVERSION} > 900014
-CC= /usr/bin/clang
-CPP= /usr/bin/clang-cpp
-CXX= /usr/bin/clang++
-.else
-USE_GCC= yes
-.endif
+.if ${PORT_OPTIONS:MMOVIES} && ${OSVERSION} < 900014
+FAVORITE_COMPILER= gcc
.endif
post-patch: