aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-10-20 17:06:53 +0800
committermarino <marino@FreeBSD.org>2014-10-20 17:06:53 +0800
commit028382a56c30dfab2894ae2caac913734f1e99fe (patch)
tree85961d462c6702b813f77cefc5efebd7c1e83fb0 /games
parent85d22699683aa275c308c5d5f4c5eaafae20bff7 (diff)
downloadfreebsd-ports-gnome-028382a56c30dfab2894ae2caac913734f1e99fe.tar.gz
freebsd-ports-gnome-028382a56c30dfab2894ae2caac913734f1e99fe.tar.zst
freebsd-ports-gnome-028382a56c30dfab2894ae2caac913734f1e99fe.zip
games/warsow: Add USES=alias plus...
While adding USES=alias to warsow under blanket permission, I decided to bring in other changes from DPorts: * define LDFLAGS=-L${LOCALBASE}/lib (required for compilers that don't search /usr/local/lib by default) * Only change x86_64 arch if the OPSYS is FreeBSD. Doing this breaks DragonFly The total sum of these changes for FreeBSD is no-op.
Diffstat (limited to 'games')
-rw-r--r--games/warsow/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/games/warsow/Makefile b/games/warsow/Makefile
index eeeb8fd9371f..5fe3309d0dff 100644
--- a/games/warsow/Makefile
+++ b/games/warsow/Makefile
@@ -18,12 +18,13 @@ RUN_DEPENDS= ${DATADIR}/basewsw/data1_15.pk3:${PORTSDIR}/games/warsow-data
ONLY_FOR_ARCHS= i386 amd64
-USES= gmake compiler:c++11-lang
+USES= alias gmake compiler:c++11-lang
WRKSRC= ${WRKDIR}/source/source
ALL_TARGET= game angelwrap
RELEASEDIR= ${WRKSRC}/release
AS_SDK_DIR= ${WRKSRC}/../libsrcs/angelscript/sdk
+LDFLAGS= -L${LOCALBASE}/lib
PORTDATA= *
PORTDOCS= *.rtf *.doc sourcecode_quickstart.txt
@@ -111,6 +112,10 @@ ALL_TARGET+= tv_server
PLIST_FILES+= bin/wswtv_server
.endif
+.if ${OPSYS} == FreeBSD
+SWAPARCH= s/x86_64/amd64/
+.endif
+
post-patch: .SILENT
# Unmute build and link commands, respect CFLAGS
${REINPLACE_CMD} -e 's|@$$(DO_CC|$$(DO_CC| ; /> Linking $$@/d ; \
@@ -118,7 +123,7 @@ post-patch: .SILENT
s| -msse2||' \
${WRKSRC}/Makefile
# Adjust architecture names, get rid of ``freebsd_'' prefix
- ${REINPLACE_CMD} -e 's/x86_64/amd64/ ; s/freebsd_//' \
+ ${REINPLACE_CMD} -e 's/freebsd_//; ${SWAPARCH}' \
${WRKSRC}/gameshared/q_arch.h
# Search directory provided by warsow-data port instead of current (doing
# so allows us not to install any wrapper scripts)