aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-07-15 20:02:49 +0800
committerijliao <ijliao@FreeBSD.org>2002-07-15 20:02:49 +0800
commit0357242ebbc7c6ada234622c0bec499c318e2d3e (patch)
tree390a0aa182f5a1d577a1a33877ea8c1e1d037f74 /games
parent30bceeea4c4f7dbee3712c9a1ebd333f7f3b2cc3 (diff)
downloadfreebsd-ports-gnome-0357242ebbc7c6ada234622c0bec499c318e2d3e.tar.gz
freebsd-ports-gnome-0357242ebbc7c6ada234622c0bec499c318e2d3e.tar.zst
freebsd-ports-gnome-0357242ebbc7c6ada234622c0bec499c318e2d3e.zip
add nInvaders 0.0.8
The nIvaders game is a Space Invaders clone for ncurses PR: 40413 Submitted by: Michael L. Hostbaek <mich@freebsdcluster.org>
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/nInvaders/Makefile32
-rw-r--r--games/nInvaders/distinfo1
-rw-r--r--games/nInvaders/pkg-comment1
-rw-r--r--games/nInvaders/pkg-descr6
-rw-r--r--games/nInvaders/pkg-plist3
6 files changed, 44 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 8b90d66ecfea..8d426644e375 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -182,6 +182,7 @@
SUBDIR += miscom
SUBDIR += myth2_demo
SUBDIR += mythserver
+ SUBDIR += nInvaders
SUBDIR += nadar
SUBDIR += nethack32
SUBDIR += nethack33
diff --git a/games/nInvaders/Makefile b/games/nInvaders/Makefile
new file mode 100644
index 000000000000..40704f00ccfb
--- /dev/null
+++ b/games/nInvaders/Makefile
@@ -0,0 +1,32 @@
+# ex:ts=8
+# Ports collection makefile for: nInvaders
+# Date created: Tue Jul 09, 2002
+# Whom: Michael L. Hostbaek (mich@freebsdcluster.org)
+#
+# $FreeBSD$
+#
+
+PORTNAME= nInvaders
+PORTVERSION= 0.0.8
+CATEGORIES= games
+MASTER_SITES= http://dettus.dyndns.org/ninvaders/
+DISTNAME= ${PORTNAME}${PORTVERSION}
+
+MAINTAINER= mich@freebsdcluster.org
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|^CC|#CC|g" \
+ -e "s|^CFLAGS|#CFLAGS|g" ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/nInvaders/distinfo b/games/nInvaders/distinfo
new file mode 100644
index 000000000000..1afb570f8f77
--- /dev/null
+++ b/games/nInvaders/distinfo
@@ -0,0 +1 @@
+MD5 (nInvaders0.0.8.tar.gz) = f8972561fd0574e0a9d68eeb03e49d4c
diff --git a/games/nInvaders/pkg-comment b/games/nInvaders/pkg-comment
new file mode 100644
index 000000000000..c9e75a168099
--- /dev/null
+++ b/games/nInvaders/pkg-comment
@@ -0,0 +1 @@
+The nIvaders game is a Space Invaders clone for ncurses
diff --git a/games/nInvaders/pkg-descr b/games/nInvaders/pkg-descr
new file mode 100644
index 000000000000..a672227bf014
--- /dev/null
+++ b/games/nInvaders/pkg-descr
@@ -0,0 +1,6 @@
+A ncurses version of the classic Space Invaders game.
+
+WWW: http://dettus.dyndns.org/ninvaders/
+
+ Michael L. Hostbaek
+ mich@freebsdcluster.org
diff --git a/games/nInvaders/pkg-plist b/games/nInvaders/pkg-plist
new file mode 100644
index 000000000000..a41597aab124
--- /dev/null
+++ b/games/nInvaders/pkg-plist
@@ -0,0 +1,3 @@
+bin/nInvaders
+%%PORTDOCS%%share/doc/nInvaders/README
+%%PORTDOCS%%@dirrm share/doc/nInvaders