aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormph <mph@FreeBSD.org>1999-05-24 04:43:27 +0800
committermph <mph@FreeBSD.org>1999-05-24 04:43:27 +0800
commit05e11901a6dad460e7ac00d2d702d5e07e46ee7e (patch)
tree060344bedd6801529b8d476beb2fa0290d223e19 /games
parentbdcdef9ae84eab32e82c38618b28735756c4d35a (diff)
downloadfreebsd-ports-gnome-05e11901a6dad460e7ac00d2d702d5e07e46ee7e.tar.gz
freebsd-ports-gnome-05e11901a6dad460e7ac00d2d702d5e07e46ee7e.tar.zst
freebsd-ports-gnome-05e11901a6dad460e7ac00d2d702d5e07e46ee7e.zip
Install and package documentation more correctly.
Diffstat (limited to 'games')
-rw-r--r--games/inform/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/games/inform/Makefile b/games/inform/Makefile
index d5720b475eef..e5541a1cfadf 100644
--- a/games/inform/Makefile
+++ b/games/inform/Makefile
@@ -3,7 +3,7 @@
# Date created: 28 June 1998
# Whom: Matthew Hunt <mph@FreeBSD.org>
#
-# $Id: Makefile,v 1.5 1999/05/02 19:11:30 mharo Exp $
+# $Id: Makefile,v 1.6 1999/05/02 21:10:44 mph Exp $
#
DISTNAME= inform-6.21
@@ -45,19 +45,21 @@ post-extract:
post-install:
@${MKDIR} ${PREFIX}/share/inform
@(cd ${PREFIX}/share/inform && \
- unzip -qq ${DISTDIR}/${DIST_SUBDIR}/inform_library69.zip)
+ unzip -qq -o ${DISTDIR}/${DIST_SUBDIR}/inform_library69.zip)
.for file in English Grammar Parser Verblib infix linklpa linklv parserm \
verblibm
@${MV} ${PREFIX}/share/inform/${file} ${PREFIX}/share/inform/${file}.h
@ chmod ${SHAREMODE} ${PREFIX}/share/inform/${file}.h
@ chown ${SHAREOWN}:${SHAREGRP} ${PREFIX}/share/inform/${file}.h
.endfor
- @${LN} -s Verblib.h ${PREFIX}/share/inform/VerbLib.h
+ @${LN} -fs Verblib.h ${PREFIX}/share/inform/VerbLib.h
@ chown ${SHAREOWN}:${SHAREGRP} ${PREFIX}/share/inform/VerbLib.h
.if !defined(NOPORTDOCS)
- @ (umask 222 && unzip -qq -d ${PREFIX}/share/doc \
+ @ (umask 222 && unzip -qq -o -d ${PREFIX}/share/doc \
${DISTDIR}/${DIST_SUBDIR}/designers_manual_html.zip)
- @${MV} ${PREFIX}/share/doc/dman ${PREFIX}/share/doc/inform
+ @${MKDIR} ${PREFIX}/share/doc/inform
+ @${MV} ${PREFIX}/share/doc/dman/* ${PREFIX}/share/doc/inform
+ @${RMDIR} ${PREFIX}/share/doc/dman
@ chown -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/share/doc/inform
.endif